[Closed] custom permalinks plugin

Home Support English Support [Closed] custom permalinks plugin

This topic contains 36 replies, has 5 voices, and was last updated by  andreas.n 1 year, 7 months ago. The support staff assigned to this topic is andreas.n.

Author Posts
Author Posts
December 23, 2012 at 11:34 pm #92904

Georgios

hi! i just bought wpml and i must say its the most pro solution for translating wp
but unfortunately i use custom permalinks plugin (which is critical for me)
and i noticed that when i create the translated post then if i switch to the other language it gives 404 it ads the en even to the default page
example
original url mysite/post
wpml url mysite/en/postenglish
after switching mysite/en/post which gives 404
any help?

December 24, 2012 at 6:02 am #92914

Harshad
Forum moderator

Dear Georgios,

I am not familiar with that plugin but we have a program here
http://wpml.org/documentation/theme-compatibility/go-global-program/

Where we work with plugin authors to work out the compatibility issues.
Would you like to interest you plugin author in it?

We are ready to join forces with him and work together to solve this compatibility problem.

Please contact the author and ask him if he is ready to work with us. If he do, please provide us with his contact details and we will do the rest.

Thank you

December 24, 2012 at 7:44 am #92936

Georgios

thanks i informed the author in the meantime as you can see here
http://www.netboy.pl/2011/01/buildin-permalinks-with-wpml-and-custom-permalinks-plugin/
it says "The plugin works together with WPML, but is not fully functional. You can take full advantage of the plugin by editing URLs of posts & pages in the primary language of your site – usually english. For posts and pages in additional languages the best you can do is to edit the “wp_post” MySQL table and change the value in the “post_name” column to what you want to appear in the URL. I recommend phpmyadmin or Sequel Pro on Mac for doing it.

The Custom Permalinks plugin stores custom URLs in “wp_postmeta” table and WPML doesn’t understand that.

Also make sure that post names that you set in the “wp_post” table are unique.

At the time of writing this post I am using:

"
maybe i could solve it somehow??
or maybe using another permalink plugin…?

December 24, 2012 at 10:20 am #92959

Harshad
Forum moderator

Dear Georgios,

I have downloaded the custom permlainks plugin from
http://wordpress.org/extend/plugins/custom-permalinks/

I have modified the plugin to make it work with WPML, I have sent you a mail with modified file attached.

Please download the attached file and upload it to /plugins/custom-permalinks folder.

Let me know if it works.

December 24, 2012 at 10:32 am #92961

Georgios

thanks for excellent support!!
i will give it a try and i will inform you!!!

December 24, 2012 at 1:51 pm #92996

Georgios

unfortunately it does not works
it breaks the plugin
also i tried several plugin and all do not work with wpml
after going to translated page when i try to go to the original language it adds the en to the original url and gives the 404
(en is my second language)
i tried all permalink setting none of them work
something causing wpml to add the en (or fr or it any language ) to the original post too

December 24, 2012 at 3:12 pm #93000

Harshad
Forum moderator

Dear Georgios,

Can you revert back all custom permalinks from tools -> custom permalinks and give another try?

December 24, 2012 at 4:39 pm #93006

Georgios

If I revert it works but if I enable custom it does not work again.
Did I did it right?

December 25, 2012 at 5:53 am #93019

Harshad
Forum moderator

Okay, I will check this with our development team, If this can be easily worked out.

December 25, 2012 at 11:41 am #93032

Georgios

Thanks I really apreciate!Apart of me, 5 of my friends are waiting to purchase wpml for their sites and they all use custom permalinks!

December 26, 2012 at 3:03 pm #93151

Georgios

maybe this detail can help developers
the original permalink does not break it is ok the problem is after you try to switch to the original language with the language switcher
it adds the 'en' to the original (default language url) and gives the error

December 26, 2012 at 9:06 pm #93190

Georgios

also i cannot select Translate by WPML it drives me back to Translate using .mo files which also does not work. in localhost i have exactly the same theme (same version) and everything works fine (except from the first problem ofcourse)
in my site i have the above problem (adding en ) and also these problems.

December 27, 2012 at 5:37 am #93207

Harshad
Forum moderator

Can you please enable a PHP error log file and check what's there?

From this page:
http://wpml.org/documentation/support/debugging-wpml/

Edit your wp-config.php file and add these lines, just before it says 'stop editing here':

ini_set('log_errors',TRUE);
ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . '/error_log.txt');

This will create an error_log.txt file in your site's root directory. Let's see what it includes.

December 27, 2012 at 7:54 am #93228

Georgios

Hi harshad!
I did reset from support and now it works.
I uploaded again with ftp and now ok
The only problem that remains is the conflict with custom permalinks
The good thing is that the permalinks do not break its just the language switcher that addls wrong the "en" again to the original URL
Sometimes it adds //
Maybe I could hack the switcher for now to direct only to mysite.com and mysite.com/en

December 27, 2012 at 8:00 am #93229

Harshad
Forum moderator

Dear Georgios,

Can you please send me your ftp and wp-admin details to my email address?

So I can take a look and check whats exactly going on.

Please include this forum link for reference.

The topic ‘[Closed] custom permalinks plugin’ is closed to new replies.