[Resolved] Translation of custom taxonomy

Home Support English Support [Resolved] Translation of custom taxonomy

This topic contains 8 replies, has 2 voices, and was last updated by  sarah.n 1 year, 9 months ago. The support staff assigned to this topic is sarah.n.

Author Posts
Author Posts
January 14, 2013 at 11:19 am #96122

VA

Hello,
I could translate one custom post type's custom taxonomy ( auction's categories created by a custom theme), but not the others ( FAQ categories of a plugin ) !
It cannot be translated neither in custom taxonomy edit page (like auction category) nor in string translation.
Thanks,
A

January 14, 2013 at 12:24 pm #96151

sarah.n
Forum moderator

Hello Attila,

Are you referring to the custom taxonomy label? If so, is the custom taxonomy label as registered by the plugin wrapped correctly in a getText function?

If on the other hand you are referring to the taxonomy terms: Please go to your translation settings under "WPML -> Translation Management -> Multilingual Content Setup" and take a screenshot of the "Custom taxonomies" section.

You can upload the screenshot you will take using the "Upload an image" link below the comment area.

January 14, 2013 at 12:28 pm #96155

VA

Hi Sarah,

no, I'm speaking about the particular custom post type taxonomies, like:
custom post: FAQ, custom taxonomy: FAQ category, like General, Shipment, Payment, Auctions. I'm not able to translate these values!
I CAN translate custom post type's ( auction ) taxonomy ( auction categories ) values!
Thanks,
A

January 14, 2013 at 1:24 pm #96189

sarah.n
Forum moderator

Attila,

What plugin are you using? Is it a free on that I can download?

January 14, 2013 at 7:18 pm #96318

VA

Sarah,
here it is:
http://wordpress.org/extend/plugins/q-and-a/

January 15, 2013 at 6:21 am #96365

sarah.n
Forum moderator

Hello Attila,

Thank you for getting back to me. The problem is that your plugin author forgot to include the text domain when he creates the custom post type.

Take a look at this for example (taken from q-and-a\inc\custom-post.php):

function create_qa_post_types() {	 
	 global $qaplus_options;	 
	 $labels = array(
		'name' => _x( 'FAQ Categories', 'taxonomy general name' ),
		'singular_name' => _x( 'FAQ Category', 'taxonomy singular name' ),
		'search_items' =>  __( 'Search FAQ Categories' ),
		'all_items' => __( 'All FAQ Categories' ),
		'parent_item' => __( 'Parent FAQ Category' ),
		'parent_item_colon' => __( 'Parent FAQ Category:' ),
		'edit_item' => __( 'Edit FAQ Category' ), 
		'update_item' => __( 'Update FAQ Category' ),
		'add_new_item' => __( 'Add New FAQ Category' ),
		'new_item_name' => __( 'New FAQ Category Name' ),
  	);
  	register_post_type( 'qa_faqs',
		array(
			'labels' => array(
				'name' => __( 'FAQs' ),
				'singular_name' => __( 'FAQ' ),
				'edit_item'	=>	__( 'Edit FAQ'),
				'add_new_item'	=>	__( 'Add FAQ')
			),
			'public' => true,
			'show_ui' => true,
			'capability_type' => 'post',
			'rewrite' => array( 'slug' => $qaplus_options['faq_slug'], 'with_front' => false ),
			'taxonomies' => array( 'FAQs '),
			'supports' => array('title','editor')	
		)
	); 	  
  	register_taxonomy('faq_category',array('qa_faqs'), array(
		'hierarchical' => true,
		'labels' => $labels,
		'show_ui' => true,
		'query_var' => true,
		'rewrite' => array( 'slug' => 'faq-category' ),
  )); 
}	

Note that the second parameter of the getText function he is using, the plugin's textdomain, is missing!

You may want to contact the plugin author and point him to point 2 here: http://wpml.org/documentation/support/troubleshooting-string-localization/

January 15, 2013 at 1:25 pm #96526

VA

Dear Sarah,

I forwarded your info to the plugin's support, I hope they solve this issue ASAP.
Thanks,
A.

January 17, 2013 at 8:56 am #97065

VA

Dear Sarah,

they upgraded their plugin, I also upgraded it, then deleted old FAQ categories,
created new ones but there's still no way to translate them,
"neither in custom taxonomy edit page (like auction category) nor in string translation".
Could you check your install pls. !
Thank you,
Attila

January 18, 2013 at 5:56 am #97363

sarah.n
Forum moderator

Attila,

Since the thread is marked as resolved I am not notified of new replies to it. Can you please open a new ticket referencing this one?

Thank you!

You must be logged in to reply to this topic.