5
UPDATE: We had to pull out version 1.7.4 due to a last minute killer bug. We’ll have it back tomorrow.

This version of WPML includes small bug fixes and changes that make it work with WordPress 3.

WordPress 3 is not out yet, but it’s just around the corner, so it’s a good idea for everyone running a WP site to start testing. WPML 1.7.4 doesn’t yet support all the new cool features of WP3, but it makes all existing functions run fine on WP 2.8-3.0.

Most of the changes are behind the scenes, without any effect on functionality. WordPress internal functions have changed considerably in version 3, so WPML had to follow.

Still, we managed to include several fixes for bugs and some new features – all reported in the forum.

Bugs we’ve fixed

  • Fixed bugs causing wp_list_pages(), wp_list_categories() and get_pages() to fail when Adjust IDs is on.
  • Sync default categories upon change. Wasn’t happening before.
  • Fixed a bug in the library used for communicating with ICanLocalize to work with HTTPS.

New features

  • Author links by language.
  • Include private pages in the CMS navigation.
  • Allow synchronizing the private flag between translations.
  • Added argument $return_original_if_missing to icl_link_to_element(). This allows returning empty strings.

Let us know

We hope that you enjoy this release and keep building exciting projects with WordPress and WPML. Leave comments on how it’s going for you. As always, if you need us to follow-up and help fix things, the best place is in the forum.

And, don’t forget to head back to WPML’s download page and leave your feedback there too!

5 Responses to “WPML 1.7.4 for WordPress 3”

  1. Um, can i just check on this – i downloaded 1.7.4 this morning (15th April) and activated it.

    Do i need to replace that version after you have repaired and re-posted 1.7.4?

    Or was the one i downloaded this mornign already the latest updated version?

    If so, how does one update it?

    Thanks for guidance

    • Version 1.7.4 had a critical bug, which we only discovered after release (and updating our own site). Please update again to 1.7.5, which is just like going back to 1.7.3.

      We’ll have a fixed version that supports WP3 properly on Monday.

  2. Hey, I am upgrading blogs with your plug in, is there a fix for the bug your team found, or is 1.7.5 (actually 1.7.3) the latest version?

    Any is there an update on when the the fix for the bug will be released?

    Thank you for your time and advice.