5

We just released an update to WPML, including the String Translation, Translation Management and WPML Media plugins. This update resolves a number of bugs that slipped through for WordPress 3.5.

Fix highlights:

  • wp_query issue that caused double posts to appear on some themes and with some plugins
  • CPT slug translation was sometimes now working
  • Non-ASCII characters converted incorrectly
  • Admin language not working in some cases
  • Categories not translated in language swithcer
  • Made the (now huge) ‘how to translate’ button optional
  • Fixed an issue with translated pages that have the same slug as originals
  • A number of PHP notices and warnings that came up after WP 3.5 update

This is a pretty small update and we felt it should go out ASAP, to avoid compatibility problems with WordPress 3.5, themes and plugins.

As far as we know, this is everything for WP 3.5. We’re thankful to everyone who took the time to carefully report and show us these issues.

To Upgrade

The Installer plugin also runs on WordPress 3.5 and it’s the recommended way to get new WPML versions automatically to your WordPress site.

You can also download the ZIP files manually from the Downloads page in your WPML account.

5 Responses to “WPML 2.6.3 fixes WordPress 3.5 related glitches”

    • A small issue, when I was visitting the Comments page from Admin Panel, there is a warning message appears: “Warning: Missing argument 2 for wpdb::prepare(), called in /home/xxxxx/public_html/mywebsitedomain/wp-content/plugins/sitepress-multilingual-cms/inc/comments-translation/functions.php on line 157 and defined in /home/xxxxx/public_html/mywebsitedomain/wp-includes/wp-db.php on line 990”. Can you fix this too?