87

Today is the official target date for WordPress 3.9 release (and also the day before Easter and Passover). We’re happy to release a second beta for WPML 3.1.5, with complete WordPress 3.9 support and other goodies.

Although this major WordPress version looks pretty similar on the surface, it packs a number of important changes to API and internal functionality. These changes are great for developers, as they make all WordPress code cleaner and nicer to work with. However, many plugins need to be updated to support the new API and remove deprecated calls.

WPML 3.1.5 addresses all the new stuff in WordPress 3.9. Since we’re just before a major holiday, we are holding back this update for next week. WPML 3.1.5 is after our complete QA and testing. It’s ready for development sites and we’ll update our own sites to it next week.

If you can give it a try on sites that you are developing now, especially with WordPress 3.9, it will be great!

Here is the list of major updates to WPML and its components.

WPML core

  • Further performance improvements: we’ve reduced the amount of repeated queries ran by WPML
  • Improved usability
  • Tested and fixed compatibility with WordPress 3.9 (this will be further improved in next release)
  • Fixed notices caused by mysql_* function when using PHP 5.5+
  • Fixed dependencies issues
  • Fixed parent-child page relationship issues
  • Fixed sub queries pagination when shown in home page
  • Fixed compatibility with CRED/Views
  • Fixed issues in root page
  • Fixed ajax requests loosing current language information

WPML CMS NAV

  • Tested and fixed compatibility with WordPress 3.9 (this will be further improved in next release)
  • Fixed notices caused by mysql_* function when using PHP 5.5

WPML MEDIA

  • Tested and fixed compatibility with WordPress 3.9 (this will be further improved in next release)
  • Fixed dependencies issues

WPML STICKY LINKS

  • Tested and fixed compatibility with WordPress 3.9 (this will be further improved in next release)
  • Fixed notices caused by mysql_* function when using PHP 5.5
  • Fixed dependencies issues
  • Proper support of custom post types

WPML STRING TRANSLATION

  • Tested compatibility with WordPress 3.9
  • Fixed slug translation issues

WPML TRANSLATION ANALYTICS

  • Tested compatibility with WordPress 3.9
  • Fixed dependencies issues

WPML TRANSLATION MANAGEMENT

  • Tested compatibility with WordPress 3.9
  • Minor bugfixes

WPML XLIFF

  • Tested compatibility with WordPress 3.9
  • Added support to multiple XLIFF versions
  • Fixed XLIFF import issues

Download and Install

As this is still a beta release, you can get it manually from your wpml.org account. Log in, go to Downloads, scroll to the bottom and get the WPML Beta Package. It’s a ZIP, which contains ZIP files of all of WPML’s components.

This update is fine for development sites. If you are upgrading sites from previous WPML versions, make sure that you upgrade all of WPML’s components.

Should I Update to WordPress 3.9?

At the time of writing this blog post WordPress 3.9 is not officially released yet (still in release candidate). Easter vacation is starting tomorrow and we don’t recommend doing major upgrades when not everyone is here. Even if WordPress 3.9 is released today, we will wait with it for our own sites for next week. Then, we’re going to run it on a test site with all plugins updated and test everything.

As WordPress 3.9 includes big changes under the surface, we’re going to carefully test our sites before we upgrade. All our testing show that WPML 3.1.5 works smoothly with WordPress 3.9. We are using a number of other plugins and have some code in our theme and I think that careful testing is better than panic problem fixing.

Feedback? Ideas? Questions?

I hope that you manage to experiment with WPML 3.1.5 on your development sites. Please give us your feedback by leaving comments. We’re attention junkies 🙂

87 Responses to “WPML 3.1.5b2 with WordPress 3.9 Support”

  1. “wpml-cms-nav” is missing in the beta3 package? Maby there are no changes in it since beta2? Hopefully the final 3.1.5 will be released soon since I did a premature upgrade to WP 3.9 and now having issues on my site.

    • WPML 3.1.5 is almost done QA and will go out on Monday. I’m not sure what hour, but Monday it will be.

      • Today is Monday and I dont see WPML 3.1.5 , please when will it be, I have issues on my site after updating WP

        • We’ll have this update today, in a few hours. The beta3 update is almost identical to the final 3.1.5 version. We had only a few minor glitches to fix between that last beta and the production version. Closing this version and releasing it very soon. If you still want to install the beta3 version until the production version is ready, make sure that you download the ‘CMS Beta Package’ and unzip it. This will include the ZIP files of all of WPML’s components.

          • I want to install CMS Beta Package but I cant here is the error
            Invalid argument supplied for foreach() in /home/&&&&&/public_html/toyou.am/wp-admin/includes/class-wp-upgrader.php on line 688

  2. I’m frustrated I updated WP without realising it was in beta, because I am losing my advanced edit option. I know this has happened with previous updates, but I have never been impacted. Interestingly I cannot even select advanced edit in the page options, it has disappeared!
    Should I downgrade back to previous WP version or just be patient a few more days?

    • Have you updated WPML to 3.1.5b3? It should run smoothly for you with WordPress 3.9. We’ve completed QA for this version and it’s ready for production update. We’ll be updating the downloads for all WPML clients to 3.1.5 tomorrow (Monday). Anyway, the 3.1.5b3 release is available right now and works fine with WordPress 3.9. Since it’s a beta, it is available for manual updates. Go to your wpml.org account, click on Downloads, scroll to the bottom and download it. That ZIP includes ZIP files or WPML’s components. Extract it and update the WPML components that you’re using.

      Please keep in mind that other plugins you are using may not have been updated for WordPress 3.9. If you update WPML to 3.1.5b3 and are having any trouble with the editing screen, you probably want to check what other plugins you are using and make sure they have all been updated to WordPress 3.9.

      • I have the same problem how can i update WPML 3.1.5b3? I download it and the wont to install plugin but i cant.

    • The String Translation should work. Have you updated this with WPML 3.1.5b3? The beta package includes the updated String Translation.

      If you updated everything and are having problems, please start a support thread in our technical forum. Tell us what’s not working for you and we’ll help.

  3. Hello,

    WPML 3.1.4 not work fine with last version of WordPress SEO By Yoast and WordPress 3.9.

    SEO section is not shown in page editor when WPML Pluging is active.

    Please Fix in 3.1.5.

    Regards.

    • Hello,

      Problem occurred when install WordPress 3.9

      Today I updated WPML to version 3.1.5 and now works fine.

      Thanks.
      Regards.

  4. Hi guys,
    I got some problems with WordPress 3.9 and WPML Multilingual CMS 3.1.5
    it seems it is advised to upgrade to 3.1.5.b2..

    well, damn.. 🙂 ..I can’t find this 3.1.5.b2 package anywhere..
    I feel dummy but.. I’ve just bought a Multilingual CMS License and I can see in my download section only package from 2.1.0 to 3.1.5
    I don’t see any beta 3.1.5 (b2 or b3)
    any idea?

    thanks a lot,
    romeo

    by the way WMPL is WIPING my htaccess file (I checked it with the Rochen.uk guys and they confirmed me it seesm it is the WPML plugin).

    • Hi guys.. it’s a mess for me. 🙂
      every time I click “Save Changes” in my ‘Woocommerce Settings’, WPML wipe out my htaccess file as soon as I switch language in my site.
      no matter if I’ve reinstalled WPML and WPML CMS 3.1.5 (wordpress 3.9)

      any idea?
      of course.. no problem if I don’t switch language..

      http://eteam3.it (control panel at REMOVED)
      The website is in maintenance Mode, you can login to see it live:
      user: REMOVED pw: REMOVED)
      feel free to contact me at REMOVED@gmail.com if you need user and pw as admin

      thanks,
      romeo

      • We don’t have ANY code in our plugins which will change the content of your .htaccess file. If you see this file getting deleted, I suggest checking for other plugins that may be involved in this. Did you try to disable other relevant plugins?

        Remember that when WordPress updated to 3.9, it made many API changes. This can easily influence other plugins or even your theme. We spent several weeks adjusting WPML to all these changes.

        • Hi Amir,
          I’ve tryed (again..) to deactivate ALL thje plugins but no way, when switching language and when browsing inside a secondary language AFTER “hitting” Save Changes in WooCommerce, i got a 404 Error and my htaccess got wiped out.
          NO PROBLEM AT ALL IF I DEACTIVATE WPML Multilingual CMS (INstalled version 3.1.5 on WordPress 3.9).
          so now we are sure it is WPML. You can check yourself.
          please consider I have proof your plugin WPML Multilingual CMS is wiping out my htaccess file (with ALL other plugin deactivated) EVERY TIME I hit “Save Changes” in WooCommerce.

          thanks a lot,
          I really appreciate your interest.
          cheers,
          romeo

          http://eteam3.it (control panel at REMOVED)
          The website is in maintenance Mode, you can login to see it live:
          user: REMOVED pw: REMOVED)
          feel free to contact me at REMOVED@gmail.com if you need user and pw as admin

          • I’m really not sure what’s causing this. I asked one of our developers to contact you and get more debug information. Best thing would be to post about it in our support forum. If you did that already, please paste here the link to your support thread and I’ll follow up.

            • Hi Amir!
              thanks again for your quick reply and interest.
              I didn’t contact your support team because it seemed to me this thread was talking about the same problem I’ve experienced.
              Thank you very much for asking your developers about that: if you think I should open a thread in your support forum, I will.
              Anyway now I’m gonna wait to be contacted from your developer: feel free to tell me if I should do in other way.
              I will report here when I find a solution.

              Regards,
              romeo

  5. Thanks Amir.
    Anyway I’ve already installed this release along with a fresh WordPress 3.9.
    I’m trying to understand if it’s a problem of compatibility with other plugins. I’ll let you know asap.
    thanks again for the quick reply, appreciate it.
    romeo