تخطي الملاحة

You can safely update WPML from old to new versions by following a manual, step-by-step process to ensure your website remains secure and compatible with WordPress and other plugins.

If you haven’t updated WPML in a long time, it’s important that you update it gradually. This way, you can avoid running into unexpected issues.

To update from an old version of WPML to the latest version in the securest way possible:

  1. From your WordPress site’s dashboard, go to Plugins → Installed Plugins.
  2. If the discontinued Installer plugin is installed and active on your site, deactivate and delete it.
  3. Deactivate the WPML core plugin and all the WPML components on your site. This includes String Translation, Media Translation, and WPML glue plugins.
  4. Delete all the WPML plugins from the Plugins page on your website. Or if you prefer, you can manually delete the WPML plugin folders from your ../wp-content/plugins/ folder.
  5. Check the WPML changelog to see which major version of WPML is closest to yours. For example, if you have WPML version 3.9, this would be 4.0.8. If the closest major version is not available on the page, you can contact our support and ask for it.
  6. Download the major version of WPML that is closest to yours.
  7. From your WordPress site’s admin, go to the Plugins page to install and activate the WPML plugin.
  8. Repeat the steps above and update the WPML core plugin one major version at a time. Once you have the latest version of WPML core plugin on your site, install the latest versions of the rest of WPML add-ons.

Note: After you activate the first latest major version of WPML (step 7), you may be asked to complete the WPML setup wizard. If this is the case, please contact support. After our team further assists you, continue with updating WPML one major version at a time (step 8).