Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Our next available supporter will start replying to tickets in about 2.39 hours from now. Thank you for your understanding.

This topic contains 28 Antworten, has 2 Teilnehmer.

Last updated by katrinA-3 vor 3 Monate, 2 Wochen.

Assigned support staff: Andreas W..

Autor Beiträge
Mai 21, 2019 um 5:57 pm #3857919

katrinA-3

Hallo,

ich habe bei einer neuen Webseite das Problem, dass meine ACF Felder nicht in der übersetzten Sprache angezeigt werden.

Installiert sind auf der neuesten WP-Version die aktuellen Versionen von WPML, ACF und Advanced Custom Fields Multilingual. Ich habe auch in den Fieldgroups die "Translation preferences" eingestellt – testweise auf "copy once" oder auch "translate". Allerdings werden unter WPML-> Settings keine custom fields angezeigt und in den Beiträgen auch nicht (siehe Screenshot).

wp memory limit ist auf 256

Mit dem "Twenty Nineteen" Template tritt der gleiche Fehler auf.

Was kann ich tun?

Viele Grüße
Götz

Mai 21, 2019 um 11:10 pm #3859137

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Vielen Dank, dass Sie den WPML Support kontaktiert haben.

Ich möchte einen temporären Zugriff (wp-admin und FTP) auf Ihre Site anfordern, um das Problem genauer zu untersuchen. Besser wäre eine Testseite, an der das Problem repliziert werden kann.

Die dafür erforderlichen Felder finden Sie unterhalb des Kommentarbereichs, wenn Sie sich anmelden, um Ihre nächste Antwort zu hinterlassen. Die Informationen, die Sie eingeben werden, sind privat, was bedeutet, dass nur Sie und ich sie sehen und darauf zugreifen können.

Vielleicht muss ich Ihre Site lokal replizieren. Dazu muss ich vorübergehend ein Plugin namens „Duplicator“ auf Ihrer Site installieren. Dadurch kann ich eine Kopie Ihrer Website und Ihrer Inhalte erstellen. Sobald das Problem behoben ist, lösche ich die lokale Site. Lassen Sie mich wissen, ob dies bei Ihnen in Ordnung ist.

 WICHTIG

Machen Sie eine Sicherungskopie der Site-Dateien und der Datenbank, bevor Sie uns den Zugriff gewähren.
Wenn Sie die Felder "wp-admin / FTP" nicht sehen, werden Ihre Anmeldedaten für Post und Website als "PUBLIC" (Öffentlich) festgelegt. Veröffentlichen Sie NICHT die Details Ihrer Website, es sei denn, Sie sehen die erforderlichen wp-admin / FTP-Felder. Wenn Sie dies nicht tun, bitten Sie mich, die private Box zu aktivieren. Die private Box sieht so aus:
hidden link

Mit freundlichen Grüßen
Andreas

Mai 22, 2019 um 10:47 pm #3869659

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Nutzen Sie zum Übersetzen von Advanced Custom Fields bitte unseren erweiterten Übersetzungseditor. Um diesen aktivieren zu können installieren Sie bitte unser Plugin Translation Management unter Plugins -> Neu installieren - Kommerziell.

Dann gehen Sie auf WPML -> Einstellungen -> Seiten und Beiträge übersetzen und wählen Sie erweiterten Übersetzungseditor.

Übersetzen Sie nun Ihre Seiten und lassen Sie mich wissen, ob sich alles Custom Fields wie erwartet übersetzen lassen.

https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

Mit freundlichen Grüßen
Andreas

Mai 27, 2019 um 10:00 am #3895577

katrinA-3

Hallo Andreas,

ich hab die Seite "translate-sites-built-with-acf" zwar mehrfach gelesen hatte aber trotzdem nicht verstanden, dass man nicht nur "Advanced Custom Fields Multilingual" sondern auch zusätzlich das "Translation Management" braucht.

Ich habe das Translation-Management installiert und die Optionsfelder werden jetzt angezeigt – soweit vielen Dank!

Allerdings funktioniert die Übersetzung immer noch nicht. Wenn ich z.B. in der Startseite auf das "+" bei Englisch klicke, bekomme ich eine neue leere Seite. Die ACF-Felder werden aber immer noch nicht angezeigt.

Ich habe auch versucht, Übersetzungen der Custom Fields zu machen und erst danach eine Englische Startseite zu erstellen, aber es gibt das gleiche Problem.

Viele Grüße
Götz

Mai 27, 2019 um 4:40 pm #3899621

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Bitte gehen Sie auf den Seiteneditor Ihrer Startseite und scrollen Sie zum Ende des Seite.

Hier sehen Sie das Multilingual Content Setup, welches Ihnen erlaubt die einzelnen Custom Fields auf, kopieren, übersetzen oder ignorieren zu stellen. Momentan stehen die Felder auf kopieren.

Nehmen Sie bitte die Äderungen vor und lassen Sie mich wissen, ob es funktioniert hat.

Aktivieren Sie zum Übersetzen bitte den WPML Advanced Translation Editor. (Siehe Screenshot)

Mit freundlichen Grüßen
Andreas

Mai 28, 2019 um 8:53 am #3904227

katrinA-3

Hallo,

funktioniert leider immer noch nicht richtig.

Ich habe alle Felder auf "Übersetzen" gestellt (Screenshot 1). Das Repeater-Feld steht auf kopieren, so wie hier beschrieben:
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

Dann habe ich eine englische Übersetzung angelegt (Screenshot 2) und im Advanced Translation Editor übersetzt (Screenshot 3).

Damit die englische Startseite auch die frontpage.php benutzt habe ich diese als Startseite ausgewählt (Screenshot 4).

Was jetzt funktioniert: Die Startseite zeigt ein bisschen Text (Screenshot 5).

Problem 1: Die Repeaterfelder werden nicht übernommen. Sie werden zwar im im Advanced Translation Editor angezeigt, aber nicht auf der Webseite.

Problem 2: Ich möchte den im Advanced Translation Editor gar nicht benutzen, denn damit kann ich im englischen dann ja gar nicht ACF benutzen. Vielleicht möchte ich komfortabel ein anderes Bild hochladen, oder im englischen 3 und im deutschen 5 Repeaterfelder benutzen. Wenn ich den im Advanced Translation Editor abschalte ist die englische Seite komplett leer.

Wir haben eine andere Webseite mit WPML wo das genau so funktioniert – sag bescheid, wenn du die Zugangsdaten zu klimaflex.de brauchst.

Danke und viele Grüße
Götz

Mai 28, 2019 um 9:33 pm #3910291

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Im Grunde müssten hier die Systemfelder auf kopieren gesetzt sein, was ich allerding leider nicht überprüfen kann, da Ihr Host-Anbieter hier eine Zugriffssperre eingerichtet hat (Screenshot 2).

Bitte gehen Sie auf den Editor für die Startseite. Scrollen Sie nach unten zur Einrichtung des mehrsprachigen Inhaltes.

Klicken Sie auf "Systemfelder anzeigen" (Screenshot 1). Wie Sie eventuell bemerken gibt es für jedes Benutzerdefinierte Feld zwei Einträge.

Beispiel:
image -> steht für benutzerdefinierte Feld
_image -> steht für das entprechende Systemfeld

Setzen Sie bitte alle Systemfgelder, die sich auf benutzerdefinierte Felder Ihres Seiteninhaltes bestehen auf "Kopieren" (Screenshot - set custom fields to copy).

Ich hoffe das löst das Problem. Lassen Sie mich wissen, ob weitere Hilfe notwendig ist.

Mit freundlichen Grüßen
Andreas

Mai 29, 2019 um 12:41 pm #3915473

katrinA-3

Hallo Andreas,

den Fehler mit "Zugriff verweigert" konnten wir beheben. "Systemfelder anzeigen" funktioniert jetzt!

Ich habe auch die Felder entsprechend konfiguriert:
image -> Übersetzen
_image -> Kopieren

Leider wird die englische Seite dann immer noch komplett ohne Custom Fields angezeigt. ich habe es mit und ohne den Advanced Translation Editor probiert.

Viele Grüße
Götz

Mai 29, 2019 um 4:10 pm #3917243

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Können Sie die Funktion wp-debug aktivieren, um festzustellen, ob aktuelle PHP-Fehler vorliegen. Geben Sie dazu folgendes in Ihrer wp-config Datei ein:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );

Besuchen Sie nun das Frontend und Backend Ihrer Website. Sollten Fehler vorhanden sein, werden diese erfasst und in der debug.log Datei im Ordner wp-content Ihres Servers gespeichert. Senden Sie mir bitte die Ergebnisse des debug.log, sollten Fehler vorhanden sein.

Weitere Informationen zum Aktivieren dieser Funktion finden Sie hier:
https://wpml.org/documentation/support/debugging-wpml/

Mit freundlichen Grüßen
Andreas

Juni 3, 2019 um 10:52 am #3941705

katrinA-3

Hallo Andreas,

hier das debug.log:

hidden link

Vielen Dank und viele Grüße
Götz

Juni 3, 2019 um 2:56 pm #3943723

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Soweit ich sehe bezieht sich Fehler auf das Theme und die damit verbunden page.php Datei.

Könnten Sie bitten den Code mitteilen, der verwendet wurde, um die Custom Fields auf der Seite sichtbar zu machen?

hidden link
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

Mit freundlichen Grüßen
Andreas

Juni 3, 2019 um 3:10 pm #3943759

katrinA-3

Hallo,

ich hatte dir in oben in einer privaten Nachricht die FTP Zugangsdaten geschickt. Ist das für dich in Ordnung, wenn du selbst im Theme nachguckst? Dann kannst du glaube ich schneller etwas testen, als wenn wir uns jetzt viele Dateien hin- und herschicken.

Alle Template-Seiten benutzen die "modul-picker.php" Datei um die ACF-Layouts zu laden. Die einzelnen Layout-Templates findest du im Ordner "templates".

Alternativ kannst du hier unser komplettes Theme runterladen:
hidden link

Viele Grüße
Götz

Juni 5, 2019 um 12:57 am #3955941

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Es tut mir sehr leid, dass ich erst spät dazu kommen Ihnen zu antworten. Ich habe mir das Ticket nochmals von Beginn an angesehen und mir war hier entgangen etwas zu erwähnen.

Ich habe das Multilingual Content Setup für den Testbeitrag Deutsch angepasst (Systemfelder auf kopieren und Benutzerdefinierte Felder auf Kopie oder Übersetzen).

Das Featured Image wurde hier nicht übersetzt, da unter WPML -> Settings -> Post Type Translation der Typ Medien als nicht übersetzbar markiert war.

Achten Sie nun bitte darauf vor dem Übersetzen die Optionen für Media Attachments zu setzen. (Siehe screenshot)

Soweit ist der Testbeitrag Deutsch nun komplett übersetzt. Der Footer muss mit String Translation übersetzt werden. Lassen Sie mich wissen, ob Sie hier Hilfe benötigen.

Sollte es weitere Custom Field Gruppen geben, die weiterhin Probleme bei der Übersetzung bereiten, so teilen Sie mir bitte die entsprechenden, Namen, Links und falls nötig Screenshots mit.

Mit freundlichen Grüßen
Andreas

Juni 5, 2019 um 11:32 am #3959883

katrinA-3

Hallo Andreas,

kein Problem, dass es etwas länger gedauert hat! 🙂

Es funktioniert leider immer noch nicht. Ich habe ein Screenrecording (screencast1) gemacht, damit du genau sehen kannst, was ich mache:
hidden link

Ich setze alle Felder auf "translate" oder "copy once", ich setze repeater-felder auf "copy" und ich setze alle Systemfelder auf "copy". Egal ob ich mit oder ohne den Übersetzungseditor übersetzen will – ich bekomme am Schluss immer eine leere Seite und sehe keine ACF Felder – weder im Frontend, noch im Backend.

Nur um sicher zu gehen, dass wir über das gleiche sprechen:
Ich möchte eine deutsche Seite nach Englisch übersetzen. Ich möchte in der englischen Seite alle ACF Felder und Module sehen, dort meine Übersetzungen eintragen. Ich möchte in der englische Übersetzung zusätzlich auch andere ACF Felder nutzen, z.B. Deutsch: 4 Felder im Repeater, Englisch: nur 3 Felder im Repeater.

Wir haben eine andere Seite mit WPML – da funktioniert das genau so – siehe (screencast2):
hidden link

Hat das vielleicht etwas damit zu tun, dass alles Clone-Fields sind? Was mache ich falsch? Wenn es bei dir schon funktioniert hat – kannst du mir eine Schritt-für-Schritt-Anleitung schicken?

Danke und viele Grüße
Götz

Juni 5, 2019 um 8:52 pm #3964109

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Bei Testbeitrag ließ sich die Unterzeile übersetzen und wurde auch angezeigt. Bei den Seiten, sehe auch ich alle Felder im Übersetzungseditor, was bedeutet, dass das Problem ncht bei WPML, sondern viel mehr am Theme liegt

Ich muss ehrlich gestehen, dass ich noch nicht sonderlich viel Erfahrung mit ACF habe, aber im Grunde muss die function get_field aufgerufen werden, um Custom Fields auf dem Frontend sichtbar zu machen. Verstehe ich richtig, dass die module-picker.php und die dazugehörigen Module speziell für Sie vom Theme Author angelegt wurden? Es scheint mir, alsob hier die PHP Dateien angepasst werden müssen.

Mehr Information dazu hier:
hidden link

Ich bitte Sie um Verständnis, dass wir leider keine Code-Lösungen für Custom Themes anbieten können und würde Ihnen raten einen unserer Vertragspartner zu kontaktieren, da unser Support leider keine individuellen Lösung, wie solche für Custom Themes, anbieten kann.

Bitte lesen Sie unsere Support-Richtlinien hier:
https://wpml.org/de/purchase/support-richtlinie/

Erfahrene WordPress Programmierer mit Erfahrung in WPML finden Sie hier:
https://wpml.org/contractors/

Mit freundlichen Grüßen
Andreas