Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Our next available supporter will start replying to tickets in about 1.22 hours from now. Thank you for your understanding.

This topic contains 6 Antworten, has 2 Teilnehmer.

Last updated by Marcel vor 5 Monate, 1 Woche.

Assigned support staff: Marcel.

Author Artikel
April 28, 2019 um 8:57 pm #3699033

niclasO

Hi,

I am using Elementor as page builder for my website. When I change something of the layout in my default language, my translated page remains the same.
How can I adapt the same look of my website in the foreign language?
And is it possible to adapt the layout of the foreign language to the default language, without changing the current translations?

Best Regards
Niclas

April 30, 2019 um 7:21 am #3708627

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Niclas,

Vielen Dank, dass Sie den WPML Support kontaktiert haben.

Könnten Sie bitte einen Screenshot hochladen, wo der Unterschied sichtbar ist? Elementor könnte im übersetzen Layout eine andere CSS ID generiert haben, somit die übersetzte Seite diese Styling Information nicht bekommen.

Bitte um Info, dann kann ich dies vergleichen. Ebenso muss z.b. auch das Headerlayout übersetzt werden: https://wpml.org/documentation/plugins-compatibility/elementor/

Freundiche Grüße
Marcel

April 30, 2019 um 8:58 am #3709723

niclasO

Hi Marcel,

Kernproblem ist eigentlich, dass Änderungen im Layout auf der Englischen Seite nicht übernommen werden.
Der Header wird bspw. gar nicht mehr angezeigt.
Ich habe bspw. auch die Menü Struktur im Deutschen geändert und es wird im Englischen nicht übernommen.
Ich möchte es eigentlich gerne so haben, dass das Deutsche Layout auf das Englische übertragen wird und ich quasi nur die Übersetzung hinzufügen muss.
Hier bin ich momentan aber überfordert.
Vielleicht kannst du mir helfen.
Bilder Folgen.

Beste Grüße
Niclas

Mai 2, 2019 um 7:09 am #3722195

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Niclas,

danke, dann warte ich auf die Bilder. Sie können mir auch gerne die Logindaten zu Ihrer Seite nennen, dann schaue ich mir das an.

Bitte aktualisieren Sie auch Elementor auf V. 2.5.6, ich hatte gestern einen ähnlichen Fall, wo dies mit der neuen Version nicht nachgestellt werden konnte.

Ich bräuchte bitte temporären Zugriff (WP-Admin und FTP) auf Ihre Seite, vorzugsweise zu einer Test/Staging Seite, an der das Problem nach Möglichkeit repliziert wurde.

Ihre nächste Antwort ist als „Privat“ markiert, dies bedeutet nur Sie und ich haben Zugriff darauf.

❌ Bitte sichern Sie Ihre Datenbank und Website davor ❌

✙ Ich würde außerdem Ihre Erlaubnis benötigen, um Plugins und das Theme zu deaktivieren und erneut zu aktivieren sowie Konfigurationen auf der Seite zu ändern. Dies ist auch der Grund, warum das Backup wirklich wichtig ist.

Freundliche Grüße
Marcel

Mai 6, 2019 um 9:16 am #3746233

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Niclas,

sehr gut, wie haben Sie das erste Problem genau gelöst? Durch das vorgeschlagene Elementor Update auf V 2.5.6?

Wegen den Permalinks: Ihre Einstellungen -> Permalinks Option für "Benutzerdefinierte Basis" ist falsch. dies linkt auf DE/EN immer auf /shop. Dies sollte auf "artikel/article" zurückgestellt werden. /shop sollte nur für "Shop-Seite" definiert sein da sie sonst den 404 Fehler bekommen.

Beste Grüße
Marcel

Mai 9, 2019 um 4:16 am #3773041

niclasO

Hi Marcel,

zu 1: ja genau, das Update hat geholfen.

zu 2: richtig, dann funktioniert es. Jedoch würde ich gerne folgende Permalink Einstellungen für das Produkt haben: sauer-troeger.com/shop/belaege/hellfire
Oder eben in Englisch: sauer-troeger.com/en/Shop/rubbers/hellfire.

Das ist jedoch nicht möglich oder?

Beste Grüße
Niclas

Mai 9, 2019 um 7:29 am #3773693

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Niclas,

#1 sehr gut, danke für die Rückmeldung.
#2 Da dies über WooCommerce gesteuert wird und WPML nur die Einstellungen zum Shop übernimmt, sehe ich hier keine Möglichkeit dies von Haus aus einzustellen. Über eine Individualanpassung am Code sollte es realisierbar sein. WooCommerce ladet im Standard immer die Kategorie dann das Produkt über einen eigenen Permalink.

Beste Grüße
Marcel