Skip Navigation

Dies ist das technische Support-Forum für WPML – das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team antwortet im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Schlagwörter: 

This topic contains 32 Antworten, has 3 Teilnehmer.

Last updated by Andreas W. vor 1 Monat, 4 Wochen.

Assigned support staff: Andreas W..

Author Artikel
April 1, 2020 um 1:15 pm #5813423

benjamin-danielS

Hallo WPML-Support-Team,

Ich versuche: Unser Kunde möchte eine zweisprachige Seite (deutsch, englisch) betreiben, in der Themer-Layouts von Beaver Builder verwendet werden. Dabei werden vom Kunden immer wieder Änderungen an den Layouts vorgenommen. Betroffen sind ausschließlich die Layouts der Subkategorien, d.h. "Küche und Haushalt", "Papeterie und Büro", "Schenken und Dekorieren" sowie "Wohnen und Textilien". Diese sind im Backend unter "Builder" und dann "Themer-Layouts" zu finden.
Wird das deutsche Layout einer Subkategorie verändert, wird auf dem englischen Pendant ein 404-Fehler angezeigt. Umgekehrt genauso, wird das englische Layout verändert, zeigt die deutsche Seite einen 404-Fehler. Dieser lässt sich beheben, indem man die Permalinkstruktur aktualisiert, so daß wir in der functions.php des Themes einen Codeschnipsel mit flush-rules() ausführen, wenn ein post jeglichen Typs gespeichert wird. Dieser greift leider nicht bei oben erwähnten Layouts. Laut Einstellungen der Beitragstypen sollen die Layouts übersetzt werden, wo wir den Fehler vermuten.

URL der/meiner Website, auf der das Problem auftritt:
hidden link
Diese Stageingumgebung ist ein aktueller (1.4.2020) Snapshot der Live-Seite.

Erwartet hatte ich zu sehen: Die übersetzte Seite, in der das Layout verwendet wird.

Stattdessen bekam ich: Fehler 404

Danke für Ihre Unterstützung.

Beste Grüße!

April 1, 2020 um 4:04 pm #5815643

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo,

Vielen Dank, dass Sie den WPML Support kontaktiert haben. Könnte ich mir dies bitte auf der oben genannten Staging Seite direkt ansehen?

Dazu bräuchte ich bitte temporären Zugriff (WP-Admin und FTP) auf Ihre Seite, vorzugsweise zu einer Test/Staging Seite, an der das Problem nach Möglichkeit repliziert wurde.

Ihre nächste Antwort ist als „Privat“ markiert, dies bedeutet nur Sie und ich haben Zugriff darauf.

❌ Bitte sichern Sie Ihre Datenbank und Website davor ❌

✙ Ich würde außerdem Ihre Erlaubnis benötigen, um Plugins und das Theme zu deaktivieren und erneut zu aktivieren sowie Konfigurationen auf der Seite zu ändern. Dies ist auch der Grund, warum das Backup wirklich wichtig ist.

Freundliche Grüße
Marcel

April 6, 2020 um 11:03 am #5847373

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Danke für den Zugang. Lt. unserer Anleitung ist das Translation Management Add-Ons, welches für den Beaver Builder benötigt wird nicht installiert: https://wpml.org/documentation/plugins-compatibility/beaver-builder/#what-you-will-need

Bitte versuchen Sie es nochmals damit.

Bitte um Info
Freundliche Grüße
Marcel

April 9, 2020 um 2:24 pm #5876795

benjamin-danielS

Hallo,

danke für den Hinweis. Das Plugin haben wir installiert und konfiguriert und sämtliche Themer-Layouts mit den passenden Übersetzungen verbunden. Wird ein Themer-Layout verändert, haben nun alle übersetzten Subkategorien einen 404-Fehler. Ändert man das deutsche Themer-Layout, sind alle englischen Subkategorien 404 und umgekehrt vom englischen zum deutschen. Wenn Sie bitte nochmal schauen könnten?

Danke schonmal,
schöne Osterfeiertage und
freundliche Grüße

April 10, 2020 um 5:05 pm #5885395

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo,

Wird ein Themer-Layout verändert, haben nun alle übersetzten Subkategorien einen 404-Fehler. Ändert man das deutsche Themer-Layout, sind alle englischen Subkategorien 404 und umgekehrt vom englischen zum deutschen.

Ich habe nun auf "Kategorie (Küche und Haushalt)" das Layout geändert und eine Aktualisierung für Englisch ausgelöst:
hidden link

Ich erhalte auf der englischen Seite jedoch keinen 404 Fehler: hidden link

Wie kann ich es nachstellen? Bzw. was mache ich falsch?

Bitte um Info & Ihnen auch schöne Osterfeiertage!

Freundliche Grüße
Marcel

April 14, 2020 um 2:33 pm #5905377

benjamin-danielS

Hallo,

danke, dass wir auf Ihre Unterstützung zählen können.

Sie betrachten die Vorschau des übersetzten Themer-Layouts. Im Frontend wird weiterhin ein 404 angezeigt: hidden link

Warum Vorschau und Frontend sich unterscheiden, können wir uns nicht erklären, haben wir alle Cache-Ebenen (Server, WordPress, WPML, Browser) ausschließen können. Den Cache zu leeren bringt auch keine Besserung, nur die Aktualisierung der Permalinkstruktur.

Manchmal werden die Änderungen auch im Frontend nicht korrekt angezeigt, wenn man noch eingeloggt ist, daher überprüfen wir die Anzeige immer im Inkognito-Modus.

Danke weiterhin und
freundliche Grüße

April 21, 2020 um 2:28 pm #5960471

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo,
danke für die Info. Bitte versuchen Sie, ob Sie dies als Fehler auf einer isolierten Sandboxumgebung nachstellen können. Ich habe dazu eine neue Installation mit WPML aufgesetzt. Bitte installieren Sie hier den Beaver Builder und prüfen Sie, ob es sich nachstellen lässt:

hidden link

Sollte es auf dieser Installation reproduzierbar sein, kann ich den Fall an unser Compatibility-Team weiterleiten.

Bitte um Info

Freundliche Grüße
Marcel

April 24, 2020 um 2:23 pm #5987431

benjamin-danielS

Hallo,

die Antwort ist eindeutig jein.
Der Fehler lässt sich wie beschrieben provozieren, doch er verschwindet beim nächsten Reload wieder.
Welche Einstellungen Ihrer Sandbox verursacht, dass der 404 wieder verschwindet?

Danke und freundliche Grüße

April 27, 2020 um 1:11 pm #6002647

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo,

die Sandbox verwendet Standardeinstellungen. Ich habe nun WPML -> Sprachen, WPML -> Einstellungen mit beiden Seiten verglichen und es ist alles identisch.

Können Sie den Reload bzw. den Fehler hier bitte als Screenshot festhalten?

Bitte um Info

Freundliche Grüße
Marcel

April 29, 2020 um 1:34 pm #6022023

benjamin-danielS

Hallo,

ja, sicher. Screenshot anbei.
Geändert wurde die Subkategorie 11 bzw das deutsche Themer-Layout Demo Archiv 1. Witzigerweise hat sich der Fehler diesmal nicht nach dem Reload verflüchtigt. Sie müssten ihn noch aufrufen können.
hidden link

Freundliche Grüße

Mai 1, 2020 um 3:18 pm #6038615

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Danke für die Info, ich versuche es nun nachzustellen.

Mai 6, 2020 um 11:32 am #6070013

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo, wenn ich die URL aufrufe bekomme ich den genannten 404 Fehler. Ein Wechsel/Zurückwechseln der Sprache leitet jedoch den Permalink komplett um und zeigt nicht die korrekte Kategorie. Wie ist bei Ihnen der 404 Fehler verschwunden?

Sie rufen "kategorie" auf anstatt "hidden link ?

Bitte um Info
Freundliche Grüße
Marcel

Mai 12, 2020 um 9:15 am #6110729

benjamin-danielS

Hallo,

Der Fehler verschwindet, wenn man die Permalinks manuell aktualisiert. Ein flush_rewrite() bringt nicht den gewünschten Effekt.

Nein, ich rufe die Unterkategorieseite "hidden link
auf und wechsele dann in das deutsche Gegenstück.

Freundliche Grüße

Mai 12, 2020 um 10:03 am #6111191

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Ich glaube wir kommen so nicht weiter. Ich kann nicht wiedergeben, wie das Problem exakt reproduduzier ist:

die Antwort ist eindeutig jein.
Der Fehler lässt sich wie beschrieben provozieren, doch er verschwindet beim nächsten Reload wieder.

Witzigerweise hat sich der Fehler diesmal nicht nach dem Reload verflüchtigt. Sie müssten ihn noch aufrufen können.
hidden link

Nein, ich rufe die Unterkategorieseite "hidden link
auf und wechsele dann in das deutsche Gegenstück.

Also Ihre Schritte sind folgende, ist dies korrekt?

#1 Sie rufen hidden link auf, wechseln dann auf DE
#2 Die Seite leitet auf hidden link um und zeigt einen 404 Fehler
#3 Wann aktualisieren Sie in diesem Schritt die Permalinks?

Können Sie mir bitte Ihre exakten Schritte aufzeigen, damit ich es nachstellen kann? Vielen Dank

Bitte um Info
Freundliche Grüße
Marcel

Mai 12, 2020 um 2:26 pm #6113739

benjamin-danielS

Hallo,

Hallo,

wie bereits beschrieben, tritt nach dem Ändern eines Themer-Layouts der 404-Fehler auf. Um die Seite danach wieder korrekt anzuzeigen, aktualisieren wir die Permalinkstruktur im Dashboard.

Freundliche Grüße

Das Thema ‘[Geschlossen] Änderung an Beaver Builder Themer Layout verursacht 404 error in Übersetzung’ ist für neue Antworten geschlossen.