Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Schlagwörter: 

This topic contains 31 Antworten, has 3 Teilnehmer.

Last updated by Andreas W. vor 3 Monate, 1 Woche.

Assigned support staff: Andreas W..

Autor Beiträge
August 1, 2019 um 2:10 pm #4322541

sebastianF-24

Ich versuche:
Den Text im Original (Englisch / Source) zu ändern. Dieser Text ist bereits übersetzt.

URL der/meiner Website, auf der das Problem auftritt:
hidden link
Erwartet hatte ich zu sehen:
Die Übersetzung bleibt erhalten und ich kann sie anpassen.

Stattdessen bekam ich:
Die Übersetzung wurde komplett gelöscht. Das Übersetzungsfeld ist leer.

August 1, 2019 um 2:54 pm #4322897

sebastianF-24

i just tested. there is no button "update translation" it just says "edit translation" after I edit the original.
When i start a fresh page, add some wpbakery text blocks and edit the original after translating them, it works.
can somebody please help me? this is really important, as we can't translate anything now without loosing to risk the translations

August 1, 2019 um 3:29 pm #4323477

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hallo Sebastian,

Vielen Dank, dass Sie den WPML Support kontaktiert haben.

Ich kann nicht ganz folgen. Also Sie übersetzen das WPBakery Element, editieren dieses später (im Page Builder), danach verliert der Übersetzungseditor die gesamte Übersetzung für dieses Feld, verstehe ich das richtig?

Ist das Feld ganz unten in der Seite in der Multilingual Content Box als "Übersetzen" oder "Kopieren" eingestellt?

Bitte um Info

Freundliche Grüße
Marcel

August 1, 2019 um 3:37 pm #4323493

sebastianF-24

Hallo Marcel. Du beschreibst das Problem genau richtig: die Übersetzung geht verloren.
Das Feld, das ich übersetze ist einfach nur der Normale Text / Body der WordPress Page, kein custom field.
Der Body ist glaube ich nicht unten angeführt in der "Multilingual Content Box", oder?

August 1, 2019 um 3:45 pm #4323627

sebastianF-24

Ich denke, es wäre das einfachste, wenn wir Teamviewer machen könnten. Ginge das?

August 2, 2019 um 12:39 pm #4330047

sebastianF-24

Hallo Marcel. Wäre jetzt im Büro. Hättest du gerade Zeit, dass wir das Problem lösen?

August 2, 2019 um 1:01 pm #4330123

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hallo Sebastian,

wir bieten leider keinen Support über Teamviewer. Ich würde mir dies jedoch gerne direkt auf Ihrer Seite ansehen.

Ich bräuchte dazu bitte temporären Zugriff (WP-Admin und FTP) auf Ihre Seite, vorzugsweise zu einer Test/Staging Seite, an der das Problem nach Möglichkeit repliziert wurde.

Ihre nächste Antwort ist als „Privat“ markiert, dies bedeutet nur Sie und ich haben Zugriff darauf.

❌ Bitte sichern Sie Ihre Datenbank und Website davor ❌

✙ Ich würde außerdem Ihre Erlaubnis benötigen, um Plugins und das Theme zu deaktivieren und erneut zu aktivieren sowie Konfigurationen auf der Seite zu ändern. Dies ist auch der Grund, warum das Backup wirklich wichtig ist.

Freundliche Grüße
Marcel

August 5, 2019 um 10:53 am #4339961

sebastianF-24

Kann ich noch irgendwie helfen?

August 5, 2019 um 3:42 pm #4341721

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hallo Sebstian,

hier liegt ein JS Konflikt vor. Erkennbar am veränderten Design der grünen 100% Anzeige im Übersetzungseditor. Ich deaktiviere nun die Plugins und gebe Ihnen Bescheid, wenn ich herausgefunden habe, was den Konflikt auslöst.

Freundliche Grüße
Marcel

August 5, 2019 um 4:17 pm #4341943

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Können Sie bitte versuchen das Problem nachzustellen, wenn nun folgende Plugins deaktiviert sind?

- Everest Timeline (Designveränderung Übersetzungseditor -> jQuery)
- Query Wrangler (Designveränderung Übersetzungseditor -> jQuery)
- The Events Calendar Shortcode and Templates (JS Fehler)

Bitte um Info
Freundliche Grüße
Marcel

August 5, 2019 um 4:45 pm #4342039

sebastianF-24

Hallo Marcel
Leider besteht das Problem auch weiterhin. Sobald ich jetzt einen Textblock original englisch ändere wird die deutsche Übersetzung überschrieben (diesmal mit dem englischen neuen Text)

August 5, 2019 um 5:37 pm #4342283

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hallo Sebastian,

haben Sie nun die Logindaten verändert? Wenn ich mich versuche einzuloggen, passiert nichts (kein Hinweis etc.). Ich würde dies gerne noch ohne Plugins in einer minimalen Umgebung testen.

Bitte um Info

Freundliche Grüße
Marcel

August 5, 2019 um 7:43 pm #4342851

sebastianF-24

Hi Marcel
Nein, habe nichts verändert. Hatte ich vorher auch schon einmal. Evtl. kurz browser cache leeren? Dann ging es bei mir.
Danke und erstmal einen schönen Feierabend!

August 7, 2019 um 3:42 pm #4356561

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hallo Sebastian,

vielen Dank. Nun hat der Login funktioniert.

Ich konnte das Verhalten auf Ihrer Seite nachstellen:
"PLANAR DIGITAL VERSATILE EFFICIENT TEST" -> wird zu "PLANAR DIGITAL VERSATILE EFFICIENT TEST"

Hier das Verhalten auf einer frischen Sandboxumgebung ohne Theme/Plugins bei der Einrichtung:
"PLANAR DIGITAL VERSATILE EFFICIENT" -> "PLANAR DIGITAL VERSATILE EFFICIENT DE"

Nach der Überarbeitung der Übersetzung:
"PLANAR DIGITAL VERSATILE EFFICIENT TEST" -> bleibt "PLANAR DIGITAL VERSATILE EFFICIENT DE"

Es scheint also, dass das Problem von einem installierten Plugin oder Ihrem Theme ausgelöst wird. Können Sie Page Builder und Theme auf dieser Sandbox installieren? hidden link

Dann können wir überprüfen von wo dieses Verhalten kommt.
Bitte um Info

Freundliche Grüße
Marcel

August 8, 2019 um 1:39 pm #4363341

sebastianF-24

Hallo Marcel
Leider kann ich das Theme nicht mit den nötigen Plugins installieren, weil man es dazu erneut authentifizieren müsste. Aber da der Key bereits auf unserer Domain genutzt wird, geht das natürlich nicht.
Ich habe gerade mal selber alle plugins (ausser wpml und wpbakery) deaktiviert und auch ein anderes theme versucht. es klappt trotzdem nicht. Immer werden die Übersetzungen überschrieben.
Die einzige Möglichkeit ist, WPBakery zu deaktivieren, dann läuft es - aber das ist keine Option.
Wie können wir vorgehen? Die Übersetzung der Webseite steht momentan ganz oben auf unserer Liste und wir müssen das wirklich angehen. Soll ich die gesamte Webseite einmal exportieren? Was benötigt ihr, um zu sehen, warum WPML nicht mit WPBAKERY zusammen laufen will?
Danke für deine Hilfe!
Sebastian