Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

This topic contains 10 Antworten, has 2 Teilnehmer.

Last updated by walterS-16 vor 6 Tage, 11 Stunden.

Assigned support staff: Diego Pereira.

Author Artikel
August 20, 2019 um 9:30 am #4422137

walterS-16

Über das Menu Übersetzungen funktioniert die Übersetzung des Fusion Builders nicht (siehe Screenshot). Ich meine dass das Problem seit dem Avada Update auf 6 auftritt. Das Plugin Classic Editor habe ich installiert und aktiviert.
Wie kann ich das Problem lösen?

August 20, 2019 um 9:24 pm #4426605

walterS-16

Mittlerweile wird unter "WPML - Übersetzung" nur noch ein Beitrag angezeigt. Dieser wurde heute erstellt (siehe Anlage).

August 21, 2019 um 6:38 pm #4434725

Diego Pereira
Supporter

Languages: Englisch (English ) Spanisch (Español ) Portugiesisch, Brasilien (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @walters-16, welcome to the WPML support Forum!

It's ok to continue this ticket on english? If not, please let me know and I will forward to another supporter.

The problem started to occur after the fusion builder update, correct? Could you tell which is the current and previous version of the plugin? I suspect they have modified the shortcodes.

Please send us access to your WordPress dashboard (website URL, login and password) I'll check and do some tests. - Please use the private field to send the sensitive data - do not post if you do not see it.

It would be better if you give me a test site rather than the live site.

IMPORTANT Please backup a working copy of site files and database before.

If possible, please also install these plugins. It may speed up the process:
Duplicator: https://wordpress.org/plugins/duplicator/
File Manager: https://wordpress.org/plugins/wp-file-manager/
All-in-one WP Migration hidden link
Adminer: https://wordpress.org/plugins/ari-adminer/
Cloudways WordPress Migrator: https://wordpress.org/plugins/bv-cloudways-automated-migration/

All the best,
Diego

August 22, 2019 um 2:50 pm #4440541

Diego Pereira
Supporter

Languages: Englisch (English ) Spanisch (Español ) Portugiesisch, Brasilien (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thank you. I did some tests with the duplicator package and it seems that the issue occurs because WPML String Translator is disabled. It started to work after I enabled it (see screenshot). Please try the following:
- Enable WPML String Translator
- Go to the edit screen of the page (original language)
- Do a small modification and save
- Translate the page

If the issue persist, probably your website is not loading the XML config of the theme. So you can try the following (with String Translator enabled):
- Copy the XML code from this page (hidden link).
- Go to WPML > Settings > Custom XML configuration
- Paste the XML code (please remove the lines 2 and 3) and save
- Go to the edit screen of the page (original language)
- Do a small modification and save
- Translate the page

Please let me know if it works for you.

Kind regards,
Diego

August 22, 2019 um 7:58 pm #4442621

walterS-16

Hi Diego,

Thanks for your help!

The whole page is already translated from German into English and can be found if you go on our website (hidden link). But (as described above), at the moment I cannot ...
...a) ACCESS the pages at the section "Uebersetzungen"/"translations" in WPML (pls. see the second screenshot above)
...b) if I go through the "pages" section of wordpress I can access the "translation" of each page. But then there is no access to the fusion builder "files". (pls. see the first screenshot above).

If I follow your first suggestion, it works in a restricted way only: I have activated the string translator (which was deactivated, because I thought it would slow down our homepage) and I have made a small change at one page, then indeed the translation of the fusion builder is working.

However - and this is a very big however - then the already made translation is lost. Both sides (left and right) show the original languages. That means that all translations seem to be lost, if I proceed this way. Which is certainly not practical.

I have copied the xml code into the field - as your second suggestion - but this havent't brought the desired effect either.

Furthermore, in the WPML/Uebersetzungen section, there is still only one "Beitrag" (with job ID number 381), which was recently added. All previous Seiten/Beitraege etc. are missing there.

Do you have another suggestion?

Best regards,
Walter

August 23, 2019 um 1:19 pm #4447561

Diego Pereira
Supporter

Languages: Englisch (English ) Spanisch (Español ) Portugiesisch, Brasilien (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello Walter,

Feedback below:

a) ACCESS the pages at the section "Uebersetzungen"/"translations" in WPML (pls. see the second screenshot above)

-- I think it's expected. It depends on which method you are using for translation. The WPML> Translations page acts as a pending translation queue. For posts to be displayed on this page, you must create a translation job in WPML> Translation Management. Please see this link for more details: https://wpml.org/documentation/getting-started-guide/#how-to-translate-pages-posts-and-custom-posts

If you translate the pages without the Translation management method (see: https://wpml.org/documentation/getting-started-guide/#translating-without-wpmls-translation-management), the posts will not be listed on WPML > Translations.

Please note that both methods works as expected.

------------------------------------------------------------------------------------------------------------------

b) if I go through the "pages" section of wordpress I can access the "translation" of each page. But then there is no access to the fusion builder "files". (pls. see the first screenshot above).

-- So, this issue is partially solved with the previous steps, correct? Now the Fusion Builder are displayed on the translation editor, the only problem now is that the translations have been lost.

Does this issue occur with all pages? Before the block problem was resolved, did you edit the contents of the single block or save the translation? If so, I think it's expected:
- WPML generated a translation field for each element of fusion builder
- After String Translator was disabled, the translation fields of the elements were removed and merged on a single text block
- If you edit or save the translation, the old translated fields are removed and now it have only a single translation field
- When we re-enable String Translator, WPML will regenerate the fields for each element, however the old translations were lost because the old fields have been removed.

Makes sense? If you want, please send me the name of the page with the issue and I will take a look to see if it's possible to recover the old translation. However I think the only way is to translate the page again, as it was overwriten.

------------------------------------------------------------------------------------------------------------------

Regarding String Translator, we are working to fix the performance issues and have released a beta today with many improvements. Please check this link: https://wpml.org/2019/08/wpml-4-3-beta-1-with-much-faster-string-translation/

Kind regards
Diego

August 26, 2019 um 10:32 am #4457645

walterS-16

Hi Diego,

Thanks for your quick response.

The crucial point is, that previously I translated the website (many pages/ beitraege/ portfolio etc.) with WPML. And all was fine!

After the error occurred after the update, most of these translations are not accessible via WPML anymore.

This has happened with nearly all pages, that means, also with the one, where I have not done any "saving" of any kind of a "single translation field".

The translations are still there (as you see if you access our webpage), but they are not accessible via WPML/Uebersetzungen with fusion builder.

There is either just the headline and nothing else (see e.g. hidden link
and hidden link)

or there is just two lines of the text section, which cannot be properly accessed, since the full text cannot be seen at once (see e.g. hidden link
and hidden link

or there is the fusion builder syntax content (see e.g. hidden link)
and hidden link )

None of these is usable for me.

FOR SURE: where I made some changes in the meanwhile, the WPML translation is lost and needs to be done again (but this is only a handful of pages).

The crucial question is:
What is with all the other webpages, which had been properly translated with WMPL and are now lost? I cannot - by hand - put all these translations into WPML mode again. This would be a mess of a work with all these many pages.

So, it would be great if you would have another solution to this problem.

Best regards,
Walter

August 26, 2019 um 8:02 pm #4461111

Diego Pereira
Supporter

Languages: Englisch (English ) Spanisch (Español ) Portugiesisch, Brasilien (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Regarding these pages that the content is missing on the translation editor, please try the following:
- Go to the edit screen of the page (original language)
- Do a small modification on the page content and save
- Translate the page.

Are the fields available after these steps? Probably the page needs a update to refresh the available fields.

For the other pages where the translation is lost, you can also use the manual editor as a alternative:
- Go to the edit screen of the page
- Switch off the "Use WPML's translation editor" on the right sidebar (see screnshot)
- Save

Now it will open the manual editor instead of the translation editor. The translations should be kept in this case.

Please let me know if it works for you.

IMPORTANT: Please backup your site first before making any change, this is important for security reasons.

Kind regards,
Diego

August 28, 2019 um 10:42 am #4473419

walterS-16

Hi Diego,

thanks for your reply.

Actually, just regarding your second suggestion, it is unfortunately not working in most cases:

1. Case: WPML put off, then it did NOT work with the old editor / the translated page is in ORIGINAL LANGAUGE (the translation seems to be lost)

Example page for this case:

Kuratorium: hidden link

hidden link

hidden link

2. Case: WPML put off, then the translated page is now in worpress mode (OK!), BUT there is now the “fusion-builder-syntax”

Example page for this case:

hidden link

hidden link

hidden link

There also rare cases, where the translation can be found, if WPML mode switched off:
WPML put off, then it worked with old editor in translated language:

1. Auszeichnungen: hidden link

hidden link

hidden link

But now, there is no chance then, to compare the original language with the translated language as in WPML mode (which is intended to use). Can this WPML mode be switched on again?

By the way, "WPML - translations" is still showing only one "Beitrag" (see image).

Do you have another suggestion, how the errors can be fixed?

Best regards,
Walter

August 28, 2019 um 6:45 pm #4476439

Diego Pereira
Supporter

Languages: Englisch (English ) Spanisch (Español ) Portugiesisch, Brasilien (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there, feedback below:

1. Case: WPML put off, then it did NOT work with the old editor / the translated page is in ORIGINAL LANGAUGE (the translation seems to be lost)
-- I checked the "Kuratorium" page on m local copy. If I choose the classic editor, the translations are not displayed on the fields (expected because it was translated using the manual editor). But if I choose the manual editor, the translations are still there (see screenshot).

Maybe you have selected the classic editor then saved. This may have overwritten the translation also on manual mode.

I still have a local copy of the website. If you want, I can upload it to our test server. This way you can copy the old translations and paste it to your website.

2. Case: WPML put off, then the translated page is now in worpress mode (OK!), BUT there is now the “fusion-builder-syntax”
-- It means that you should do a small modification on the page content and save. It should refresh the available fields on the translation editor. I did a test with the kontakt page and it worked, but the translations are also lost on that page. In this case, you can open the translated page on the front end then copy the content to the fields, or choose the manual editor. Please do that before clicking on "save", or the translated version will be overwriten.

But now, there is no chance then, to compare the original language with the translated language as in WPML mode (which is intended to use). Can this WPML mode be switched on again?
You can switch between the classic and manual editor on the right sidebar of each page (see screenshot). You can set the preferences for each page or for the entire website.

Please let me know if it works for you.

Kind regards,
Diego

September 10, 2019 um 11:05 am #4544387

walterS-16

Hi Diego,

Thank you for your help!

I had to go through the whole website and change manually each page:
1. from Fusion editor to classic editor
2. Switch off WPML's translation editor
3. update the page
4. go to the translated page and check, whether all is correct and correct it if necessary.

I finished most of the sites / portfolio / Beitraege etc.

No everything runs fine, doing the translation management the classic way (without WPML's translation manager).

Best regards,
Walter