Skip Navigation

Dies ist das technische Support-Forum für WPML – das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team antwortet im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Schlagwörter: 

This topic contains 14 Antworten, has 2 Teilnehmer.

Last updated by Andreas W. Vor 1 Monat, 3 Wochen.

Assigned support staff: Andreas W..

Author Artikel
März 31, 2022 um 9:33 pm #10924989

pabloS-10

Ich versuche:
Jedes mal wenn ich etwas speichere dauert es mindestens 30 sekunden bis etwas reagiert. Ohne WPML funktioniert es sofort.
Ich habe auch zum testen mal andere Plugins deaktiviert aber nur WPML alleine hat schon diese Probleme hervorgerufen.

URL der/meiner Website, auf der das Problem auftritt:
alle seiten
Erwartet hatte ich zu sehen:
Es ist klar das die performance etwas kleiner wird aber das wir 30 statt 5 sekunden warten geht leider nicht.

April 1, 2022 um 6:21 am #10926409

Andreas W.
Supporter

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich kann gerne anbieten mir das einmal genauer anzusehen.

Ich möchte einen temporären Zugriff (wp-admin und FTP) auf die Website anfordern, um das Problem genauer zu untersuchen.

Die dafür erforderlichen Felder findst Du unterhalb des Kommentarbereichs, wenn Du dich anmelden, um die nächste Antwort zu hinterlassen. Die Informationen, die Du angibst sind privat, was bedeutet, dass nur Du und ich sie sehen und darauf zugreifen können.

WICHTIG
Lege bitte unbedingt eine Sicherungskopie der Website und der Datenbank an, bevor Du uns den Zugriff gewährst.

Eventuell muss ich eine Kopie der Website anlegen, um diese auf einem virtuellen Server zu testen. Dazu würde ich das Plugin "All In One WP Migration" installieren. Lass mich bitte wissen, solltest Du damit nicht einverstanden sein.

Wenn Du die Felder "wp-admin / FTP" nicht sehen kannst, werden Ihre Anmeldedaten für Post und Website als "PUBLIC" (Öffentlich) festgelegt. Veröffentliche die Daten NICHT, es sei denn, Du siehst die erforderlichen wp-admin / FTP-Felder.

Das private Antwortformular sieht so aus:
hidden link

Klicke beim nächsten Antworten auf "I still need asistance".

Video:
hidden link

Mit freundlichen Grüßen
Andreas

April 5, 2022 um 10:36 pm #10958301

Andreas W.
Supporter

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich habe hier aller verfügbaren Updates durchgeführt und die für WPML notwendigen benutzerdefinierten Sprachdateien generieren lassen.

Zudem habe ich Query Monitor installiert.

Das Aktualisieren eines Originalbeitrages (ohne Divi) dauerte her etwa 10 Sekunden und das Übersetzen benötige etwa 5 Sekunden.

Auf der originalen Homepage dauerte das Speichern etwa 25-30 Sekunden, allerdings sehe ich hier eine sehr lange Ladezeit, die sich anscheinend auf mehr als 30 duplizierte Queries bezieht, von denen die große Mehrzahl von WPML stammt.

Es is jedoch sehr wahrscheinlich, dass diese duplizieren Queries vor allem deshalb auftreten, weil hier momentan insgesamt 14 laufenden Übersetzungsaufträge für die Seite offen sind, die noch nicht abgeschlossen wurden.

Teste ich dies auf der Website ohne WPML sehe ich weiterhin eine Ladezeit von mind. 10 Sekunden, die duplizierten Queries treten allerdings ohne WPML nur 3 mal auf.

Teste ich auf einer Seite, die Divi verwendet, aber bei der keine laufenden Aufträge darauf warten übersetzt zu werden, beträgt die Ladezeit ebenfalls nur etwa 10 Sekunden.

Sol bedeuten, wenn auf der Homepage momentan 14 laufende Prozesse im WPML bersetzungseditor habe, di jeweils aktualisiert werden müssen, wenn wir die Homage editieren, dann ist diese lange Ladezeit ggfls. durchaus zu erwarten.

Folglich, wenn diese laufenden Übersetzungen abgeschlossen wurden, sollte das speichern der Seite etwa 10 Sekunden dauern, wie es auf der Website auch ohne WPML der Fall ist.

Ich kann gerne anbieten zu versuchen diese Problem zu replizieren und unsere Entwickler dazu zu konsultieren, bitte Dich dazu allerdings um etwa Geduld.

Mit freundlichen Grüßen
Andreas

April 7, 2022 um 4:38 am #10969499

Andreas W.
Supporter

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich habe versucht das Problem auf einer neuen Test-Site mit mehr als 20 Sprachen und Divi nachzustellen, kann hier aber kein solches Problem bislang replizieren.

Momentan lade ich die Kopie der Website herunter, um diese lokal auf einem virtuellen Server zu testen und werde mich daraufhin wieder melden.

Vielen Dank für Deine Geduld.

Mit freundlichen Grüßen
Andreas

April 8, 2022 um 1:51 pm #10982053

pabloS-10

Hallo Andreas,
danke ich weiß deinen Einsatz sehr zu schätzen.
Können wir diese Übersetzungsaufträge zwischenzeitlich abbrechen bis wir sie aktiv benötigen doer würde das dem System eh nicht helfen?

April 9, 2022 um 3:04 am #10984985

Andreas W.
Supporter

Timezone: America/Lima (GMT-05:00)

Hallo,

Hier lassen sich momentan leider keine Aufträge abbrechen.

Der Status der Übersetzungen steht auf "Completed - Needs update", was recht seltsam ist, da diese Übersetzungen in der Tat einen Status von 0% haben.

Auf der Kopie Deiner Website sehe ich das Problem in der Tat auch dann, wenn ich alleine mit Divi und WPML teste.

Selbst wenn ich hier für alle Sprachen laufende Aufträge erstelle habe ich weiterhin die gleichlange Bearbeitungszeit beim Speichern des Originalinhaltes.

Das Durchführen der WPML Optionen zur Fehlerbehebung lösen die Probleme mit der Ladezeit ebenfalls nicht.

Wenn ich die Homepage dupliziere und einen neuen Draft erstelle, dauert es sogar mehrere Minuten, um den Inhalt abzuspeichern.

Du hast zum Beispiel einen Code-Block in der Seite, der ein Formulat aufruft.
Ich sehe dass hier unter anderem einiges an JavaScript eingesetzt wird.

Wenn ich auf der duplizieren Seite diesen Code-Block entferne speichert die Seite in weniger als 20 Sekunden.

Entferne ich dann weitere der verwendeten Blöcke sinkt die Verabreitungszeit auf 15 Sekunden, wenn ich zum Beispiel nur den Header und die erste Sektion verwenden.

Die Anzahl der aktiven Sprachen spielt hier wohl keine große Rolle. Ich habe fast die gleiche Ladezeit, selbst wenn ich mit nur zwei aktiven Sprachen teste (13 Sekunden).

Ein letzter Test auf dieser duplizierten Seite mit gemindertem Inhalt dauerte ohne WPML etwa 10 Sekunden, um die Seite zu speichern.

Ich sehe folglich auch ohne WPML eine recht hohe Bearbeitungszeit und je mehr Inhalt die Seite, um so mehr Zeit benötigt dann zusätzlich WPML, um die Inhalte zu verarbeiten.
Dies sollte verdeutlichen, dass die Speicherzeit durchaus mit der Art und dem Umfang der Divi-Inhalte in Verbindung steht.

Ich würde gerne nochmals probieren, ob sich dieses Problem replizieren lässt, wenn ich ein gleichartiges Setup und den gleichen Seiteninhalt verwende.

Ich habe nur leider nicht die aktuellste Version von Divi verfügbar. Könntest Du bitte Divi in aktuellster Version auf folgender Test-Site installieren?

Ein-Klick-Anmeldung:
hidden link

Ich werde dann dort deine Homepage importieren und erneut testen.

Bitte, falls möglich, füge auch das Divi Essentials Plugin hinzu, damit wir ebenso testen können, ob dessen verwendete Widgets korrekt übersetzt werden können.

Mit freundlichen Grüßen
Andreas

April 12, 2022 um 8:55 am #11001467

pabloS-10

Hi Andreas,
ich habe beides hinzugefügt.

April 13, 2022 um 12:51 am #11007645

Andreas W.
Supporter

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich hatte leider ausversehen die Zugangsdaten zu Deiner Website bereits aus dem Ticket entfernt.

Bitte erteile mir nochmals Admin-Zugriff zu Deiner Website, damit ich Deinen Seiteninhalt auf meiner Sandbox importieren kann, um dann nochmals zu testen oder importiere die Seiten einfach selbst unter Tools > Import > WordPress > Run importer

hidden link

Das private Antwortformular ist erneut aktiviert.

Sollte dieser abschließende Test nicht zu dem gleichen Ergebnis führen, werde ich Morgen eine Kopie Deiner Website an unseren Second Tier Support weiterleiten, damit dieser sich diese duplzierten Querries und das Problem mit der langen Ladezeit genauer ansehen kann.

Mit freundlichen Grüßen
Andreas

April 13, 2022 um 5:42 pm #11015809

Andreas W.
Supporter

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich hatte noch eine Kopie Deiner Website, die ich glücklicherweise noch nicht gelöscht hatte.

Auf meiner Test-Site habe ich nun Deine Seiten importiert und zahlreiche Sprachen aktiviert und die Bearbeitungszeit beim Speichern der Hompage ist hier nahezu identsich bei etwa 20 Sekunden.

Teste ich mit nur zwei aktiven Sprachen dauert es weiterhin gut 13 Sekunden Deine Homepage zu speichern.

Ohne WPML speichert Deine Homepage in etwa 5-7 Sekunden.

Teste ich mit nur zwei aktiven Sprachen auf einer Seite, die sehr geringen Inhalt hat, dauert es weiterhin gut 8 Sekunden die Seite zu speichern (WPML mit zwei Sprachen)

Es scheint im Grunde, als ist eine solch lange Bearbeitungszeit auf Grund der Anzahl der aktivierten Sprachen zu erwarten.

Zum weiteren Vorgehen mit diesem Thema werde ich nun unseren Second Tier Support konsultieren und mich dann zurückmelden.

Mit freundlichen Grüßen
Andreas

April 22, 2022 um 12:34 pm #11074745

pabloS-10

Hi
Is there any update on this?

April 23, 2022 um 1:05 am #11081543

Andreas W.
Supporter

Timezone: America/Lima (GMT-05:00)

Hallo,

Entschuldige bitte die Verzögerung.

Hast Du auf Deiner Website bereits auf Divi 4.17.3 aktualisiert und erneut getestet?

Ich hatte vor einigen Tagen mit einer Vorversion von Divi auf einer neuen WordPress Test-Site folgendes replizieren können:

Die Website verwendet 19 aktive Sprachen.

Divi ist so eingestellt, dass es den klassischen Editor unter Divi> Designoptionen> Builder> Erweitert verwendet.

Alle Inhalte hatte ich aus Deiner Website importiert.

Ergebnis:

Die Homepage benötigt 20 Sekunden zum Aktualisieren, wenn WPML mit 16 aktiven Sprachen verwendet wird.
Die Homepage benötigt 8 Sekunden zum Aktualisieren, wenn WPML mit 2 aktiven Sprachen verwendet wird.
Die Homepage benötigt 5-7 Sekunden zum Aktualisieren ohne WPML

Der Second Tier Support bat mich darum dies nochmals versuchen zu replizieren und intern als Perofrmance-Problem zu eskalieren.

Wenn ich allerdings aktuell (Divi 4.17.1) eine neue WordPress-Intallation aufsetze, und mit einem neuen Post oder einen neuen Seite testen, ohne Deine Inhalte zu importieren, so kann ich das Problem leider nicht mehr replizieren.

Du kannst das hier selbst testen:
hidden link

Die aktuelle Version voN divi ist 4.17.3. Es wäre sehr hilfreich, wenn du diese installieren und folgendes bestätigen könntest:

Mein Test Post speichert in etwa 7 Sekunden, egal ob mit oder ohne WPML und unbeachtet von der Anzahl aktiver Sprachen.

Wenn der Gutenberg Editor und das Divi Forntend verwendet wird (Kein Divi Classic Modus) scheint die Website sogar noch schneller zu speichern.

Sollte sich das Problem weiterhin nicht replizieren lassen, bitte ich Dich mir nochmals Zugriff auf Deiner Website zu erteilen.

Eventuell wäre es ratsam wir testen die Übersetzungen mit aktuellem Debug um festzustellen, ob hier Fehler vorliegen.

Zudem würde ich gerne auf Deiner Website mit einem neu erstellten Inhalt testen.

Solltest Du mir Zugriff auf eine Staging-Site geben können, dann w8re dies dieal zum Testen.

Das private Antwortformular ist erneut aktiviert.

Mit freundlichen Grüßen
Andreas

April 26, 2022 um 2:05 pm #11097545

pabloS-10

Hi,
ich habe alle updates eingespielt und kann nach wie vor leider keine veränderung feststellen.
Es sind immernoch mindestens 20 Sekunden beispielsweise für die Startseite.

Der Zugang den wir schonmal vergeben haben ist nach wie vor aktiv falls ihr diesen noch habt oder soll ich nochmals neu die Zugangsdaten angeben?

April 27, 2022 um 5:16 am #11102109

Andreas W.
Supporter

Timezone: America/Lima (GMT-05:00)

Hallo,

Tut mir leid zu hören, dass die Updates das Problem nicht lösen konnten.

Bitte erteile mir erneut Zugriff zur Website. Besser wäre ein Klon oder eine Staging Site, auf der sich das Problem replizieren lässt.

Du kannst gerne die vorher verwendeten Daten angeben, ich hatte nur die allte private Nachricht versehentlich entfernt.

Die dafür erforderlichen Felder findst Du unterhalb des Kommentarbereichs, wenn Du dich anmelden, um die nächste Antwort zu hinterlassen. Die Informationen, die Du angibst sind privat, was bedeutet, dass nur Du und ich sie sehen und darauf zugreifen können.

WICHTIG
Lege bitte unbedingt eine Sicherungskopie der Website und der Datenbank an, bevor Du uns den Zugriff gewährst.
Wenn Du die Felder "wp-admin / FTP" nicht sehen kannst, werden Ihre Anmeldedaten für Post und Website als "PUBLIC" (Öffentlich) festgelegt. Veröffentliche die Daten NICHT, es sei denn, Du siehst die erforderlichen wp-admin / FTP-Felder.

Das private Antwortformular sieht so aus:
hidden link

Klicke beim nächsten Antworten auf "I still need assistance".

Video:
hidden link

Sobald ich Zugriff habe, werde ich eine Kopie der Website intern eskalieren, damit sich der Second Tier Support dies einmal genauer ansieht.

Mit freundlichen Grüßen
Andreas

April 27, 2022 um 7:05 am #11102415

Andreas W.
Supporter

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich hatte glücklicherweise noch eine lokale Kopie Deiner Website auf meinem virtuellen Server und konnte das Problem mit der 20 Sekunden Ladezeit ebenso mit Deiner Homepage auf einer neuen WordPress-Installation alleine mit Divi und WPML nachstellen.

Auf anderen Seiten sehe ich allerdings eine normale Ladezeit und wenn ich die Hompage dupliziere scheint sich das Problem zu lösen, sobald ich die deaktivierten Sektionen (Rows) aus der Seite entferne.

Auf einer neuen Seite konnte ich das Problem bislang leider nicht replizieren, selbst dann wenn ich zahlreiche deaktivierte Sektionen in die Seite einbaue.

Das Problem wurde nun intern an unser Kompatilbitätsteam weitergeleitet und ich werde mich wieder melden, sobald ich dazu nähre Informationen habe.

Momentan benötige ich keinen weiteren Zugriff zu Deiner Website.

Mit freundlichen Grüßen
Andreas

April 30, 2022 um 10:10 pm #11127237

Andreas W.
Supporter

Timezone: America/Lima (GMT-05:00)

Hello,

Our team is having some issues with finding the cause for the issue on your site.

Could you please clarify for me according to what I realized on your site copy:

1) The issue only occurs on one page (Homepage) and other pages are not affected, correct?

2) As a workaround, does recreating the page from scratch solve the issue?

Best regards
Andreas

Das Thema ‘[Geschlossen] Backend extrem langsam’ ist für neue Antworten geschlossen.