Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Schlagwörter: 

This topic contains 14 Antworten, has 3 Teilnehmer.

Last updated by Andreas W. vor 11 Stunden, 33 Minuten.

Assigned support staff: Andreas W..

Autor Beiträge
November 18, 2019 um 8:35 am #4962773

lutzH-2

Ich versuche: mit WPBakery erstellte Seiten übersetzen

URL der/meiner Website, auf der das Problem auftritt: hidden link

Erwartet hatte ich zu sehen: fehlerfreie Übersetzung

Stattdessen bekam ich: zusätzliches Backslash \ vor Anführungszeichen " und Apostrophen ' (siehe Screenshot)
Die anderen Übersetzungsseiten habe ich inzwischen per Suchen und Ersetzen im externen Editior und wieder einfügen des Sourcecodes korrigiert, nur die tschechische Übersetzung ist aktuell noch fehlerhaft belassen.

November 18, 2019 um 2:04 pm #4965723

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hallo,

Vielen Dank, dass Sie den WPML Support kontaktiert haben.

Mit welchem WPBakery Element ist das Problem genau aufgetreten?
Passierte dies auch in der Default Language?

Bitte um Info

Freundliche Grüße
Marcel

November 18, 2019 um 7:52 pm #4967507

lutzH-2

Hallo Marcel,

das Problem tritt mit Einzelbildern, Textelementen, Layouts usw. auf, es passiert nicht mit einem einzelnen Element und ist davon abhängig, ob ein Anführungszeichen " und/oder Apostroph ' vorhanden ist.
In der Basissprache deutsch wird alles korrekt gespeichert, nur bei den Übersetzungen werden die Backslashs hinzugefügt.

VG,
Lutz

November 19, 2019 um 8:51 am #4969541

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hallo Lutz,

Ich würde mir das gerne direkt auf Ihrer Seite ansehen. Dazu bräuchte ich bitte temporären Zugriff (WP-Admin und FTP) auf Ihre Seite, vorzugsweise zu einer Test/Staging Seite, an der das Problem nach Möglichkeit repliziert wurde. Bitte hängen Sie ebenso einen Link zu einem Beispiel an.

Ihre nächste Antwort ist als „Privat“ markiert, dies bedeutet nur Sie und ich haben Zugriff darauf.

❌ Bitte sichern Sie Ihre Datenbank und Website davor ❌

✙ Ich würde außerdem Ihre Erlaubnis benötigen, um Plugins und das Theme zu deaktivieren und erneut zu aktivieren sowie Konfigurationen auf der Seite zu ändern. Dies ist auch der Grund, warum das Backup wirklich wichtig ist.

Freundliche Grüße
Marcel

November 28, 2019 um 6:14 pm #5038989

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hallo Lutz,

danke für den Zugang, ich konnte es sehen. Der Backslash ist das "Escaping" der Sonderzeichen. Nun müssen wir herausfinden, warum dies auf Ihrer Installation nicht korrekt dargestellt wird.

#1 Bitte installieren Sie den WPBakery Builder auf folgender isolierten Sandbox Umgebung und versuchen Sie das Problem nachzustellen. WPML ist dazu bereits in Englisch + Französisch und Tschechisch vorkonfiguriert. Dann wissen wir, ob dies ein Bug ist, oder ob Ihre Installation/Datenbank dies auslöst. hidden link

#2 Wenn Sie es nachstellen können, kann ich den Fall an unsere Entwickler eskalieren.

Bitte um Info

Freundliche Grüße
Marcel

November 28, 2019 um 8:09 pm #5039443

lutzH-2

Hallo Marcel,

vielen Dank schon mal.
Ich habe die Version 6.0.5 gerade in der Sandbox installiert und aktiviert.

Viele Grüße,
Lutz

November 29, 2019 um 5:29 pm #5045243

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hallo Lutz,

danke! Bitte versuchen Sie das Problem mit Ihren Beispieltexten in den 3 Sprachen nachzustellen, dann sehen wir welche Sonderzeichen Probleme verursachen.

Vielen Dank

Freundliche Grüße
Marcel

Dezember 2, 2019 um 9:31 am #5051681

lutzH-2

Hallo Marcel,

in unserem Backend ist der WPML-Editor aktiv und wird für die Übersetzungen genutzt, in der Sandbox ist das aber nicht vorhanden. Kann das für den Test aktiviert werden?

VG,
Lutz

Dezember 2, 2019 um 10:05 pm #5057107

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Mein Kollege Marcel ist diese Woche leider nicht verfügbar, aber ich helfe Ihnen gerne weiter.

Der WPML Übersetzungseditor ist per standard nicht aktiv. Er kann generell unter WPML -> Einstellungen aktiviert werden.

Sie können ihn allerdings auch, wie auf Ihrem Screenshot, in den Sprachoptionen auf der Seitenleiste des Seiteneditor für alles Seiten aktivieren.

Lassen Sie uns bitte wissen, ob das Problem auch auf der neuen Installtion auftritt. Sollte es das nicht tun, könnte das Problem an einem zusätzlich verwendeten Plugin liegen.

Um dies zu prüfen, müssten Sie Ihre Live-Site in einem minimalen Setup auszuführen:

Bitte deaktivieren Sie alle zusätzlichen Plugins, die nicht mit WPML und seinen Add-Ons zusammenhängen.

Sollte das Problem behoben sein, aktivieren Sie die Plugins erneut oder aktivieren Sie sie in kleinen Gruppen. Überprüfen Sie auf diese Weise, an welchen Stellen das Problem erneut auftritt, und geben Sie das Plugin an, das das Problem verursacht.

Wechseln Sie auch zu einem Standardthema wie TwentySeventeen, um festzustellen, ob das Problem möglicherweise mit dem Thema zusammenhängt.

Auf diese Weise könnten wir der Ursache des Problem näher kommen.

Mit freundlichen Grüßen,
Andreas

Dezember 6, 2019 um 11:33 am #5083407

lutzH-2

Hallo Andreas,

irgendwie finde ich in der Sandbox die Einstellmöglichkeit für den Editor nicht. Da mein Kunde diesen nutzt, möchte ich das gern aktivieren und damit testen. Können sie mir da bitte helfen?

VG,
Lutz

Dezember 6, 2019 um 11:07 pm #5086217

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Könnten Sie mir bitte genauere Angaben dazu machen, auf welchen Editor Sie sich beziehen?
Bitte senden Sie mir einen Screenshot.

Sollten Sie sich auf den WordPress Classic Editor beziehen, ich habe dieses Plugin nun installiert.

Sollten Sie sich auf den WPML Übersetzungseditor beziehen, so habe ich nun die klassische Version aktivieren. Die Option war nicht verfügbar, weil das Plugin Translation Management noch nicht aktiviert war. Sollten Sie den erweiterten Editor verwenden wollen, so informieren Sie mich bitte, da ich in diesem Fall einige Änderungen vornehmen muss. Die Option wird nicht funktionieren solange es User gibt, die keinen gültigen Namen oder E-Mail besitzen.

Mit freundlichen Grüßen
Andreas

Dezember 7, 2019 um 8:14 am #5086575

lutzH-2

Hallo Andreas,

danke fürs aktivieren.
Es geht um den WPML Advanced Translation Editor. Es wäre nett, wenn sie den aktivieren könnten.

Viele Grüße,
Lutz

Dezember 9, 2019 um 2:30 pm #5093557

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Der WPML Advanced Translation Editor ist nun aktiv. Sie müssen nur die folgenden Nutzerdaten verwenden, um sich anzumelden:

Login: hidden link
Username: wpml
Password: support

Mit freundlichen Grüßen
Andreas

Dezember 9, 2019 um 8:57 pm #5096021

lutzH-2

Hallo Andreas,

vielen Dank. Klappt soweit.
Ich habe jetzt nur eine andere Ansicht des Editors als auf unserer Seite (siehe Screenshot).
Woher kommt die unterschiedliche Darstellung? Ist das über die Settings einstellbar?

VG,
Lutz

Dezember 9, 2019 um 10:23 pm #5096233

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo Lutz,

Unser Plugin hat momentan zwei verschiedene Übersetzungeditoren.

Der Classic Translation Editor und der Advanced Translation Editor.

Unter "WPML -> Einstellungen -> Wie Sie Beiträge und Seiten übersetzen" können Sie die bevorzugte Variante wählen, es ist allerdings nicht ratsam diese zu wechseln, weil es zu Verlust von Übersetzungen führen kann.

Deshalb haben wir eine Zusatzoption hinterlegt, mit der sich festlegen lässt, dass alte Inhalte, die bereits mit dem alten Classic Translation Editor übersetzt wurden, weiterhin den gleichen alten Editor verwenden, sollte der neue Advanced Translation Editor für neue Inhalte aktiviert wordern sein.

Hier mehr Informationen:

Classic Translation Editor:
https://wpml.org/de/documentation-3/ubersetzen-ihrer-inhalte/verwendung-des-translation-management-moduls-von-wpml/

Advanced Translation Editor:
https://wpml.org/documentation/translating-your-contents/advanced-translation-editor/

Vertsehe ich nun richtig, dass die Übersetzung vorher mit dem Classic Translation Editor nicht funktioniere, es allerdings mit dem Advanced Translation Editor funktioniert?

Mit freundlichen Grüßen
Andreas