Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

This topic contains 11 Antworten, has 2 Teilnehmer.

Last updated by Marcel vor 5 Monate, 1 Woche.

Assigned support staff: Marcel.

Author Artikel
April 24, 2019 um 7:07 am #3669743

radomirG

Tell us what you are trying to do?
Bei einer kleinen Änderung auf der deutschen Seite, wird der komplette Inhalt auf der übersetzten englischen Seite wieder auf deutsch überschrieben. Welche Einstellungen muss ich vornehmen, dass dies nicht passiert?

Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site?

April 24, 2019 um 3:56 pm #3674941

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Radomir,

Vielen Dank, dass Sie den WPML Support kontaktiert haben.

#1 Können Sie mir bitte einen Screenshot aus dem Backend anhängen, wo das Problem genau auftritt?

#2 Bitte aktualisieren Sie zuvor ebenso alle WPML Add-Ons.
Ich empfehle Ihnen davor ein Backup Ihrer Seite und Datenbank durchzuführen.

Bitte geben Sie mir Bescheid. Vielen Dank.

Freundliche Grüße
Marcel

April 25, 2019 um 6:53 am #3679205

radomirG

Habe gerade bei Apart Relax mit der Seite Gallery und Contact getestet und es hat leider nicht funktioniert. Nach einer kleinen Änderung auf der deutschen Seite war die komplette englische Seite wieder auf DE….Das ist echt blöd...
https:apart-relax.com
Alles ist aktualisiert

lg

April 25, 2019 um 7:19 am #3679453

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Radomir,

können Sie bitte einen Screenshot aus dem Backend anhängen? Ich sehe beide Seiten statt Englisch in Deutsch. ich müsste sehen wie die Seiten angelegt bzw. ob diese mit der Duplizier Funktion erstellt wurden. Dies ist in der rechten Seitenleiste ersichtlich. Ist das JupiterX Parent Theme auch aktuell?

Was genau wurde am Content geändert?

Freundliche Grüße
Marcel

April 25, 2019 um 7:47 am #3679651

radomirG

Hallo, danke für rasche Antwort. Hier sind die Screenshot, ich kann ihnen auch Zugangsdaten zusenden wenn sie möchten, sagen sie mir nur als Admin oder reichr redaktuer?

April 25, 2019 um 10:20 am #3681071

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Radomir,

vielen Dank für die Screenshots. Das sieht soweit alles in Ordnung aus.

Ich bräuchte bitte temporären Zugriff (WP-Admin und FTP) auf Ihre Seite, vorzugsweise zu einer Test/Staging Seite, an der das Problem nach Möglichkeit repliziert wurde.

Ihre nächste Antwort ist als „Privat“ markiert, dies bedeutet nur Sie und ich haben Zugriff darauf.

❌ Bitte sichern Sie Ihre Datenbank und Website davor ❌

✙ Ich würde außerdem Ihre Erlaubnis benötigen, um Plugins und das Theme zu deaktivieren und erneut zu aktivieren sowie Konfigurationen auf der Seite zu ändern. Dies ist auch der Grund, warum das Backup wirklich wichtig ist.

Freundliche Grüße
Marcel

Mai 1, 2019 um 7:59 am #3716757

radomirG

Hallo,

haben Sie Zugangsdaten bekommen, bzw. funktioniern die?
Bitte um kurze Antwort?

Lg RAtko

Mai 1, 2019 um 7:46 pm #3719629

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Ratko,

bitte entschuldigen Sie die Verzögerung meiner Antwort.

Ich habe zuerst Elementor aktualisiert. Dann habe ich den Text sowie die Überschriften in Deutsch bearbeitet, abgespeichert und in EN wurde bei meinem Versuch nichts zurückgesetzt. Die Änderungen sind noch aktiv. ("Test 2x im Text, sowie in der Überschrift)

Können Sie es bitte ebenso nochmals probieren?
Falls es nochmals auftritt, können Sie mir die genauen Schritte die Sie machen aufzeigen? Passierte dies nur bei Überschriften?

Vielen Dank
Freundliche Grüße
Marcel

Mai 3, 2019 um 7:38 pm #3737699

radomirG

Hallo

Habe gerade mit der Seite „KONTAKTE“ bei Apart Relax getestet. Leider immer noch dasselbe Problem.

Habe folgende Schritte durchgeführt:

Die EN Seite von „KONTAKT“ mit Elementor bearbeitet, sprich alles auf Englisch übersetzt.
Danach bin ich auf die DE Seite „KONTAKT“ – mit Elementor bearbeiten – habe bei der Überschrift KONTAKT lediglich ein E dazugefügt (KONTAKTE) und gespeichert.
Nach Kontrolle der EN Seite war keine einzige Silbe mehr auf Englisch, also entsprach die EN Seite zu 100% der DE Version.

LG RATKO

Mai 7, 2019 um 6:08 pm #3761077

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Radko,

bitte entschuldigen Sie die erneute Verzögerung, ich musste hier nun einige Dinge für Elementor überprüfen sowie Tests durchführen.

Wie es aussieht, wird durch die Duplizier Funktion die Übersetzung überschrieben. Ich konnte es lt. Ihrer Beschreibung nachstellen. Die Duplizier Funktion ist für die Seiten "Kontakt" sowie "Gallery" aktiv. Ich habe dies nun für Kontakt deaktiviert, die Übersetzung ist nun für diese Seite eigenständig.

Können Sie bitte wie in der Anleitung beschrieben den WPML Translation Editor aktivieren und es erneut versuchen? https://wpml.org/documentation/plugins-compatibility/elementor/#adding-a-new-element-to-the-page-and-updating-the-translation

Haben Sie ggf. früher den WPML Translation Editor sowie den nativen Editor abwechselnd bei dieser Seite verwendet?

Beste Grüße
Marcel

Mai 8, 2019 um 10:04 am #3765319

radomirG

HAllo,
danke für ausführliche Mail.

Ja, wir haben früher den WPML Translation Editor sowie den nativen Editor abwechselnd bei dieser Seite verwendet!? Aus verzweiflung, wussten wir nicht was wir machen sollen!

Wie sollen wir jetzt vorgehen?

Lg Ratko

Mai 9, 2019 um 7:49 am #3773859

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Radko

danke für die Info. Dann bestätigte sich mein Verdacht. Ein Kollege erzählte mir von einem ähnlichen Fall wo Elementor genau dieses Problem verursachte, wenn beide Editoren abwechselnd verwenden wurden. Die Lösung war wie oben beschrieben alle Seiten nach folgender Anleitung einzustellen:

https://wpml.org/documentation/plugins-compatibility/elementor/#adding-a-new-element-to-the-page-and-updating-the-translation

Die Funktion "Use WPML Translation Editor" wird das Problem beheben.

Beste Grüße
Marcel