Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Our next available supporter will start replying to tickets in about 4.70 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: Meine Testumgebung lädt nicht die HauptURL, nur wenn ich direkt /en oder /de anhänge. Dies passiert nur auf der Staging Seite und nicht auf der Produktivumgebung.

Solution: Eine Neueinrichtung der Testumgebung löste das Problem.

Relevant Documentation: https://wpml.org/documentation/getting-started-guide/language-setup/directory-default-language/

Schlagwörter: 

This topic contains 12 Antworten, has 2 Teilnehmer.

Last updated by Martin vor 3 Monate.

Assigned support staff: Marcel.

Autor Beiträge
Juli 17, 2019 um 5:24 am #4225961

Martin

Hallo

Ich habe einen Klon von einer Website erstellt.
Es funktioniert soweit alles, nur die Weiterleitung von der "Haupt-URL" klappt nicht.
Wenn man die Website mit /de oder /fr aufruft, klappt alles.

Woran könnte dies liegen?

Hier wären die Logins:
(Removed from WPML Support)

Danke & Lg
Chrigi

Juli 17, 2019 um 11:09 am #4229241

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Chrigi,

Vielen Dank, dass Sie den WPML Support kontaktiert haben.
Ich habe Ihre Logindaten entfernt und in eine private Nachricht eingefügt, da diese öffentlich einsehbar waren.

Sie meinen hidden link zeigt eine weiße Seite, oder?

Ich habe folgendes überprüft:
#1 Sie haben ein zu geringes WP Memory Limit. Dies habe in der wp-config.php angepasst. (von 40MB auf 256MB erhöht: define ('WP_MEMORY_LIMIT', '256M');)
#2 .htaccess sieht soweit korrekt aus
#3 Permalinks habe ich erneut abgespeichert
#4 Sie haben unter hidden link ""Verzeichnis für Standardsprache benutzen" aktiviert. Benötigen Sie diese Funktion?

Bitte um Info

Freundliche Grüße
Marcel

Juli 17, 2019 um 11:52 am #4229715

Martin

Hi Marcel

Genau, das wäre die richtige Domäne.

#1 Danke 🙂
#4 Ich möchte, dass die Standardwebsite unter /de läuft, das es einheitlich aussieht.

Bei der "Live-Website" funktioniert es mit den genau gleichen Angaben einwandfrei.

P.S. Wird dieses Support-Ticket bei Google indexiert? Wäre schon, wenn man die dev-Domäne nicht sehen würde 😉

Juli 18, 2019 um 8:38 am #4236029

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Martin,

vielen Dank für die Info.

#1 Sind die WPML Einstellungen dazu auf beiden Seiten identisch? (Folder Option sowie die Checkbox darunter)
#2 Können Sie mir bitte Ihre .htaccess der Produktseite anfügen? Dies sieht stark nach einem Redirect Problem Ihres Servers aus. Bei der Hauptseite bekomme ich einen Status 200 (OK) zurück, hier sollte jedoch ein 301 Redirect aktiv sein:

>>> <em><u>hidden link</u></em>

> --------------------------------------------
> 301 Moved Permanently
> --------------------------------------------

Status:	301 Moved Permanently
Code:	301
Content-Type:	text/html; charset=UTF-8
Expires:	Wed, 17 Jul 2019 16:41:10 GMT
Cache-Control:	max-age=3600
X-Redirect-By:	WordPress
Location:	<em><u>hidden link</u></em>
X-LiteSpeed-Cache:	hit
Content-Length:	0
Date:	Thu, 18 Jul 2019 08:36:18 GMT
Alt-Svc:	quic=":443"; ma=2592000; v="35,39,43,44"
Connection:	close

PS: Ja das Ticket wird indexiert, jedoch haben wir eine URL-Whitelist aktiv. Es ist somit keine URL erkennbar 🙂

Freundliche Grüße
Marcel

Juli 18, 2019 um 12:38 pm #4238699

Martin

Hi Marcel

#1 Ja diese sind 1:1 genau gleich
#2 Sieht wie folgt aus:

# BEGIN LSCACHE
## LITESPEED WP CACHE PLUGIN - Do not edit the contents of this block! ##
<IfModule LiteSpeed>
RewriteEngine on
CacheLookup on
RewriteRule .* - [E=Cache-Control:no-autoflush]
RewriteRule ^min/\w+\.(css|js) - [E=cache-control:no-vary]

### marker FAVICON start ###
RewriteRule favicon\.ico$ - [E=cache-control:max-age=86400]
### marker FAVICON end ###

</IfModule>
## LITESPEED WP CACHE PLUGIN - Do not edit the contents of this block! ##
# END LSCACHE
# BEGIN NON_LSCACHE
## LITESPEED WP CACHE PLUGIN - Do not edit the contents of this block! ##
### marker MINIFY start ###
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{DOCUMENT_ROOT}%{REQUEST_URI} ^(.*)/min/(\w+)\.(css|js)$
RewriteCond %1/wp-content/cache/$2/$1.$2 -f
RewriteRule min/(\w+)\.(css|js) wp-content/cache/$2/$1.$2 [L]
</IfModule>
### marker MINIFY end ###

## LITESPEED WP CACHE PLUGIN - Do not edit the contents of this block! ##
# END NON_LSCACHE

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress
AddHandler application/x-httpd-php73 .php
Juli 18, 2019 um 1:16 pm #4239003

Martin

Ich teste das ganze kurz mit einer neuen Installation.

Nur zur Info 😉

Lg
Chrigi

Juli 18, 2019 um 1:21 pm #4239053

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Geht in Ordnung 🙂

Soweit ich bereits gesehen habe war

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

aktiv.

Freundliche Grüße
Marcel

Juli 18, 2019 um 1:26 pm #4239073

Martin

Habe es kurz bei einer neuen WordPress Installation getestet und erhalte folgende Fehlermeldung:

Ein Fehler vom Typ E_ERROR wurde in der Zeile 22 der Datei /home/electro5/public_html/dev-web.electrosuisse.ch/wp-content/plugins/sitepress-multilingual-cms/classes/url-handling/resolver/class-wpml-resolve-object-url-helper-factory.php verursacht. Fehlermeldung: Uncaught Error: Class 'WPML_Translate_Link_Targets' not found in /home/electro5/public_html/dev-web.electrosuisse.ch/wp-content/plugins/sitepress-multilingual-cms/classes/url-handling/resolver/class-wpml-resolve-object-url-helper-factory.php:22
Stack trace:
#0 /home/electro5/public_html/dev-web.electrosuisse.ch/wp-content/plugins/sitepress-multilingual-cms/classes/API/Hooks/class-wpml-api-hooks-factory.php(30): WPML_Resolve_Object_Url_Helper_Factory->create('absolute')
#1 /home/electro5/public_html/dev-web.electrosuisse.ch/wp-content/plugins/sitepress-multilingual-cms/classes/action-filter-loader/class-wpml-action-filter-loader.php(144): WPML_API_Hooks_Factory->create()
#2 /home/electro5/public_html/dev-web.electrosuisse.ch/wp-content/plugins/sitepress-multilingual-cms/classes/action-filter-loader/class-wpml-action-filter-loader.php(92): WPML_Action_Filter_Loader->run_factory(Object(WPML_API_Hooks_Factory))
#3 /home/electro5/public_html/dev-web.electrosuisse.ch/wp-content/plugins/sitepress-multilingual-cms/cl
Juli 18, 2019 um 1:31 pm #4239113

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

E_Error sind gruppierte Meldungen aus dem WordPress Health Monitor.

Könnten Sie bitte das volle PHP Debugging auf Ihrer Seite aktivieren? Dann sehen wir was davor passiert.
Dazu bitte die wp-config.php Datei öffnen und nach folgender Zeile suchen:

define('WP_DEBUG', false);

Diese bitte auf folgende Werte ändern. Damit wird das Debugging eingeschaltet sowie die Logausgabe aktiviert:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', true ); 

Es werden dann etwaige Fehler auf direkt auf der Seite angezeigt und eine "debug.log" Datei unter /wp-content/ geschrieben.

Anbei eine Dokumentation (in Englisch):
https://codex.wordpress.org/Debugging_in_WordPress

Freundliche Grüße
Marcel

Juli 18, 2019 um 1:52 pm #4239335

Martin

Hier wäre der Inhalt der debug.log

[18-Jul-2019 13:52:06 UTC] PHP Fatal error:  Uncaught Error: Class 'WPML_Translate_Link_Targets' not found in /home/electro5/public_html/dev-web.electrosuisse.ch/wp-content/plugins/sitepress-multilingual-cms/classes/display-as-translated/class-wpml-fix-links-in-display-as-translated-content-factory.php:16
Stack trace:
#0 /home/electro5/public_html/dev-web.electrosuisse.ch/wp-content/plugins/sitepress-multilingual-cms/classes/action-filter-loader/class-wpml-action-filter-loader.php(144): WPML_Fix_Links_In_Display_As_Translated_Content_Factory->create()
#1 /home/electro5/public_html/dev-web.electrosuisse.ch/wp-content/plugins/sitepress-multilingual-cms/classes/action-filter-loader/class-wpml-action-filter-loader.php(92): WPML_Action_Filter_Loader->run_factory(Object(WPML_Fix_Links_In_Display_As_Translated_Content_Factory))
#2 /home/electro5/public_html/dev-web.electrosuisse.ch/wp-content/plugins/sitepress-multilingual-cms/classes/action-filter-loader/class-wpml-action-filter-loader.php(76): WPML_Action_Filter_Loader->load_factory(Object(WPML_Fix_Links_In_ in /home/electro5/public_html/dev-web.electrosuisse.ch/wp-content/plugins/sitepress-multilingual-cms/classes/display-as-translated/class-wpml-fix-links-in-display-as-translated-content-factory.php on line 16
[18-Jul-2019 13:52:06 UTC] PHP Fatal error:  Uncaught Error: Call to a member function get_requested_lang() on null in /home/electro5/public_html/dev-web.electrosuisse.ch/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php:1102
Stack trace:
#0 /home/electro5/public_html/dev-web.electrosuisse.ch/wp-content/plugins/sitepress-multilingual-cms/classes/utilities/class-wpml-locale.php(104): SitePress->get_current_language()
#1 /home/electro5/public_html/dev-web.electrosuisse.ch/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php(3361): WPML_Locale->locale()
#2 /home/electro5/public_html/dev-web.electrosuisse.ch/wp-includes/class-wp-hook.php(286): SitePress->locale_filter('de_DE')
#3 /home/electro5/public_html/dev-web.electrosuisse.ch/wp-includes/plugin.php(208): WP_Hook->apply_filters('de_DE', Array)
#4 /home/electro5/public_html/dev-web.electrosuisse.ch/wp-includes/l10n.php(75): apply_filters('locale', 'de_DE')
#5 /home/electro5/public_html/dev-web.electrosuisse.ch/wp-includes/l10n.php(131): get_locale()
#6 /home/electro5/public_h in /home/electro5/public_html/dev-web.electrosuisse.ch/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php on line 1102
[18-Jul-2019 13:52:08 UTC] PHP Fatal error:  Uncaught Error: Class 'WPML_Translate_Link_Targets' not found in /home/electro5/public_html/dev-web.electrosuisse.ch/wp-content/plugins/sitepress-multilingual-cms/classes/display-as-translated/class-wpml-fix-links-in-display-as-translated-content-factory.php:16
Stack trace:
#0 /home/electro5/public_html/dev-web.electrosuisse.ch/wp-content/plugins/sitepress-multilingual-cms/classes/action-filter-loader/class-wpml-action-filter-loader.php(144): WPML_Fix_Links_In_Display_As_Translated_Content_Factory->create()
#1 /home/electro5/public_html/dev-web.electrosuisse.ch/wp-content/plugins/sitepress-multilingual-cms/classes/action-filter-loader/class-wpml-action-filter-loader.php(92): WPML_Action_Filter_Loader->run_factory(Object(WPML_Fix_Links_In_Display_As_Translated_Content_Factory))
#2 /home/electro5/public_html/dev-web.electrosuisse.ch/wp-content/plugins/sitepress-multilingual-cms/classes/action-filter-loader/class-wpml-action-filter-loader.php(76): WPML_Action_Filter_Loader->load_factory(Object(WPML_Fix_Links_In_ in /home/electro5/public_html/dev-web.electrosuisse.ch/wp-content/plugins/sitepress-multilingual-cms/classes/display-as-translated/class-wpml-fix-links-in-display-as-translated-content-factory.php on line 16
[18-Jul-2019 13:52:08 UTC] PHP Fatal error:  Uncaught Error: Call to a member function get_requested_lang() on null in /home/electro5/public_html/dev-web.electrosuisse.ch/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php:1102
Stack trace:
#0 /home/electro5/public_html/dev-web.electrosuisse.ch/wp-content/plugins/sitepress-multilingual-cms/classes/utilities/class-wpml-locale.php(104): SitePress->get_current_language()
#1 /home/electro5/public_html/dev-web.electrosuisse.ch/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php(3361): WPML_Locale->locale()
#2 /home/electro5/public_html/dev-web.electrosuisse.ch/wp-includes/class-wp-hook.php(286): SitePress->locale_filter('de_DE')
#3 /home/electro5/public_html/dev-web.electrosuisse.ch/wp-includes/plugin.php(208): WP_Hook->apply_filters('de_DE', Array)
#4 /home/electro5/public_html/dev-web.electrosuisse.ch/wp-includes/l10n.php(75): apply_filters('locale', 'de_DE')
#5 /home/electro5/public_html/dev-web.electrosuisse.ch/wp-includes/l10n.php(131): get_locale()
#6 /home/electro5/public_h in /home/electro5/public_html/dev-web.electrosuisse.ch/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php on line 1102
Juli 18, 2019 um 2:07 pm #4239527

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Vielen Dank!

Ich habe unseren 2nd Tier bezüglich Ihres Falls kontaktiert und warte nun auf eine Rückmeldung. Ich gebe Ihnen schnellstmöglich Bescheid, wenn ich eine Rückmeldung erhalte.

Freundliche Grüße
Marcel

Juli 19, 2019 um 10:05 am #4245573

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Martin,

können Sie bitte auf der Produktseite folgendes überprüfen?

https://wpml.org/documentation/getting-started-guide/language-setup/directory-default-language/

Ist nur die Checkbox aktiv, oder eine Root URL aktiviert? Bei der Staging Seite ist nur die Checkbox aktiv.

Bitte um Info

Freundliche Grüße
Marcel

Juli 24, 2019 um 7:04 am #4270835

Martin

Habe die Testumgebung nochmals von Grund auf aufgesetzt und nun hat es funktioniert. Wieso es plötzlich geklappt hat - weiss ich nicht 😀

Aber somit ist das Problem gelöst 😉