Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

This topic contains 5 Antworten, has 2 Teilnehmer.

Last updated by Andreas W. vor 1 Monat.

Assigned support staff: Andreas W..

Autor Beiträge
Februar 19, 2020 um 3:28 pm #5525335

johannesM-11

Hallo,
Ich versuche: Leider funktioniert das übersetzen von Bildern nicht mehr. Die Bilder tauchen nicht im Übersetzungsmanagement auf. Ich habe bereits versucht eine neue Seite anzulegen und das Bild neu hochgeladen, aber das Bild wird im Übersetzungsmanagement nicht angezeigt.

Die übersetzten Bilder sind über Media Translations hochgeladen. Das Bild wird egal in welcher Sprache immer nur auf deutsch angezeigt.

Ich hoffe ihr könnt mir helfen.

Liebe Grüße

Februar 19, 2020 um 11:21 pm #5528185

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Vielen Dank, dass Sie das WPML Support Forum kontaktiert haben.

Könnte es sein, dass dieses Problem auf Bilder bezogen ist, die in einem Elementor Page Builder Element verwendet werden?

Sie sagen, die Bilder erscheinen nicht im Translation Management. Meinen Sie die Bilder erscheinen nicht beim erstellen eines Übersetzungsjobs?

Wenn Sie die betroffenen Seiten übersetzen, nutzen Sie den WPML Classic Translation Editor? Falls ja, sehen Sie die Bilder hier?

Oder nutzen Sie den Advanced Translation Editor? In diesem Fall werden die Bilder nicht im Editor angezeigt und Sie sollten sich auf Media Translation beschränken.

Ich würde mir das Problem gerne einmal mit Adminberechtigung genauer ansehen. Ich habe Ihre nächste Antwort als privat markiert, damit Sie im zusätzlichen Eingabefeld die neue Anmeldedaten angeben können. Bitte legen Sie zuvor eine Sicherungskopie Ihrer Website und der Datenbank an.

Mit freundlichen Grüßen
Andreas

Februar 20, 2020 um 5:29 pm #5535481

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich kann mich mit den angegebenen Nutzerdaten leider nicht anmelden. Könnten Sie diese bitte nochmals überprüfen?

Mit freundlichen Grüßen
Andreas

Februar 21, 2020 um 3:04 pm #5542039

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Bevor wir weitere Schritte vornehmen, bitte beachten Sie folgendes:

Ihr Server erfüllt nicht die Mindestvoraussetzungen für WordPress und WPML.

Bitte aktualisieren Sie auf PHP Version 7.3 oder höher und erhöhen Sie da WP Memory Limit.

Ihre aktuellen Werte sind:

PHP MemoryLimit 1G
WP Memory Limit 256M (Davon knapp 200M ausgelastet)
Fügen Sie diesen Code Ihrer wp-config.php hinzu, um den Arbeitsspeicher von WP zu erhöhen:
[php]
/ * Speichergrenze /
define ('WP_MEMORY_LIMIT', '512M'));
</ code>
Fügen Sie es kurz vor:
[php]
/ That's all, stop editing! Happy blogging. /
</ code>

Diese Einstellungen können direkt von Ihrem Hosting-Provider eingeschränkt werden. Daher empfehle ich Ihnen, sich mit ihnen in Verbindung zu setzen und sie zu bitten, sie direkt zu ändern.
Wenn Sie noch höhere Werte erhalten können, wäre das großartig. Achten Sie auch bitte darauf, dass die Speichergrenze für PHP immer etwas grüér sein sollte, als das WP Memory Limit.
Das MemoryLimit für PHP lässt sich in der php.ini Datie Ihrere aktuellen PHP version geändert werden. Sie finde diese Datei auf Ihrem Server.

Sollte das Problem so nicht gelöst werden können, werde ich weitere Untersuchungen durchführen.

Was verwirrend ist, ist das zum Beispiel das erste unübersetze Image auf der Hompage in der Mediengallerie in jeder Sprache mindestens 3-4 erscheint und zudem in unterschiedlichen Sprachen.

Wenn Sie auf der Mediengallerie die Sprache in der oberen Admin-Leiste ändern, sollten die Medien je nach Sprache gefiltert werden. Ich würde dazu raten hier duplizierte Medien oder solche die nicht der gewählten Sprache entpsrechen zu löschen und dann mit Media Translation erneut zu übersetzen.

Ich sehe auch auf Media Translation, dass es mehrere Einträge für das genannte Image gibt. Das kann vorkommen, wenn Sie das Image auf mehreren Seiten einfügen oder die Hauptsprachen von WPML ändern. War das hier der Fall?

Mit freundlichen Grüßen
Andreas
Mit freundlichen Grüßen
Andreas

Februar 28, 2020 um 10:32 am #5584367

johannesM-11

Hallo Andreas,

vielen Dank, die Übersetzungen werden jetzt richtig angezeigt.

Sobald ich aber eine Seite aktualisiere und beispielsweise Text ändere, wird das Bild auf der Seite wieder auf deutsch angezeigt und nicht mehr automatisch übersetzt.
Es wird erst wieder übersetzt angezeigt, nachdem ich das Bild nochmal neu in Media Translations hochlade.
Ist das normal?

Februar 28, 2020 um 5:36 pm #5587777

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Nein, das Verhalten hier ist nicht gewollt und wir müssen dies weiter testen.

Hier ist was ich getan habe:

1) Auf der Hompage habe ich im Elementor Editor eine kleine Textänderung vorgenommen (Leerzeichen hinter einem Titel) und die Seite in Elementor neu gespeichert.

2) Danach habe ich die italienische und französische Seite überprüft und konnte keine Änderungen an den Bildern feststellen.

3) Das wir das Original aktualisiert/editiert haben fordert WPMK auf die Übersetzung zu aktualisieren. Ich habe dann die Homepage erneut auf italienisch und französisch übersetzt.

4) Nun erscheint auf den übersetzten Seiten das deutsche Bild, anstelle der übersetzten Bilder.

5) Ich habe dann die Bilder neu über die Medienübersetzung hochgeladen und die Übersetzung funktioniert.

Zu meiner Verwunderung, ist die nur der Fall beim ersten Bild, direkt unter dem text: So funktioniert's

Das Bild weiter unten, links neben dem Text "Deine Vorteile mit ryd" verhält sich korrekt.

Ich hatte dann vor in einem minimalen Setup zu testen und habe alle Plugins deaktiviert, um alleine mit Phlox Core Elements, den WPML Plugins, wie Elementor und Elementor PRO getestet.

Leider wurde ich daraufhin automatisch abgemeldet und konnte mich nicht mehr anmelden.

Führen Sie bitte einen Test in minimalem Setup durch und lassen Sie mich wissen, ob das Problem weiterhin besteht. Sollte dies der Fall sein, probieren Sie bitte auch, dass Image in der deutschen Seite im Elementor einmal zu löschen und neu einzufügen.

Testen Sie bitte auch, ob das bereits erwähnte zweite Bild den gleichen Fehler aufweist, wenn Sie den Text editieren, der sich in der Sektion befindet zu welcher diese Bild zugeordnet ist.

Mit freundlichen Grüßem
Andreas

Das Thema „[Geschlossen] Bilder werden nur in deutscher Sprache angezeigt“ ist für neue Antworten geschlossen.