Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

This topic contains 9 Antworten, has 2 Teilnehmer.

Last updated by Jamal vor 2 Monate, 3 Wochen.

Assigned support staff: Jamal.

Autor Beiträge
Juli 22, 2019 um 11:11 am #4256507

markusH-42

Hello,

I was trying to have my languages in directories. Like on our thermocon site.
But it's not working on the new site. Our provider said they use Ngnix server.

We don't understand why it worked without any problem on the first site?!

Even the settings menue of WPML looks completely different on the two sites?!

Best regards

Juli 22, 2019 um 1:58 pm #4258167

Jamal
Supporter

Languages: Englisch (English ) Französisch (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for contacting WPML Support. I will be glad to help with this.

The Nginx settings to make WordPress work with rewrite rules are enough to make WPML work with languages in directories. As you also say that the WPML menu is different, I would suspect a compatibility conflict, please check if this issue appears when:
- Only WPML plugins are activated. It will tell us if there is an interaction issue with another plugin.
- The theme is set to a WordPress default like Twenty Fourteen. Its will tell us if there is an interaction issue with your theme.
- If the problem disappears, start activating one at the time to track where the incompatibility is produced.

If this does not help, can you deactivate WPML and choose a permalink format that is different than the default one (/?p=123), check Settings->Permalinks. Save permalinks and check if a page or a post is accessible with its slug (e.g. /sample-page).

Can you also ask your hosting provider for the Nginx settings used? I am activating the private reply to safely share that.

PS: Please note that I don't know German, let me know if you want a German supporter, as this ticket was created in the German forum.

Best regards,
Jamal
WPML Support

Juli 23, 2019 um 6:12 am #4262819

markusH-42

Hello Jamal,

I deactivated every plug-in one by one. Till 'WPML Multilingual CMS' was the only one left. But I still couldn't choose to have my languages in directories. I also changed the theme to a WP default "Twenty nineteen" but the issue was still there. So I also deactivated the last WPML Plug-in - so there was no single plug-in left which was activated. I tried to access a single site of our website. Besides that the avia builder was also deactivated and the site was like a bunch of coding - it was definately possible to access this site.

Our provider would like to know which settings of Ngnix you're interested in?

Btw.: English is fine. As long as my problem gets solved 🙂

Best regards

Juli 23, 2019 um 3:25 pm #4267387

Jamal
Supporter

Languages: Englisch (English ) Französisch (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

My apologies for the late reply. I would suspect that Nginx does have some rewrite rules that are interfering with WPML.

Can you allow me temporary access to your backend to check what permalink structure are you using, it may reveal if yes or no, the rewrite rules are there.

Best regards,
Jamal

Juli 24, 2019 um 12:18 pm #4274337

markusH-42

Hello Jamal,

yes I set up a login at our staging environment.
Can you activate the private text field?

Best regards

Juli 24, 2019 um 1:19 pm #4275067

Jamal
Supporter

Languages: Englisch (English ) Französisch (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Sure, here the private box is activated. You can also use my email if you have any doubts. jamal.b(at)onthegosystems.com

Best regards,
Jamal

Juli 25, 2019 um 5:46 am #4279241

markusH-42

Unfortunately, I still need to work at our site.
So maybe you can document what you've done (if you find the problem) so I can redo that to the live-site or reproduce your solution, after I cloned the site again next week (so we can replace the live-site with the staging site).
I'm fine with eather way. But right now it's not possible to not work on the website for 1 or 2 days. Sorry for that.We'll figure something out. For now, I'd be happy if you find what causes the problem.

Looking forward hearing from you 🙂

Juli 25, 2019 um 11:53 am #4282691

Jamal
Supporter

Languages: Englisch (English ) Französisch (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

I was able to set the language per directories but there are still some issues. I believe that this is caused by the file permissions on your directory, check the attached image, notice the padlock on the files and folders icons.

Also, check this article https://wpml.org/documentation/getting-started-guide/language-setup/cannot-activate-language-directories/

You will need to set the proper permissions for the files recursively. You hosting provider should help with this.

I hope this helps. Let me know if there is still something I can do.

Best regards,
Jamal

Juli 29, 2019 um 5:26 am #4297079

markusH-42

Hey Jamal,

thanks a lot. I will hand this info to our provider.
Are you able to redo your changes? As I said I had to work on the site at the same time as you were working on the staging site - so I can't overwrite the site with the staging now - my progress on the site would be lost. I would copy the site to staging again tomorrow so you can redo the changes. Or you can tell me what you've done so I can do it on my own. What do you prefer? Or do you have another suggestion?

Best regards

Juli 29, 2019 um 8:49 am #4297893

Jamal
Supporter

Languages: Englisch (English ) Französisch (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello Markus,

I only set the setting for languages in Directories, this should be reverted easily. That's the only change I performed.

Let me know if there is still something else I can help with. Looking forward to your reply.

Best regards,
Jamal