Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

This topic contains 5 Antworten, has 2 Teilnehmer.

Last updated by Marcel vor 4 Monate.

Assigned support staff: Marcel.

Autor Beiträge
Juni 18, 2019 um 6:07 am #4040581

paulW-38

Ich versuche: die Sprache zu Wechseln (von DE auf EN). Problem tritt seit Version auf Version 4.2.7.1

URL der/meiner Website, auf der das Problem auftritt: die Beschreibung der Bezahlmethode wechselt die Sprache nicht.

Erwartet hatte ich zu sehen: das die Description der Bezahlmehthoden ebenfalls auf English wechselt.

Stattdessen bekam ich:nur die Beschreibung der Bezahlmethoden bleibt weiterhin auf Deutsch.

Juni 18, 2019 um 7:20 am #4040879

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Paul,

Vielen Dank, dass Sie den WPML Support kontaktiert haben.

Ich würde mir das gerne direkt auf Ihrer Seite ansehen. Dazu bräuchte ich bitte temporären Zugriff (WP-Admin und FTP) auf Ihre Seite, vorzugsweise zu einer Test/Staging Seite, an der das Problem nach Möglichkeit repliziert wurde.

Ihre nächste Antwort ist als „Privat“ markiert, dies bedeutet nur Sie und ich haben Zugriff darauf.

❌ Bitte sichern Sie Ihre Datenbank und Website davor ❌

✙ Ich würde außerdem Ihre Erlaubnis benötigen, um Plugins und das Theme zu deaktivieren und erneut zu aktivieren sowie Konfigurationen auf der Seite zu ändern. Dies ist auch der Grund, warum das Backup wirklich wichtig ist.

Freundliche Grüße
Marcel

Juni 19, 2019 um 11:52 am #4051247

paulW-38

Hi Marcel!

Ich kann unsere komplette Website leider nicht in der Sandbox nachbauen.
Ich habe aber ein Backup auf einen anderen Server eingespielt, wobei
- WPML Multilingual CMS auf 4.3.6
- WPML String Translation auf 2.10.4
- WPML Translation Management auf 2.8.5
läuft. Hier tritt das Problem definitiv NCIHT auf.
Danach habe ich auf:
- WPML Multilingual CMS auf 4.2.7.1
- WPML String Translation auf 2.10.5.1
- WPML Translation Management auf 2.8.6.1
aufgeatmet und das Problem tritt auf.
Interessanter weise nur in der englischen Version, nicht auf der Italienischen Version. Im Italienischen werden die Beschreibungen der Bezahlmehthoden korrekt auf italinisch geswitcht.

In der Englischen Sprachversion bleiben die Beschreibungen der Bezahlmehtoden auf Deutsch.

Ich werde versuchen, einen SSH Zugang auf unser Integrations-System freischalten zu lassen damit Ihr das Problem dort debuggen könnt.

LG

:: Paul

Juni 19, 2019 um 2:53 pm #4052501

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Paul,

vielen Dank.

Sie müssen die Seite nicht nachbauen. Die Sandbox ist dazu gedacht zu prüfen, ob sich das Problem in dieser isolierten, sauberen Installation mit den neuesten Versionen von WPML & WooCommerce nachstellen lässt. Es reicht 1 übersetztes Produkt, um bis zum Checkout zu kommen (mit Ihren Einstellungen wie Sprache als Parameter etc.). Damit schließen wir aus, ob das Problem von einem anderen Plugin kommt. WPML habe ich bereits vorkonfiguriert.

Freundliche Grüße
Marcel

Juni 19, 2019 um 4:52 pm #4053521

paulW-38

Hi Marcel!

Ich habe oben in der private Message jetzt die sFTP Zugangsdaten eingetragen. Damit könnt Ihr das auf unserer Maschine debuggen.
Wie gesagt konnte ich eindeutig nachstellen, dass das Problem erst NACH der Installation von:
- WPML Multilingual CMS auf 4.2.7.1
- WPML String Translation auf 2.10.5.1
- WPML Translation Management auf 2.8.6.1
auftritt.
Das Problem ist sauber reproduzierbar und sollte mit sFTP zugriff gut debugbar sein.

LG

:: Paul

Juni 20, 2019 um 11:51 am #4059583

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Paul,

vielen Dank für die Info. Ich habe dies nun auf der Sandbox versucht zu reproduzieren und konnte das Problem nicht nachstellen.

Ich konnte das Problem auf Ihrer Seite durch die Deaktivierung folgender Option lösen:

WPML -> Lokalisierungsoptionen -> Deaktivierung der Checkbox "Angenommen, die Originalsprache aller Strings ist Englisch". Ich forsche gerade nach warum die Einstellung aktiv war. Dies sollte nur der Fall sein, wenn die Default Sprache Englisch ist.

Freundliche Grüße
Marcel