Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:
Wir haben versucht, WP Rocket zu aktivieren, um die Geschwindigkeit der Webseite zu verbessern. Die Weiterleitung der Startseite in die entsprechende Startseite der Sprachen funktioniert nicht so bald WP-Rocket aktiviert ist.

Solution:
Es war eingestellt, dass Sie einen Sprachordner in der Default-Sprache verwenden wollen. Es wurde dafür jedoch keine notwendige "Root" Page erstellt. Lt. Optionen war nur eine Page ausgewählt, jedoch nicht erstellt.

Relevant Documentation:
https://wpml.org/documentation/getting-started-guide/language-setup/directory-default-language/#setting-up-the-root-page.

Dies ist das technische Support-Forum für WPML – das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team antwortet im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Heute stehen keine Supporter zur Arbeit im German-Forum zur Verfügung. Sie können gern Tickets erstellen, die wir bearbeiten werden, sobald wir online sind. Vielen Dank für Ihr Verständnis.

This topic contains 2 Antworten, has 2 Teilnehmer.

Last updated by birgitB-6 Vor 1 Monat, 2 Wochen.

Assigned support staff: Marcel.

Author Artikel
Juni 27, 2022 um 10:30 am #11549423

birgitB-6

Ich versuche: Wir haben folgendes Problem auf unserer Seite. Wir haben versucht WP Rocket zu aktivieren, um die Geschwindigkeit der Webseite zu verbessern. Die einzelnen Seiten sehen auch richtig aus /de/... oder nur /de

Jedoch die Weiterleitung der Startseite in die entsprechende Startseite der Sprachen funktioniert nicht sobald WP-Rocket aktiviert ist. Ohne WP-Rocket funktioniert alles alles bestens. Um das Problem besser nachzuvollziehen haben wir eine Staging Seite eingerichtet.
Wir haben einen nginx Webserver und kein Apache. Wenn ich jedoch die Seite ohne Mehrsprachigkeit aufsetzte und nur wp Rocket verwende geht es auch problemlos.

Das Problem äußert sich nur in Verbindung mit Mehrsprachigkeit und WP-Rocket und das falsche Aussehen der Startseite. Ohne WP-Rocket werde ich sofort zu der jeweiligen Untersprache weitergeleitet. Dies funktioniert leider aktuell nicht.

Bei der Default Sprache ist englisch eingestellt.

Können Sie uns weiterhelfen, damit die Seite in Verbindung mit WP-Rocket funktioniert.

Viele Grüße

Startseite mit wp-Rocket.JPG
Startpage german_without_rocket-chat.JPG
Settings-wmpl.JPG
Juni 27, 2022 um 11:03 am #11549957

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo,

lt. Source-Code ist WP Rocket aktuell aktiv, ich kann es jedoch nicht nachstellen.

Sie haben eingestellt, dass Sie einen Sprachordner in der Default-Sprache verwenden wollen. Es wurde dafür jedoch keine notwendige "Root" Page erstellt. Lt. Optionen ist nur eine Page ausgewählt, jedoch nicht erstellt.: https://wpml.org/documentation/getting-started-guide/language-setup/directory-default-language/#setting-up-the-root-page.

Ist dies hier der Fall?

Freundliche Grüße
Marcel

Juni 27, 2022 um 1:40 pm #11551895

birgitB-6

My issue is resolved now. Thank you!