Skip Navigation

Dies ist das technische Support-Forum für WPML – das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team antwortet im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

This topic contains 7 Antworten, has 2 Teilnehmer.

Last updated by renateR-3 Vor 3 Monate.

Assigned support staff: Andreas W..

Author Artikel
Oktober 15, 2021 um 10:14 am #9796349

renateR-3

Sagen Sie uns, was Sie versuchen zu erreichen?
Die Profil-Seite übersetzen

Folgen Sie einer Dokumentation?

Gibt es ein ähnliches Beispiel, das wir sehen können?

Was ist der Link zu Ihrer Website?

Bildschirmfoto 2021-10-15 um 12.04.03.png
Oktober 15, 2021 um 11:05 am #9797393

Andreas W.
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Sie vermissen die Seite "Profil" in den Übersetzungsmöglichkeiten?

Existiert denn eine Seite dazu oder handelt es sich hier eventuell im ein Theme Template?

Wie wurde die Profilseite erstellt?

Sollten Sie keine Option finden, im diese Seite mit dem WPML-Übersetzungseditor zu übesetzen, so kann es sein, dass es sich um ein Theme Template handlet, dass mit WPML -> Stringübersetzung übersetzt werden muss.

Mehr dazu hier:
https://wpml.org/de/documentation-3/ratgeber-zum-loslegen/string-ubersetzung/finden-von-strings-die-nicht-auf-der-string-translation-seite-erscheinen/

Lassen Sie mich bitte wissen, ob Sie dabei weitere Hilfe benötigen.

Mit freundlichen Grüßen
Andreas

Oktober 15, 2021 um 4:53 pm #9799835

renateR-3

Hallo Andreas,

es ist etwas kurios. Die Seite ist schon online. Ich hatte heute eine Überschrift geändert auf der Startseite (Profil) hidden link. Dann stellte ich fest, dass in den übersetzten Startseiten die 3D-Animation nicht mehr lief. Ich wandte mich an Bruno Kos. Er meinte, ich solle einfach die Profilseiten übersetzten, dann würde es wieder laufen.
Der virtuelle Rundgang läuft wieder, aber die türkische Übersetzung der Startseite ist weg und ich kann die Startseite (Profil) zum Übersetzen nicht wiederfinden.
Was tun? Ich kann es so ja nicht lassen, die Seite ist online.

Viele Grüße, Renate

Bildschirmfoto 2021-10-15 um 12.04.03.png
Oktober 16, 2021 um 5:01 am #9801603

Andreas W.
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo Renate,

Lass mich da bitte mal einen Blick drauf werfen.

Ich möchte einen temporären Zugriff (wp-admin und FTP) auf Ihre Site anfordern, um das Problem genauer zu untersuchen. Besser wäre eine Testseite, an der das Problem repliziert werden kann.

Die dafür erforderlichen Felder finden Sie unterhalb des Kommentarbereichs, wenn Sie sich anmelden, um Ihre nächste Antwort zu hinterlassen. Die Informationen, die Sie eingeben werden, sind privat, was bedeutet, dass nur Sie und ich sie sehen und darauf zugreifen können.

WICHTIG

Machen Sie eine Sicherungskopie der Site-Dateien und der Datenbank, bevor Sie uns den Zugriff gewähren.
Wenn Sie die Felder "wp-admin / FTP" nicht sehen, werden Ihre Anmeldedaten für Post und Website als "PUBLIC" (Öffentlich) festgelegt. Veröffentlichen Sie NICHT die Details Ihrer Website, es sei denn, Sie sehen die erforderlichen wp-admin / FTP-Felder. Wenn Sie dies nicht tun, bitten Sie mich, die private Box zu aktivieren. Die private Box sieht so aus:
hidden link

Mit freundlichen Grüßen
Andreas

Oktober 18, 2021 um 1:43 am #9806537

Andreas W.
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo Renate,

Wenn Du mal bitte einen Blick auf den Screenshot "settings" wirfst. Diese Felder findest Du untern im WordPress Editor, wenn Du die Startseite editierst.

In der Regel, sollten diese auf "Copy" stehen, damit die entsprechenden Einstellungen auf die Übersetzungen übernommen werden, sie standen aber nich auf "nicht übersetzen".

Danach habe ich die englische Übersetzung der Homepage nochmal geöffnet und im WPML Übersetzungseditor bearbeitet und die ersten drei Zeilen nochmals übersetzt.

Dabei stellte ich fest, dass sich der Title und Untertitel der Seite anscheinend nicht übersetzen lassen und ich habe dazu Konfiguration angelegt.

Sie finden diese unter WPML -> Einstellungen -> Benutzerdefinierte XML Konfiguration:

<wpml-config>
    <shortcodes>
        <shortcode>
            <tag>vc_column_text</tag>
        </shortcode>
    </shortcodes>
</wpml-config>

Danach habe ich das Titleelement kurz editiert, neu gespeichert und die erneut die Übersetztung geöffnet, in welcher die englischen Übersetzungen nun wie erwartet gespeichrt blieben und ebenso nach erneutem Übernehmen der Übersetzungen auf der englischen Homepage angezeigt werden.

Ich habe zudem die Speichergrenze für WordPress angepasst, da die aktuell verwendeten 40M zu niedrig waren. Die Website lief hier knapp an der Grenze.

Die Änderung wurde in der wp-config.php Datei vorgenommen, welche die Einstellungen für WordPress festlegt und sich im Hauptverzeichnis Ihrer WordPress-Installation auf dem Server befindet.

Das Problem, welches momentan betsehen bleibt, ist das aus irgendeinem Grund die russische Übersetzung nicht direkt anegzeigt wurde.

Das Problem liegt aber nicht direkt an WPML, sondern es scheint eher am Server zu liegen. Es dauerte ein paar Minuten und die Übersetzungen erscheinen wie erwartet.

Prüfen Sie bitte, ob ich das korrekt übersetzt habe und geben Sie mit Bescheid, sollten Sie weitere Hilfe benötigen oder Fragen haben.

Mit freundlichen Grüßen
Andreas

Bitte aktualisiere auch noch einem die russische und türkische Übersetzung.

Oktober 18, 2021 um 7:42 am #9807745

renateR-3

Hallo Andreas,

vielen Dank für Deine rasche und unkomplizierte Hilfe! Die Seite zeigt wieder alle Übersetzungen an, das ist prima!
Allerdings kann ich im Menüpunkt WPML "Übersetzungen" nochimmer die Start/Profilseite nicht sehen. Sollte ich nochmals etwas übersetzen wollen, weiß ich nicht, wie ich es wiederfinden soll. Wie mache ich das am Besten?

Schöne und sonnige Grüße, Renate

Oktober 19, 2021 um 8:24 pm #9821751

Andreas W.
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo Renate,

Du kannst entweder direkt auf den WordPress-Editor der deutschen Homepahge gehen und in der rechte Seitenleisten die Übersetzung öffnen, indem du auf die WPML Symbole (Bleistift, Pfeilkreis, etc.) klickst:

hidden link

Solltest Du lieber mit WPML Translation Management arbeiten, so wirst Du unter WPML -> Übersetzungen nur Überseztungsjobs finden, die Du zuvor erstellt hast.

Um einen Job zu erstellen, gehst Du zuerst auf WPML -> Übersetzungsmanagament -> Übersetzungs-Dashboard, markierst den Inhalt und klickst unten auf "Den ausgewählten Inhalt dem Übersetzungskorb hinzufügen. Siehe Screenshot.

Dann wechselst Du open auf den Tab "Übersetzungskorb" und bestätigst die Jobs, welche sich danach unter WPML -> Übersetzungen aufrufen lassen.

Mehr zum Thema Übersetzungsmanagement findest Du hier:
https://wpml.org/de/documentation-3/ubersetzen-ihrer-inhalte/

Mit freundlichen Grüßen
Andreas

job erstellen.jpg
Oktober 20, 2021 um 5:34 am #9823275

renateR-3

My issue is resolved now. Thank you!