Skip Navigation

Dies ist das technische Support-Forum für WPML – das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team antwortet im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Our next available supporter will start replying to tickets in about 0.37 hours from now. Thank you for your understanding.

Schlagwörter: 

This topic contains 4 Antworten, has 2 Teilnehmer.

Last updated by wolfgangL-11 vor 6 Monate.

Assigned support staff: Andreas W..

Author Artikel
Februar 10, 2020 um 5:55 pm #5463883

wolfgangL-11

Ich habe mit dem Divi Theme Builder ein Template für alle Seiten erstellt. Darauf befindet sich unter anderem ein Blurp-Element. Ich habe es im Übersetzungsmanagement zur Übersetzung gestellt und dann selbst übersetzt. Es wird mir als abgeschlossener Auftrag angezeigt. Leider wird auf der Seite selbst in allen Sprachen nur die deutsche Version angezeigt.
Habe ich einen Schritt übersehen?

Februar 10, 2020 um 10:38 pm #5465081

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Vielen Dank, dass Sie das WPML Support Forum kontaktiert haben.

Handelt es sich hier eventuell im ein Divi Global Module? Wir hatten diesbezüglich Probleme seit der Einführuing von Divi 4.0 und unsere Entwickler sind damit beschäftigt einige Probleme aus dem Weg zu räumen.

Wir haben momentan eine Beta verfügbar, die solche Probleme bereiningen sollte, Sie finden diese hier:
https://wpml.org/de/download/wpml-mehrsprachiges-cms/?section=changelog

Mehr zum Thema:
https://wpml.org/documentation/support/maintaining-divi-builder-compatibility-wpml/#page-builder-shortcode-structure-in-the-language-configuration-file

Auch wichtig:
Wurden bei der Übersetzung alle Elemente im WPML Übersetzungseditor angezeigt? Falsl nicht, können wir versuchen dies mit einer Custom XML Config zu beheben.

https://wpml.org/documentation/support/maintaining-divi-builder-compatibility-wpml/#page-builder-shortcode-structure-in-the-language-configuration-file

Lassen Sie mich wissen, ob das Problem auf bereits bekannte Probleme bezogen werden kann oder ob es sich um ein anderes Problem handelt, welches wir weite runtersuchen müssten.

Zuletzt noch ein Ratschlag:

Könnten Sie bitte Ihre WordPress-Speichergrenze (WP Memory Limit) auf mindestens 256 MB erhöhen? Für WPML ist mindestens 128M erforderlich.
Ihre aktuellen Werte sind:

PHP MemoryLimit 256M
WP Memory Limit 40M
Fügen Sie diesen Code Ihrer wp-config.php hinzu, um den Arbeitsspeicher von WP zu erhöhen:
[php]
/ * Speichergrenze /
define ('WP_MEMORY_LIMIT', '256M'));
</ code>
Fügen Sie es kurz vor:
[php]
/ That's all, stop editing! Happy blogging. /
</ code>

Diese Einstellungen können direkt von Ihrem Hosting-Provider eingeschränkt werden. Daher empfehle ich Ihnen, sich mit ihnen in Verbindung zu setzen und sie zu bitten, sie direkt zu ändern.
Wenn Sie noch höhere Werte erhalten können, wäre das großartig. Achten Sie auch bitte darauf, dass die Speichergrenze für PHP immer etwas höher sein sollte, als das WP Memory Limit.
Das PHP MemoryLimit lässt sich in der php.ini Datie Ihrere aktuellen PHP version geändert werden. Sie sollten Sie Datei auf Ihrem Server oder in den PHPmyAdmin Server-Einstellungen finden können.

Mit freundlichen Grüßen
Andreas

Februar 11, 2020 um 9:45 am #5467667

wolfgangL-11

Vielen Dank für die Antwort,

leider ist das Problem auch mit der Beta nicht gelöst.
Das Problem ist auch nicht, dass eine Übersetzung nicht möglich ist, sondern, dass die abgeschlossene Übersetzung dieses Global-module nicht auf der Seite angezeigt wird. Ich vermute einfach, dass ich das System nicht richtig verstanden habe.
Wenn ich einen Übersetzungsauftrag im Management erteilt habe, mir dann aber selbst zuordne, muss ich dann nach der erfolgten Übersetzung noch etwas unternehmen? Der Auftrag wird als abgeschlossen angezeigt.
Dennoch ist der Text in dem verwendeten Element auf allen Sprachenseiten nur in deutscher Sprache vorhanden.
Bei Menüs kann ich verschiedene Landesversionen einstellen, bei anderen Elementen offensichtlich nicht.

Februar 11, 2020 um 3:25 pm #5470801

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich möchte einen temporären Zugriff (wp-admin und FTP) auf Ihre Site anfordern, um das Problem genauer zu untersuchen. Besser wäre eine Testseite, an der das Problem repliziert werden kann.

Die dafür erforderlichen Felder finden Sie unterhalb des Kommentarbereichs, wenn Sie sich anmelden, um Ihre nächste Antwort zu hinterlassen. Die Informationen, die Sie eingeben werden, sind privat, was bedeutet, dass nur Sie und ich sie sehen und darauf zugreifen können.

Vielleicht muss ich Ihre Site lokal replizieren. Dazu muss ich vorübergehend ein Plugin namens „Duplicator“ auf Ihrer Site installieren. Dadurch kann ich eine Kopie Ihrer Website und Ihrer Inhalte erstellen. Sobald das Problem behoben ist, lösche ich die lokale Site. Lassen Sie mich wissen, ob dies bei Ihnen in Ordnung ist.

 WICHTIG

Machen Sie eine Sicherungskopie der Site-Dateien und der Datenbank, bevor Sie uns den Zugriff gewähren.
Wenn Sie die Felder "wp-admin / FTP" nicht sehen, werden Ihre Anmeldedaten für Post und Website als "PUBLIC" (Öffentlich) festgelegt. Veröffentlichen Sie NICHT die Details Ihrer Website, es sei denn, Sie sehen die erforderlichen wp-admin / FTP-Felder. Wenn Sie dies nicht tun, bitten Sie mich, die private Box zu aktivieren. Die private Box sieht so aus:
hidden link

Mit freundlichen Grüßen
Andreas

Februar 14, 2020 um 9:07 am #5492857

wolfgangL-11

My issue is resolved now. Thank you!