Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Schlagwörter: 

This topic contains 21 Antworten, has 2 Teilnehmer.

Last updated by Andreas W. vor 7 Monate, 2 Wochen.

Assigned support staff: Andreas W..

Autor Beiträge
Februar 15, 2019 um 4:37 pm #3205979

hannesF

i would like to translate the opt-in field label "voglio ricevere la newsletter" from WooCommerce Sendinblue Newsletter Subscription plugin

Februar 15, 2019 um 9:18 pm #3206595

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Vielen Dank, dass Sie den WPML Support kontaktiert haben.

Bitte führen Sie die Aktualisationen für WPML und dessen Add-Ons durch. Gehen Sie dazu auf Plugins -> Installieren -> Kommerziell.

Die Strings der Optionen des Plugins SendinBlue Subscribe Form And WP SMTP können mit String Translation übersetzt werden.
https://wpml.org/de/documentation-3/ratgeber-zum-loslegen/string-ubersetzung/

Bitte gehen Sie auf WPML -> String Übersetzung und nutzen Sie das Eingabe-Suchfeld, um nach dem namentlichen String zu suchen. Sollte der String nicht gefunden werden können, müsste er zuerst von der Option "Text auf Admin-Bildschirmen übersetzen"zugefügt werden. Sie finden die Option am unteren Linken Ende des Bidschirms.

Dort suchen Sie nach einem namentlichen Eintrag für das Plugin und markeiren den passenden String, sobald er gefunden wurde. Bestätigen Sie dann Ihre Eingabe am unteren Ende des Bidschirms. Der String sollte nun auf String Translation verfügbar sein.

Bitte lassen Sie mich wissen, ob Sie weitere Hilfe bei der Übersetzung benötigen.

Mit freundlichen Grüßen
Andreas

Februar 18, 2019 um 8:45 am #3210548

hannesF

hallo andreas,

danke für die antwort. unten links habe ich eigentlich immer eingestellt:
Strings von allen Text-Domains werden autom. registriert

trotzdem sehe ich dieses feld nicht.

gruß
hannes

Februar 18, 2019 um 8:54 pm #3214082

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

In manchen Fällen ist es leider nötig, die Strings manuell hinzuzufügen. Ich kann Ihnen gerne dabei behilflich sein.

Ich möchte einen temporären Zugriff (wp-admin und FTP) auf Ihre Site anfordern, um das Problem genauer zu untersuchen. Besser wäre eine Testseite, an der das Problem repliziert werden kann.

Die dafür erforderlichen Felder finden Sie unterhalb des Kommentarbereichs, wenn Sie sich anmelden, um Ihre nächste Antwort zu hinterlassen. Die Informationen, die Sie eingeben werden, sind privat, was bedeutet, dass nur Sie und ich sie sehen und darauf zugreifen können.

Vielleicht muss ich Ihre Site lokal replizieren. Dazu muss ich vorübergehend ein Plugin namens „Duplicator“ auf Ihrer Site installieren. Dadurch kann ich eine Kopie Ihrer Website und Ihrer Inhalte erstellen. Sobald das Problem behoben ist, lösche ich die lokale Site. Lassen Sie mich wissen, ob dies bei Ihnen in Ordnung ist.

 WICHTIG

Machen Sie eine Sicherungskopie der Site-Dateien und der Datenbank, bevor Sie uns den Zugriff gewähren.
Wenn Sie die Felder "wp-admin / FTP" nicht sehen, werden Ihre Anmeldedaten für Post und Website als "PUBLIC" (Öffentlich) festgelegt. Veröffentlichen Sie NICHT die Details Ihrer Website, es sei denn, Sie sehen die erforderlichen wp-admin / FTP-Felder. Wenn Sie dies nicht tun, bitten Sie mich, die private Box zu aktivieren. Die private Box sieht so aus:
hidden link

Mit freundlichen Grüßen
Andreas

Februar 19, 2019 um 2:42 pm #3217192

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich habe den String jetzt hinzugefügt.

Gehen Sie dazu auf WPML -> Tradicione stringhe -> Traduci le stringhe dell'area di amministrazione.

Sie finden diese Option am unteren Ende der Seite "Tradicione stringhe".

Drücken Sie jetzt Ctrl+F um das Browser-Suchfeld zu öffnen und geben Sie "blue" ein. Sie sollten jetzt sofot die Text-Domain wc_sendinblue_settings sehen. Klicken Sie auf diese und Sie werden einen String mit dem Namen ws_opt_field_label sehen. Markieren Sie die Checkbox des Strings und scrollen Sie zum Ende der Seite, um Ihre Eingabe zu bestätigen.

Der String ist jetzt auf Tradicione stringhe zum übersetzen verfügbar.

Bitte lassen Sie mich wissen, ob der String erfolgreich übersetzt wurde.

Mit freundlichen Grüßen
Andreas

Februar 19, 2019 um 3:17 pm #3217514

hannesF

hallo andreas,

danke für die hilfe. nur: ich habe das jetzt gemacht ohne meine sprache auf italienisch zu wechseln und jetzt zeigt es mir den string in DE an. auch wenn ich ihn dann bei den einstellungen in deutsch eintippe, kommt immer wieder das italienische. wie kann ich das ändern? bei sprachen der domains? oder kann ich das wiederholen?

Februar 19, 2019 um 3:25 pm #3217574

hannesF

kann man diesen vorgang komplett löschen bzw. wiederholen? ich habe es mal auf meiner live-seite probiert: hidden link und es zeigt überall italienisch an und wenn ich diese option deaktviere bleibt es trotzdem. ist es jetzt irgendwie fest verankert?

Februar 19, 2019 um 3:52 pm #3217818

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Vielen Dank für Ihre Nachricht.

Es ist nicht notwendig den Vorgang zu wiederholen. Wenn Sie auf String Translation nach untern scrollen sollten Sie eine Option sehen, mit der Sie die Sprache für ausgewählte Strings ändern können.
Markieren Sie dazu einfach zuerst die Strings, die geändert werden sollen und wählen Sie dann eine Sprache aus dem Options-Menu.

Siehe Screenshot.

Mit freundlichen Grüßen
Andreas

Februar 19, 2019 um 4:40 pm #3218088

hannesF

ich konnte die sprache problemlos ändern, schaut auch alles richtig aus, nur wird es trotzdem überall nur italienisch angezeigt: hidden link
soll ich dir einen login zur live-seite geben?

Februar 19, 2019 um 5:03 pm #3218257

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Natürlich, ich schaue mir das gerne mal an.

Ich möchte einen temporären Zugriff (wp-admin und FTP) auf Ihre Site anfordern, um das Problem genauer zu untersuchen. Besser wäre eine Testseite, an der das Problem repliziert werden kann.

Die dafür erforderlichen Felder finden Sie unterhalb des Kommentarbereichs, wenn Sie sich anmelden, um Ihre nächste Antwort zu hinterlassen. Die Informationen, die Sie eingeben werden, sind privat, was bedeutet, dass nur Sie und ich sie sehen und darauf zugreifen können.

Vielleicht muss ich Ihre Site lokal replizieren. Dazu muss ich vorübergehend ein Plugin namens „Duplicator“ auf Ihrer Site installieren. Dadurch kann ich eine Kopie Ihrer Website und Ihrer Inhalte erstellen. Sobald das Problem behoben ist, lösche ich die lokale Site. Lassen Sie mich wissen, ob dies bei Ihnen in Ordnung ist.

 WICHTIG

Machen Sie eine Sicherungskopie der Site-Dateien und der Datenbank, bevor Sie uns den Zugriff gewähren.
Wenn Sie die Felder "wp-admin / FTP" nicht sehen, werden Ihre Anmeldedaten für Post und Website als "PUBLIC" (Öffentlich) festgelegt. Veröffentlichen Sie NICHT die Details Ihrer Website, es sei denn, Sie sehen die erforderlichen wp-admin / FTP-Felder. Wenn Sie dies nicht tun, bitten Sie mich, die private Box zu aktivieren. Die private Box sieht so aus:
hidden link

Kind regards
Andreas

Februar 20, 2019 um 6:18 pm #3223343

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Vielen Dank für die Zugangsdaten.

Ich kann das Problem leider nicht abschließend prüfen, das das Plugin, auf welchen sich der String bezieht deaktiviert ist. Bitte melden Sie sich erneut für den Dienst des Plugins SendingBlue Newsletter Subscription an.

Versuchen Sie dann bitte einmal das Plugin mit der Standard-Sprache Englisch zu verwenden und den String auf String Translation, der sich auf den nicht übersetzten Eintrag bezieht, auf Englisch umzuschalten.
Es wäre außerdem möglich das Plugin, sobald es wieder reaktiviert ist, nach weiteren Strings zu durchsuchen.
Sie finden diese Option unter WPML -> Theme and Plugin Localization -> Strings in the Plugins.

WICHTIG:

Es wäre außerdem hilfreich, wenn Sie das Plugin und das momentan verwendete Template Flatsome auf der folgenden Testseite installieren könnten, damit ich diese auf Kompabilität prüfen kann. Es sit sehr gut möglich, dass SendinBlue Subscribe Form And WP SMTP nicht mit WPML kompatible ist.

Ein-Klick-Anmeldung: hidden link

Bitte nehmen Sie hier von einer Liste Kenntnis, die zahlreiche Plugins jeglicher Art beinhaltet, die von uns getestet wurden und mit WPML kompatible sind.
https://wpml.org/faq/list-of-top-compatibility-recommendations/

Mit freundlichen Grüßen
Andreas

Februar 21, 2019 um 12:42 pm #3227430

hannesF

hallo andreas,

achtung: das plugin heisst woocommerce sendinblue newsletter subscription (nicht sendinblue subscribe form and wp smtp, das brauchts für andere sachen).
ich habe deine einleitung befolgt, hilft leider alles nicht.
im gegenteil: auch wenn ich etwas ändere im eingabefeld vom plugin, wird das überhaupt nicht in die string translation übernommen, deswegen bleibt z.b. der text in italienisch obwohl ich die sprache ändere ...

meinst du mit raufladen ich muss nur das theme raufladen und die plugins? einstellen muss ich dann nichts oder?

Februar 21, 2019 um 5:11 pm #3229064

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Vielen Dank für Ihre Nachricht.

Ich würde gerne das Plugin auf der folgenden Testseite mit WPML prüfen, da ich das Problem auf einer neuen WordPress-Installation nachbilden muss.

Bitte installieren Sie das Plugin Woocommerce Sendinblue Newsletter Subscription hier:
Ein-Klick-Anmeldung: hidden link

Es wäre außerdem hilfreich, wenn Sie auch Ihr Design Template installieren könnten.

Mehr müssen Sie nicht tun. Es scheint mir als ob das Plugin nicht kompatible ist und sobald ich dies nachstellen konnte, kann ich die Angegenheit an unser Kompatibilitätsteam weiterleiten.

Mit freundlichen Grüßen
Andreas

Februar 22, 2019 um 9:44 am #3231608

hannesF

hallo andreas,

ich habe das theme (flatsome) und das plugin (Woocommerce Sendinblue Newsletter Subscription) installiert. beides aber nicht aktiviert in der WP-installation.

gruß
hannes

Februar 22, 2019 um 6:48 pm #3233766

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Es scheint mir, alsob das Plugin den String nicht korrekt kodiert, um diesen zu übersetzen. Um dies zu Bestätigen, würde ich das Problem für unser Kompatibilitätsteam gerne auf einer neuen Installation von WordPress nachstellen.

Ich habe leider Probleme beim prüfen des Plugins, da ich einen Produktschlüssel benötige, um es zu aktivieren. Es wäre sehr hilfreich, wenn Sie bitte Ihren API-Produktschlüssel in der nächsten privaten Nachricht übermitteln könnten.

Bitte lassen Sie mich wissen, ob Sie damit einverstanden sind. Ich werde das Problem dann direkt weiterleiten.

Mit freundlichen Grüßen
Andreas