Skip Navigation

Dies ist das technische Support-Forum für WPML – das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team antwortet im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Our next available supporter will start replying to tickets in about 3.98 hours from now. Thank you for your understanding.

This topic contains 6 Antworten, has 3 Teilnehmer.

Last updated by Andreas W. Vor 3 Wochen, 6 Tage.

Assigned support staff: Andreas W..

Author Artikel
April 1, 2021 um 7:41 am #8446029

venturisI

Sagen Sie uns, was Sie versuchen zu erreichen?
Die Seite wurde mit dem erweiterten Editor bearbeitet, jetzt wird aber nur der klassische Editor angezeigt.
WPML-Einstellung: von Beginn an erweiterter Editor (wird in den WPML-Einstellungen auch jetzt noch angezeigt)

Folgen Sie einer Dokumentation?

Gibt es ein ähnliches Beispiel, das wir sehen können?

Was ist der Link zu Ihrer Website?
hidden link

April 2, 2021 um 2:21 pm #8455325

Laura
Supporter

Languages: Englisch (English ) Italienisch (Italiano ) Portugiesisch, Brasilien (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for contacting us. Unfortunately, until next week we don't have any German supporters available, but we can offer support in English.

Can you please click on the "Synchronize translator" button in WPML > Settings > How to translate posts and pages?

After doing that, please do a small change to the original page, then open the translation (you should have the round circle icon, not the pencil one). This should trigger the Advanced editor again.

April 6, 2021 um 4:14 pm #8475327

venturisI

Hi, I have synchronised the WPML and made a small change to one original page. Unfortunately, it still doesn't work on all pages.

April 6, 2021 um 9:31 pm #8476775

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Haben Sie bereits versucht die Übersetzung unter WPML -> Translation Management -> Translation jobs abzubrechen und neu zu starten?

Auch wichtig zu wissen wäre: Wenn Sie eine neue Seite erstellen, wird dann die Übersetzung mit dem ATE geöffnet?

Falls nicht, scheint es, als würde der ATE momentan überhaupt nicht funktionieren.

Ich würde in diesem Fall dazu raten zu versuchen WPML neu zu registrieren und ggfls. dazu einen neuen Seitenschlüssle unter https://wpml.org/de/account/websites/ zu erstellen.

Sollte das Problem so nicht gelöst werden können, so erteilen Sie mir bitte Zugriff als Admin. Das private Antwortformular ist aktiviert.

Mit freundlichen Grüßen
Andreas

April 7, 2021 um 9:38 pm #8486287

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Zunächst habe ich die WP-Speichergrenze erhöht, da die verwendeten 40M hier nicht ausreichend sind. Danach habe ich das debug_log aktiviert. Vorhandene Fehler werden nun in einer debug.log Datei im Ordner /wp-content/ gespeichert.

Dann habe ich mir die Seiten angeschaut. Als Beispiel:

Die Seite "Akademie" war nicht komplett übersetzt.

Ich habe die Übersetzung abgeschlossen. Danach habe ich für die Seite unter WPML -> Translation Management -> Translation Dashboard einen neuen Übersetzungsjob erstellt.

Die Übersetzung öffnet sich allerdings weiterhin mit dem klassischen Editor.

Unter WPML -> Einstellungen -> Wie Sie Beiträge und Seiten übersetzen ist festgelegt, dass "Inhalt, der mit WPMLs klassischem Übersetzungs-Editor erstellt wurde" de "WPMLs klassischen Übersetzungs-Editor verwenden".

Kann es sein, dass es sich hier um Seiten handelt, die erstellt wurden, bevor der erweiterte Übersetzungseditor aktiviert wurde?

Ich sehe hier zudem einen Fehler im ATE Error Log. Kann es sein, dass hier ein Übersetzer entfernt wurde, der noch einen oder mehrere Jobs zugewiesen hatte?

Active record record not found: Couldn't find Translator with [WHERE `translators_websites`.`website_id` = ? AND `translators`.`email` = ?]

Zudem, kann es sein, dass der ATE kurzzeitig nicht funktionierte und deshalb im CTE editiert wurde. Das kann auch daran liegen, dass solche Nutzer, die den Editor nutzen dürfen, keinen kompletten Namen und keine gültige E-Mail zugewiesen bekommen haben.

Eine Möglichkeit wäre hier ​den klassischen Editor komplett zu deaktivieren. Siehe Screenshot.

Sollte keiner dieser Vorschläg nicht annehmbar für Sie sein oder dieser zu keiner Lösung führen, werden wir weitere Schritte vornehmen.

Mit freundlichen Grüßen
Andreas

April 8, 2021 um 9:08 am #8489235

venturisI

Hallo Andreas,
vielen Dank, ich habe den klassischen Editor deaktiviert. Jetzt lassen sich die Seiten mit dem ATE bearbeiten. Allerdings sind einige Headlines (z.B. bei "Anlagenplanung" (Plant design) auf deutsch und im ATE nicht zu bearbeiten. Des Weiteren werden Texte im ATE übersetzt aber dann nicht auf der englischen Seite übersetzt angezeigt (siehe Consulting, letzter Absatz: "Unterstützung der Migration…"

Viele Dank!

Mit freundlichen Grüßen
Ulrike Renner

April 8, 2021 um 12:19 pm #8491977

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Zum Heading:

Ich habe dies kurz im Original editiert und neu gespeichert. Sie können dieses nun Übersetzen. Gehen Sie so bitte auch bei anderen sichtbaren Elementen vor, die im ATE nicht angezeigt werden.

Bei dem Consulting Text-Block musste ich sogar dem originalen deutsche Textblock eine Charakter hinzufügen, das Element und die Seite speichern, damit die Übersetzung eine Aktualisierung erwartet. Den Charakter habe ich natürlich wieder entfernt.

Ich musste dann den Block neu übersetzen, aber danach funktionierte dies auch.

Diese Probleme sollten einmalig sein, nachdem der ATE aktiviert wurde und dann auf den gleichen Seiten nicht mehr auftauchen.

Lassen Sie mich bitte wissen, ob Sie weitere Hilfe benötigen.

Mit freundlichen Grüßen
Andreas

heading.PNG

Das Thema ‘[Geschlossen] Editor Ansicht hat gewechselt’ ist für neue Antworten geschlossen.