Skip Navigation

Dies ist das technische Support-Forum für WPML – das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team antwortet im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Our next available supporter will start replying to tickets in about 3.58 hours from now. Thank you for your understanding.

This topic contains 6 Antworten, has 3 Teilnehmer.

Last updated by marikaH-2 Vor 1 Monat.

Assigned support staff: Andreas W..

Author Artikel
April 27, 2021 um 5:18 pm #8637925

marikaH-2

Wir haben ein Update auf die aktuellste WordPress Version gemacht inkl. aller Plugins und des Themes.
Nach dem Update wurde alles übersetzt bis auf den Footer der mit Elementor erstellt wurde.
Wir haben schon diverse Lösungsschritte versucht:

- WP_MEMORY_LIMIT auf 256M erhöht
- max_input_vars auf 10000 erhöht
- Den Footer dupliziert und sogar neu erstellt
- String Translations inkl. Paket gelöscht

Leider hat keiner dieser Schritte geholfen, weswegen wir uns an den Support wenden.

VG

April 28, 2021 um 12:31 pm #8644451

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I understand right, that the Footer Template is translated and the content is showing up inside of the WPML Translation Editor, but the Front-End is showing only original language?

Could you please provide access as admin? I might need to take a copy of the site for debugging which for I would install the plugin "All In One WP Migration".

The private reply form is enabled.

Best regards
Andreas

April 30, 2021 um 7:42 am #8660341

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

On your site copy I can confirm that the issue persists, when switching to the Craftis Parent and running the site only with

ThemeREX Addons
Elementor
WPML Plugins

At this point I need to cerify if we can recreate the issue on a new test site and then escalate the issue from there towards our compatibility team who will review the problem and work on a solution.

For this I have created the following temporary test-site:

One-Click-Login:
hidden link

Please install the Craftis Theme and the ThemeREX Addons Plugin in their latest versions for this test. Elementor and WPML are pre-installed.

Leave me a short notification once the components are ready for testing.

Best regards
Andreas

Mai 1, 2021 um 5:10 pm #8668449

marikaH-2

The theme and plugin are installed.

Mai 4, 2021 um 8:23 am #8681649

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I was able to recreate the issue, which is actually not Elementor related, as it also occurs when using the default WordPress Editor Gutenberg. Anyhow, I see the templates are not showing up at all once Elementor is disabled.

I have created simple footer using the Gutenberg Blocks Logo, some text and a HTML Block. Text and HTML do not appear translated. I was able to adjust some custom field settings and make possible to select the translated footer inside the theme options of the pages, but apart from site logo and tagline, which are translate don String Translation, nothing else shows up as translated.

Please let me know if you would like to add some more details towards this investigation.

This is a compatilbity issue between the theme and WPML and I am escalating this towards our compatilbity team for further review.

Once I receive further advise or a possible workaround I will be in contact. Please also feel free to inform the theme support about incompatilbity between their template builder and WPML.

Best regards
Andreas

Mai 4, 2021 um 5:25 pm #8687895

Andrés
Supporter

Languages: Englisch (English ) Spanisch (Español ) Französisch (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello there,

t seems that your theme works slightly different and it expects you to translate your footer ID. Please follow this procedure:
- Open any of your pages.
- In the Multilingual Content Setup section > Custom fields.
- Set the "craftis_options" field to Translate.
- Translate your page.
- In the editor you will see a field field-craftis_options-0-footer_style. This field expects the ID of the layout, in the Sandbox it is 38.

Now, it will displayed the right footer.

footer_style.png
Mai 11, 2021 um 5:27 pm #8742655

marikaH-2

Hi, thanks for your help, but I have one more issue with your solution. I can change this option on the main page, but on some pages (like AGB) where I have the footer too, the fields are missing, even if I set the "craftis_options" to Translate.