Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

This thread is resolved. Here is a description of the problem and solution.

Problem: Ich möchte die Default Sprache der Strings umstellen Solution: Markieren Sie einfach den String mit der Checkbox und wählen Sie "Sprachen der Domain". Hier können Sie die Originalsprache der Strings auf Deutsch stellen.

Relevant Documentation: https://wpml.org/de/documentation-3/ratgeber-zum-loslegen/string-ubersetzung/#originalsprache-der-strings

Schlagwörter: 

This topic contains 6 Antworten, has 2 Teilnehmer.

Last updated by baerbel-ingeborgZ vor 3 Monate, 1 Woche.

Assigned support staff: Marcel.

Author Artikel
Juni 20, 2019 um 1:40 pm #4060283

baerbel-ingeborgZ

Ich versuche: translate strings in gravity forms

URL der/meiner Website, auf der das Problem auftritt: hidden link

Erwartet hatte ich zu sehen: alle strings either original language english or original language german.

Stattdessen bekam ich: it is a mixture. mostly it is correctly shown in german with translation needed to english, but some strings are in english
example:
address strings are correctly in german
questions for gender or type of membership shows english as the original language even though the words are german
i tried to change original language of strings but get the following error message
Sie haben Strings ausgewählt, die zu einem Paket gehören. Bitte wählen Sie alle Strings der betreffenden Pakets aus oder wählen Sie diese Strings ab.
(should read in english) You have selected strings that belong to a package. Please select all strings of the respective packages or select these strings.
so no idea what to do. checked forum, documentation, google, no help there
tks for a tip
BIZ

Juni 20, 2019 um 2:02 pm #4060497

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Bärbel-Ingeborg,

Vielen Dank, dass Sie den WPML Support kontaktiert haben.

#1 Können Sie bitte den Screenshot hochauflösend hochladen? Ich kann leider nicht bei der Größe erkennen um welche Strings es sich genau handelt.

#2 Ich habe bereits eine Vermutung wo das Problem liegt. Ich würde mir das gerne direkt auf Ihrer Seite ansehen. Dazu bräuchte ich bitte temporären Zugriff (WP-Admin und FTP) auf Ihre Seite, vorzugsweise zu einer Test/Staging Seite, an der das Problem nach Möglichkeit repliziert wurde.

Ihre nächste Antwort ist als „Privat“ markiert, dies bedeutet nur Sie und ich haben Zugriff darauf.

❌ Bitte sichern Sie Ihre Datenbank und Website davor ❌

✙ Ich würde außerdem Ihre Erlaubnis benötigen, um Plugins und das Theme zu deaktivieren und erneut zu aktivieren sowie Konfigurationen auf der Seite zu ändern. Dies ist auch der Grund, warum das Backup wirklich wichtig ist.

Freundliche Grüße
Marcel

Juni 20, 2019 um 3:07 pm #4060903

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Bärbel-Ingeborg,

vielen Dank,

das Passwortfeld hat leider die URL hinterlegt. Können Sie dies bitte nochmals prüfen?

Vielen Dank

Juni 21, 2019 um 7:28 am #4065175

baerbel-ingeborgZ

Hallo Marcel
Können Sie mich bitte nochmals auf private message setzen, damit ich das passwort nochmals übermitteln kann?
Vielen Dank und sorry für das Versehen gestern.
LG
BIZ

Juni 21, 2019 um 7:32 am #4065189

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Natürlich 🙂

Juni 21, 2019 um 8:36 am #4065507

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Bärbel-Ingeborg,

es lag hier kein Fehler vor, mein Verdacht hat sich nicht bestätigt. Sie können die fehlerhaften Strings einfach auf die korrekte Sprache umstellen und dann übersetzen.

z.B.:
gravity_form-1 field-66-label Termine
Markieren Sie einfach den String mit der Checkbox und wählen Sie "Sprachen der Domain". Hier können Sie die Originalsprache der Strings auf Deutsch stellen.

Ich hänge Ihnen noch die Anleitung an, dann können Sie den Prozess einfach mit den Screenshots folgen: https://wpml.org/de/documentation-3/ratgeber-zum-loslegen/string-ubersetzung/#originalsprache-der-strings

Freundliche Grüße
Marcel

Juli 6, 2019 um 3:56 am #4154927

baerbel-ingeborgZ

My issue is resolved now. Thank you!