Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

This topic contains 5 Antworten, has 2 Teilnehmer.

Last updated by Marcel vor 2 Monate, 3 Wochen.

Assigned support staff: Marcel.

Author Artikel
Juli 17, 2019 um 8:22 am #4227249

martinW-20

Ich versuche:
eine existierende Englisch-Übersetzung der Seite "Lech und der Arlberg" für den User freizugeben. Scheinbar erkennt aber WPML die übersetzte Seite nicht.

Weiters ist ein Update des Plugins nicht möglich. (Siehe Screenshot 6.png)

Beschreibung der Screenshots:

1.png:
Unter dem Reiter WPML->Übersetzungen fehlt unter dem Bearbeiten-Button der "Anzeigen-Link". Die englische Seite scheint also nicht erkannt zu werden, obwohl die Übersetzung existiert.

2.png:
Unter dem Reiter Seiten->Alle Seiten befindet sich neben der betreffenden Seite ein Plus Symbol mit dem Tooltip "Übersetzung in die Sprache EN hinzufügen". Das ist seltsam, da die Übersetzung schon existiert.

3.png:
Unter dem Reiter Seiten->Alle Seiten->Lech und der Arlberg kann ich im WordPress-Header den Inhalt auf EN einstellen. Sobald ich das mache, kommt die Fehlermeldung "Du versuchst ein Element zu bearbeiten, welches nicht existiert. Möglicherweise wurde es gelöscht?". (Siehe Screenshot 4.png)

5.png:
Der User der Website kann die Seite nicht auf Englisch umstellen (Der Button EN fehlt links neben dem DE-Button).

6.png:
Update des Plugins ist nicht möglich

URL der/meiner Website, auf der das Problem auftritt:
hidden link

Erwartet hatte ich zu sehen:
Die übersetzte Seite kann von einem User angesehen werden, indem er auf den EN Button drückt.

Stattdessen bekam ich:
Auf der Seite "Lech und der Arlberg" wird der EN Button nicht angezeigt. Daher kann ein User nicht auf die englische Seite zugreifen.

Juli 17, 2019 um 10:42 am #4228767

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Martin,

Vielen Dank, dass Sie den WPML Support kontaktiert haben.

#1 Bitte überprüfen Sie, ob die betroffene Seite mit identischem Namen im WordPress Papierkorb vorhanden ist. Wenn ja leeren Sie bitte den Papierkorb.

#2 Sehen Sie WPML Aktualisierungen, wenn Sie unter Dashboard "Prüfen" das Update Cache bereinigen? Dies wird durch Drücken des Buttons ausgelöst.

Bitte um Info

Freundliche Grüße
Marcel

Juli 17, 2019 um 11:12 am #4229295

martinW-20

Hallo Marcel,

danke für die schnelle Rückmeldung!

#1 Ich habe den gesamten Papierkorb geleert aber es hat sich leider nichts geändert.

#2 Ja, ich sehe Aktualisierungen des Plugins "WPML Translation Management". Im Anhang sende ich einen Screenshot.

Freundliche Grüße

Juli 18, 2019 um 8:16 am #4235949

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Martin,

#1 bitte aktualisieren Sie das angezeigte Plugin.

#2 Ich würde mir das gerne direkt auf Ihrer Seite ansehen. Dazu bräuchte ich bitte temporären Zugriff (WP-Admin und FTP) auf Ihre Seite, vorzugsweise zu einer Test/Staging Seite, an der das Problem nach Möglichkeit repliziert wurde.

Ihre nächste Antwort ist als „Privat“ markiert, dies bedeutet nur Sie und ich haben Zugriff darauf.

❌ Bitte sichern Sie Ihre Datenbank und Website davor ❌

✙ Ich würde außerdem Ihre Erlaubnis benötigen, um Plugins und das Theme zu deaktivieren und erneut zu aktivieren sowie Konfigurationen auf der Seite zu ändern. Dies ist auch der Grund, warum das Backup wirklich wichtig ist.

Freundliche Grüße
Marcel

Juli 22, 2019 um 1:57 pm #4258143
martinW-20

Hallo Marcel,

das beschriebene Problem hat sich nun gelöst. Ich habe die bestehenden Seiten dupliziert und neu übersetzt. Auf der Website sind nun auch alle WPML-Updates durchgeführt worden. Trotzdem sind weitere Probleme entstanden.

1. Wenn man den erweiterten Übersetzungsmodus aktivieren möchte, kommt folgende Fehlermeldung: "Error: Api error unprocessable entity: Empty value for display_name". (Screenshot im Anhang)

2. Bereits übersetzte Textblöcke, die sich auf Seiten befinden, sind plötzlich nicht mehr im WPML-Übersetzungseditor zu finden, obwohl sie existieren. Dadurch kann man die Übersetzungen der Blöcke nicht mehr verändern. Nachdem man jedoch den deutschen Text direkt auf der Seite verändert und speichert, werden die Blöcke wieder für kurze Zeit im Übersetzungseditor angezeigt.

Freundliche Grüße

Juli 22, 2019 um 2:31 pm #4258781

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Martin,

vielen Dank für die Info. Ich habe für Ihre neuen Fälle 2 neue Tickets angelegt. Dies hilft unseren Kunden die Problemlösungen einfach im Forum durch die Suchfunktion zu folgen. Ich werde diese Tickets schnellstmöglich beantworten.

Sie können dieses Ticket daher bitte als erledigt markieren.

Vielen Dank
Freundliche Grüße
Marcel