Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Our next available supporter will start replying to tickets in about 7.81 hours from now. Thank you for your understanding.

Schlagwörter: 

This topic contains 3 Antworten, has 2 Teilnehmer.

Last updated by Cristina vor 1 Jahr, 5 Monate.

Assigned support staff: Cristina.

Author Artikel
Mai 13, 2018 um 4:34 pm #2107062

benediktL-3

Hallo,

auf der englischen Version unserer Startseite (hidden link) ist das Produkt "I am Nobody who are you? Nr.2" fälschlicherweise mit einem Attachment verknüpft.
Der Link zeigt auf hidden link anstelle des eigentlichen Produkts.

Ich habe die Übersetzung bereits (unwiderruflich) gelöscht und neu angelegt und auf der Fehlerbehebungsseite unter "Aufräumen" sämtliche Buttons betätigt, leider ohne Erfolg.

Lässt sich dieser Fehler evtl manuell in der Datenbank bereinigen oder wie soll vorgegangen werden?

Mai 14, 2018 um 4:48 pm #2124817

Cristina

Hallo Benedikt,

wenn ich das korrekt verstehe, ist der Link auf der Startseite der englischen Galerie falsch zugewiesen, obwohl das übersetzte Produkt selbst schon gelöscht ist.

Wenn diese Homepage die Produktbilder abruft, müsste das eigentlich mit einem Update der englischen Homepage inklusive Cache-Leeren (auch der Autoptimize-Cache) korrigiert werden.

Ist das Bild selbst korrekt verlinkt oder hat

Wenn Sie die deutsche Seite aktualisieren, dann die englische Homepage updaten und die Clean Up Optionen aus WPML > Support > troubleshooting page anwenden, sollte die Homepage die richtigen Links zeigen.

Wenn Sie in der DB nachsehen wollen, was hier verlinkt ist, können Sie nach der ID des übersetzten Produkts suchen und die IDs der Produktbilder überprüfen und auch die Links der Bilder an sich korrigieren:

Um die Produktbilder zu überprüfen können Sie nach der ID des Produtks in der Tabelle wp_postmeta in der Spalte "post_id" suchen. Damit filtert man dann alle Meta-Einträge für diesen Post aus. Es können ziemlich viele sein. Die Felder, in denen Informationen zu Bildern enthalten sind, befinden sich in den Werten zum Metakey "_product_image_gallery". Dort sind die IDs der Produktbilder enthalte, die für das Produkt kopiert wurden.
Sie können hier die IDs der Medien überprüfen und ersetzen.

Um die Links der Bilder zu überprüfen, also ob die attachment_id die richtige ist, können Sie in der Tabelle wp_posts in der Spalte ID nach der ID des Bilds suchen. Das wäre hier das Bild für dieses Produkt.
Die Spalte guid enthält die URl des Bilds, so wie sie für die attachment_id genutzt wird. Wenn also das falsche Bild bei attachment_id 75 gezeigt wird, können Sie in der Spalte guid der ID 75 in der Tabelle _posts nachsehen, ob hier eine falsche oder richtige URL angezeigt wird.

Wenn die URL korrekt für das Bild ist, also der URL in der Medienbibliothek entspricht, sollte nach einem Update und der Synchronisierung der Homepage auch das richtige Bild erscheinen.

MfG,
Cristina

Mai 15, 2018 um 7:41 pm #2146576

benediktL-3

Die Produkte auf der Startseite sollen mit den Produktdetailseiten verlinkt sein. Es funktioniert wie gesagt nur der eine Produktlink nicht, alle anderen Produkte sind korrekt verlinkt. Dieser zeigt fälschlicherweise auf ein Attachment.

Der Link müsste sein:
hidden link

Aktuell ist er aber:
hidden link

Cache hatte ich bereits geleert bzw. ist dieser für eingeloggte User sowieso deaktiviert.

Mai 16, 2018 um 7:48 am #2151144

Cristina

Hallo Benedikt,

haben Sie in dem übersetzten Produkt selbst und in der Datenbank nachgesehen, ob die URL des Produkts noch mit dem richtigen Link gespeichert ist?

Wenn es nur bei diesem Produkt passiert, kann es in der DB eine kleinen Fehler geben, der dann den falschen Link abrufe.

Ich aktiviere die private Antwortoption, wenn Sie möchten, dass wir eine Blick auf die Seite werfen. Dafür wäre es praktisch, wenn Sie zuvor das Plugin Ari Adminer installieren und aktivieren, mit dem man die Einträge in der Datenbank bequem einsehen kann.

Die private Antwort ist nur für Sie und den Support sichtbar.

MfG,
Cristina

Das Thema ‘[Geschlossen] Falsche Link-Verknüpfung bei Produkt’ ist für neue Antworten geschlossen.