Skip Navigation

Dies ist das technische Support-Forum für WPML – das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team antwortet im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Heute stehen keine Supporter zur Arbeit im German-Forum zur Verfügung. Sie können gern Tickets erstellen, die wir bearbeiten werden, sobald wir online sind. Vielen Dank für Ihr Verständnis.

This topic contains 23 Antworten, has 2 Teilnehmer.

Last updated by danielK-111 Vor 8 Monate, 1 Woche.

Assigned support staff: Marcel.

Author Artikel
Januar 19, 2022 um 4:46 pm #10387085

danielK-111

Leider konnte ich das Problem nicht rekonstruieren. Die Sandbox Version ist doch noch ein wenig anders. Ich kann z.B. keine "Primär" Kategorie in dem Produkt festlegen. Außerdem ändert sich die URL auch nicht, nachdem ich das Produkt der Kategorie zugewiesen habe.

MfG

Januar 19, 2022 um 5:02 pm #10387117

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo,

überprüfen Sie die Permalink Einstellungen Ihrer Installation sowie die der Sandbox, ich nehme an, Sie haben dort einen Custom Permalink mit der Kategorie hinterlegt. Die Staging Seite ist leider nicht mehr aktiv um dies zu überprüfen.

Ansonsten werden Sie sich an die Plugin-Autoren von "WooCommerce TM Extra Product Options" wenden müssen, wenn das Problem in isolierter Form nicht reproduzierbar ist. Ggf. können die Autoren dies anhand einer Kopie Ihrer Seite überprüfen.

Freundliche Grüße
Marcel

Januar 19, 2022 um 5:13 pm #10387193

danielK-111

Ich konnte es nun doch rekonstruieren. Bei beiden wird "spiele" angezeigt obwohl beim hreflang "en" -> "games" stehen müsste.

Ich habe hierzu nochmal ein Bild hochgeladen.

MfG

Sanbox.JPG
Januar 19, 2022 um 7:30 pm #10388289

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Vielen Dank! Ich kann es damit nachstellen. Ich werde dies nun intern an das Compatibility-Team zur Überprüfung weitergeben und melde mich, sobald ich eine Rückmeldung dazu erhalte.

Freundliche Grüße
Marcel

Januar 20, 2022 um 10:50 am #10391729

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

(Internal Status Change)

Januar 24, 2022 um 8:32 pm #10421943

danielK-111

Hallo,

gibt es bereits Neuigkeiten zu dem Problem?

MfG

Januar 25, 2022 um 10:02 am #10424805

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo,

das Debugging wurde bereits durchgeführt und auch wurde festgestellt, was das Problem genau auslöst, es gibt jedoch noch keine Lösung dazu. Ich melde mich, sobald ich Neuigkeiten dazu erhalte.

Freundliche Grüße
Marcel

Januar 26, 2022 um 2:49 pm #10437383

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo,

wir haben einen Workaround dafür gefunden:

#1 Öffnen Sie wp-content\plugins\woocommerce-tm-extra-product-options\include\class-tm-extra-product-options.php file
#2 Suchen Sie nach dem Foolowing-Snippet am Ende der Methode THEMECOMPLETE_Extra_Product_Options::get_product_tm_epos() (um Zeile 3945):

$this->cpf[ $post_id ]["{$no_disabled}"]["f{$form_prefix}"] = $epos;
		
		return $epos;
}

Ersetzen Sie es mir:

	$this->cpf[ $post_id ]["{$no_disabled}"]["f{$form_prefix}"] = $epos;		
	if (class_exists('SitePress')) {
		wp_cache_flush();
	}
	return $epos;
}

Ein funktionierende Beispiel können Sie im Source Code von hidden link sehen.

Freundliche Grüße
Marcel

Januar 26, 2022 um 4:46 pm #10438655

danielK-111

Hallo,

habe den Fix nun implementiert. Das Problem ist damit wohl gelöst. Bleibt das auch so, wenn es zu einem Update von den Plugin kommt? Oder wird es dann wieder überschrieben?

Vielen Dank aber für die Hilfe.

MfG