Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Heute stehen keine Supporter zur Arbeit im German-Forum zur Verfügung. Sie können gern Tickets erstellen, die wir bearbeiten werden, sobald wir online sind. Vielen Dank für Ihr Verständnis.

This topic contains 10 Antworten, has 2 Teilnehmer.

Last updated by alexanderL-28 vor 2 Wochen, 3 Tagen.

Assigned support staff: Marcel.

Autor Beiträge
September 30, 2019 um 9:42 am #4663395

alexanderL-28

Hallo liebes WPML-Supportteam,

die Url einer der Seiten, die Probleme machen ist:hidden link

URL der/meiner Website, auf der das Problem auftritt: hidden link

Erwartet hatte ich zu sehen: Nach der Aktualisierung eines Beitrages habe ich erwartet, dass der Beitrag gespeichert wird.

Stattdessen bekam ich: Eine Fehlermeldung, die vom eingesetzten Bild produzuert wird:

Fatal error: Uncaught TypeError: Argument 1 passed to WPML_Media_Post_Images_Translation::translate_images_in_post_content() must be an instance of WP_Post, null given, called in /homepages/18/**********/htdocs/2017/wp/wp-content/plugins/wpml-media-translation/classes/media-translation/class-wpml-media-post-images-translation.php on line 107 and defined in /homepages/18/**********/htdocs/2017/wp/wp-content/plugins/wpml-media-translation/classes/media-translation/class-wpml-media-post-images-translation.php:130 Stack trace: #0 /homepages/18/**********/htdocs/2017/wp/wp-content/plugins/wpml-media-translation/classes/media-translation/class-wpml-media-post-images-translation.php(107): WPML_Media_Post_Images_Translation->translate_images_in_post_content(NULL, Object(WPML_Post_Element)) #1 /homepages/18/**********/htdocs/2017/wp/wp-includes/class-wp-hook.php(288): WPML_Media_Post_Images_Translation->translate_images(27) #2 /homepages/18/**********/htdocs/2017/wp/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, in /homepages/18/**********/htdocs/2017/wp/wp-content/plugins/wpml-media-translation/classes/media-translation/class-wpml-media-post-images-translation.php on line 130

September 30, 2019 um 12:35 pm #4664629

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Alexander,

Vielen Dank, dass Sie den WPML Support kontaktiert haben.

Das WPML Media Add-On ist auf Ihrer Seite neuer als das WPML Core Plugin. Können Sie bitte WPML Multilingual CMS sowie String Translation +Translation Management aktualisieren und versuchen den Fehler nachzustellen?

Bitte um Info.

Freundliche Grüße
Marcel

September 30, 2019 um 2:40 pm #4665571

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Danke für die Info.

Ich würde mir das gerne direkt auf Ihrer Seite ansehen. Dazu bräuchte ich bitte temporären Zugriff (WP-Admin und FTP) auf Ihre Seite, vorzugsweise zu einer Test/Staging Seite, an der das Problem nach Möglichkeit repliziert wurde.

Ihre nächste Antwort ist als „Privat“ markiert, dies bedeutet nur Sie und ich haben Zugriff darauf.

❌ Bitte sichern Sie Ihre Datenbank und Website davor ❌

✙ Ich würde außerdem Ihre Erlaubnis benötigen, um Plugins und das Theme zu deaktivieren und erneut zu aktivieren sowie Konfigurationen auf der Seite zu ändern. Dies ist auch der Grund, warum das Backup wirklich wichtig ist.

Freundliche Grüße
Marcel

Oktober 1, 2019 um 9:52 am #4670643

alexanderL-28

Sorry, arbeiten Sie gerade an der Website?

Oktober 1, 2019 um 10:01 am #4670773

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo,

Ich bekomme auch Fehler beim Speichern des Beitrages, wenn WPML deaktiviert ist. Die Seite bleibt dann mit folgenden Warnungen hängen:

Bitte prüfen Sie die betroffene Zeile 26:

Notice: Constant WP_POST_REVISIONS already defined in /homepages/18/******/htdocs/2017/wp/wp-content/themes/uoncorp-child/functions.php on line 26

Warning: Cannot modify header information - headers already sent by (output started at /homepages/18/******/htdocs/2017/wp/wp-content/themes/uoncorp-child/functions.php:26) in /homepages/18/******/htdocs/2017/wp/wp-admin/includes/misc.php on line 1196

Warning: Cannot modify header information - headers already sent by (output started at /homepages/18/******/htdocs/2017/wp/wp-content/themes/uoncorp-child/functions.php:26) in /homepages/18/d630089209/htdocs/2017/wp/wp-admin/post.php on line 222

Warning: Cannot modify header information - headers already sent by (output started at /homepages/18/******/htdocs/2017/wp/wp-content/themes/uoncorp-child/functions.php:26) in /homepages/18/******/htdocs/2017/wp/wp-includes/pluggable.php on line 1251

Warning: Cannot modify header information - headers already sent by (output started at /homepages/18/******/htdocs/2017/wp/wp-content/themes/uoncorp-child/functions.php:26) in /homepages/18/******/htdocs/2017/wp/wp-includes/pluggable.php on line 1254

Zeile 26:

define('WP_POST_REVISIONS', 10);

Ich habe zusätzlich noch in der wp-config.php den WordPress Speicher auf 256MB statt 40MB erhöht, sowie unter wp-content/debug.log die Fehler als Logdatei aufgezeichnet.
Freundliche Grüße
Marcel

Oktober 1, 2019 um 10:07 am #4670837

alexanderL-28

Hallo Marcel,

wenn ich das Plugin "WPML Media" (darauf wird ja in der fehlermeldung verwiesen) deaktiviere, dann verschwindet die fehlermeldung und der Beitrag wird normal gespeichert. Was kann das bedeuten?

Oktober 1, 2019 um 10:16 am #4670919

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Meinen Test habe ich ohne WPML Plugins durchgeführt, daher wurde der Fehler ebenso ohne Bezug auf WPML ausgelöst. (Siehe Logfiles)

Oktober 1, 2019 um 10:26 am #4671005

alexanderL-28

Sorry, da stimmt etwas nicht. Meine ursprungliche Meldung wird nach dem Bearbeiten eines Beitrages in der Dashboard ausgelöst. Wenn ich "WPML Media" abschalte, kommt sie nicht und ich kann den Beitrag normal speichern. Fehlermeldungen, die Sie oben gezeigt haben, kommen scheinbar nur dann, wenn man die Fehleausgabe in der wp-config auf maximum stellt. Es sind allerdings Fehler, die mit der besagten Fehlermeldung nichts zu tun haben und auch keinerlei Funktionsbeeinträchtigung verursachen.

Oktober 1, 2019 um 11:54 am #4671795

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Danke für die Info. Bitte versuchen Sie folgendes (nach einem Backup)

1. WPML > Support > Troubleshooting
2. Klicken Sie auf "Remove ghost entries from the translation tables".

Bitte um Info, ob Sie es damit lösen konnten.

Freundliche Grüße
Marcel

Oktober 1, 2019 um 12:07 pm #4671891

alexanderL-28

Hallo Marcel,

das ist die Lösung, Danke! 🙂

Können Sie bitte dieses Thema auf privat stellen bzw. löschen? Ich möchte nicht, dass Details des Projektes öffentlich sind.

Beste Grüße,
Alexander

Oktober 1, 2019 um 12:09 pm #4671917

alexanderL-28

My issue is resolved now. Thank you!