Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Our next available supporter will start replying to tickets in about 1.64 hours from now. Thank you for your understanding.

Schlagwörter: 

This topic contains 5 Antworten, has 2 Teilnehmer.

Last updated by anjaG-7 vor 3 Monate, 2 Wochen.

Assigned support staff: Noman.

Autor Beiträge
Juni 10, 2019 um 9:51 am

anjaG-7

Ich versuche: Die 404 Seite zu übersetzen

URL der/meiner Website, auf der das Problem auftritt: Die Website ist noch im Coming Soon Modus.

Erwartet hatte ich zu sehen: Alle Felder zur Übersetzung, jedoch fehlt der Text aus dem Inhaltselement "Featured Item"

Stattdessen bekam ich: Nur Titel und Buttontext zur Übersetzung angezeigt.

Juni 10, 2019 um 10:01 am #3986533

Noman
Supporter

Languages: Englisch (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. I am going to reply this in English, if you still need German support please let me know.

- Here are WPBakery Page Builder modules that are supported by WPML and will automatically be displayed on the Translator Editor page:
https://wpml.org/documentation/plugins-compatibility/how-to-build-multilingual-sites-with-wpbakery-page-builder-and-wpml/#supported-modules

- And here is a guide on how to make custom VC element WPML translation editor compatible:
https://wpml.org/documentation/support/wpml-integration-with-page-builders-that-use-shortcodes/
https://wpml.org/documentation/support/language-configuration-files/

- You can add XML code in WPML >> Settings >> Custom XML Configuration section
- Then you need to make a small change in the original page, for example, a space in your title.
- Edit the translation again

Please let me know if this resolves your issue or you need further assistance with this issue.

Thank you

Juni 10, 2019 um 10:39 am #3986833

anjaG-7

Dear Noman, thanks for your fast reply.

The instructions are a little misleading. I did the following steps:

1. checked the missing shortcodes (attach1)
2. created wpml-config.xml (attach2)
3. upload xml to the root folder of the WPBakery plugin (attach3)
4. deactivated the WPBakery plugin
5. activated the WPBakery plugin

Was that way the right way? Because it didn't work.

Best, Anja

Juni 10, 2019 um 1:22 pm #3987647

Noman
Supporter

Languages: Englisch (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Could you please try below steps and let me know how it goes?
- Edit the translation and finish it as it is (mark it as 100% Translated).
- Make a small change in the original page, for example, a space in your title.
- Edit the translation again.

Does it work this time? If still issue persists, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

Juni 10, 2019 um 2:25 pm
Juni 10, 2019 um 4:47 pm #3988901

Noman
Supporter

Languages: Englisch (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have fixed this issue by following below steps:
- Opened this page in edit mode:
hidden link
- Then duplicated existing VC elements and deleted original ones and pressed the update button.
- Edited the translation again

And now fields are available in translation editor for translation as you can see in the attached screenshot.

Could you please check and confirm?

Thank you

Juli 11, 2019 um 2:35 pm #4190983

anjaG-7

Dear Noman, thank you! Now I continue working on the page.

It's a mystery. Now I tried to translate the Spanish version, but there the fields are missing (attach1).

I saw the fields as in your screen shots in the English version (attach1).

But now, after I tried to do the same steps you did, in both versions the fields are missing again.

Why?

Best, Anja