Skip Navigation

Dies ist das technische Support-Forum für WPML – das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team antwortet im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Heute stehen keine Supporter zur Arbeit im German-Forum zur Verfügung. Sie können gern Tickets erstellen, die wir bearbeiten werden, sobald wir online sind. Vielen Dank für Ihr Verständnis.

This topic contains 5 Antworten, has 2 Teilnehmer.

Last updated by Marcel Vor 1 Monat, 2 Wochen.

Assigned support staff: Marcel.

Author Artikel
Juni 21, 2022 um 11:47 am #11508573
ulrikeL

So, nachdem mein Ticket schon geschlossen ist, das Problem aber weiter aktiv ist, hier der 2. Versuch. Es dreht sich um folgendes Ticket:
https://wpml.org/de/forums/topic/font-awesome-custom-icons-not-working/

Die Webseite liegt auf einem WordPress nginx Server - somit geht hier nichts mit htaccess

Die anderen Optionen in WPML habe ich so durchgeführt - jedoch keine Änderung.
Keine Ahnung ob das hilft - nach Login ist der Fehler nicht mehr da, aber dann irgendwann am nächsten Tag wieder.

Und bzgl. der Registrierung von wpml - hab ich alles versucht - da ich das Problem schon mal bei einer anderen Seite hatte - in dem Fall komme ich aber nicht weiter.

Neue Threads, die von Marcel erstellt wurden und mit diesem verbunden sind, sind unten aufgeführt:

https://wpml.org/de/forums/topic/seitenregistrierung-wpml/

Juni 21, 2022 um 1:49 pm #11509621

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo,

die Tickets werden nach ca. 10 Tagen ohne Rückmeldung automatisch geschlossen.

Bitte kontaktieren Sie Ihren Hoster hierzu. Den notwendigen ORIGIN header kann dieser ebenso für die unter NGINX konfigurieren: hidden link.

Für die Seitenregistrierung habe ich ein getrenntes Ticket angelegt, welches ich gleich im Anschluss beantworten werde.

Freundliche Grüße
Marcel

Juni 27, 2022 um 10:25 am #11549399

ulrikeL

Hi, so vom Provider wurden die nötigen Einstellungen vorgenommen - Problem ist geblieben. Wie gesagt, direkt nach dem Login als Admin werden auch alle Zeichen korrekt angezeigt. Ich brauche hier irgendwie eine Lösung für diese Webseite.

Juni 27, 2022 um 10:47 am #11549905

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo,

das Problem ist weiterhin im Browser Debugger ersichtlich. Es wurde scheinbar nichts umgestellt, der Referrer ist weiterhin unterschiedlich als in der übermittelten Dokumentation:

 Referrer Policy: strict-origin-when-cross-origin

Sie können dies selbst im Chrome Debugger unter "Network" überprüfen.

Access to font at '<em><u>hidden link</u></em>' from origin '<em><u>hidden link</u></em>' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource.

Wenn Ihr Hoster es nicht zusammenbekommt, fragen Sie Ihren Hoster ob dieser alternativ eine Rewrite Rule von https:// auf hidden link. Setzen kann.

Freundliche Grüße
Marcel

Juni 29, 2022 um 12:31 pm #11567691

ulrikeL

Also ich habe die Antwort hier erneut an meinen Provider gesendet - der ist auch sehr fähig! Die Änderungen sind eingepflegt worden. Anbei auch ein Screenshot. Sollte hier noch etwas erfolgen, würde er spezifischere Infos brauchen - grundsätzlich kann er alles umsetzen, aber bis jetzt hat er exakt das umgesetzt was ihr vorgechlagen habt.

screen6.png
Juni 29, 2022 um 1:16 pm #11568131

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo,

die Konfiguration scheint nun zu passen:

marce@MARCEL-NB MINGW64 /
$ curl -Ils hidden link
HTTP/2 200
server: nginx
date: Wed, 29 Jun 2022 13:08:04 GMT
content-type: text/html; charset=UTF-8
referrer-policy: strict-origin-when-cross-origin
x-frame-options: SAMEORIGIN
access-control-allow-origin: *

Es werden jedoch weiterhin CORS Fehler für die Schriften ausgegeben:

Access to font at 'hidden link' from origin 'hidden link' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource.

Es wird hier weiterhin versucht eine Ressource von einer https Domain abzufragen, obwohl WP unter hidden link..de läuft. Dies betrifft neben Ihrem Divi Theme auch das Formcraft Plugin.

Ihr Hoster kann versuchen den Eintrag für access-control-allow-origin: * mit den jeweiligen Filetypen (woff2) der Schriften zu ergänzen: Beispiel: hidden link

Dies ist nicht wirklich ein Fehler von WPML. Das Problem hierbei ist, dass in Kombination mit einer zweiten Sprache eine zusätzliche Referer-URL ohne www. geladen wird. Es wäre wohl generell ratsam dies direkt in der DB per Search/Replace zu beheben.

Freundliche Grüße
Marcel