Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Heute stehen keine Supporter zur Arbeit im German-Forum zur Verfügung. Sie können gern Tickets erstellen, die wir bearbeiten werden, sobald wir online sind. Vielen Dank für Ihr Verständnis.

Schlagwörter: 

This topic contains 9 Antworten, has 2 Teilnehmer.

Last updated by Juergen vor 1 Monat, 3 Wochen.

Assigned support staff: Diego Pereira.

Autor Beiträge
August 19, 2019 um 7:17 am

Juergen

Ich versuche: The image attachments on the website hidden link do not work, but if you click on the images of the english version, the attachments are found.

The error message says that to many redirections occurred. I disabled the plugins redirection and cache and deleted also the browser cache but the problem still persits.

Can you help please?

August 20, 2019 um 11:50 pm #4426809

Diego Pereira
Supporter

Languages: Englisch (English ) Spanisch (Español ) Portugiesisch, Brasilien (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hallo @juergen, welcome to the WPML support Forum!

Please go to WPML > Settings > Post Type Translation and check if the "Media (attachment)" is set as "Translatable - only show translated items".

After that, please go to Settings > Permalinks and re-save the permalink structure.

Please let me know if it worked for you.

All the best,
Diego

August 21, 2019 um 8:47 pm #4434995

Juergen

Hello Diego,

I did as you proposed, but it did not help. The attachment page is not found than. I also tried "Translatable - use translation if available or fallback to default language" but that is where endless redirection occurs.

Again, I do not want to translate media. I put two languages in the media description and that does the job as e.g. at hidden link

However, this does not work on more and more posts.

Since there are some posts where the concept is working, it could not be a general setting, could it? There are many more settings (see attachment) which I did not notice before ...

Thanks!

August 22, 2019 um 12:06 pm #4439117

Diego Pereira
Supporter

Languages: Englisch (English ) Spanisch (Español ) Portugiesisch, Brasilien (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks for the feedback. I understand that you don't want to translate media, but setting post type media to translatable is necessary for WPML to work properly. It doesn't mean you need to translate them.

Please send us access to your WordPress dashboard (website URL, login and password) I'll take a look at the settings. - Please use the private field to send the sensitive data - do not post if you do not see it.

It would be better if you give me a test site rather than the live site.

IMPORTANT Please backup a working copy of site files and database before.

If possible, please also install these plugins (it may speed up the process):
Duplicator: https://wordpress.org/plugins/duplicator/
File Manager: https://wordpress.org/plugins/wp-file-manager/
All-in-one WP Migration hidden link
Adminer: https://wordpress.org/plugins/ari-adminer/
Cloudways WordPress Migrator: https://wordpress.org/plugins/bv-cloudways-automated-migration/

Kind regards,
Diego

August 23, 2019 um 8:32 am
August 23, 2019 um 2:03 pm #4447995

Diego Pereira
Supporter

Languages: Englisch (English ) Spanisch (Español ) Portugiesisch, Brasilien (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thank you. I tried to login with the provided credentials but I got the following message: "ERROR: The password you entered for the username **** is incorrect. Lost your password?"

Could you please check?

Kind regards,
Diego

August 23, 2019 um 7:00 pm #4449557

Juergen

I am sorry, Diego! I generated a new password and try to mail it to you via the previous used way.

August 23, 2019 um 7:03 pm #4449573

Juergen

Sorry, Diego, apparently the secure form does not work any more. How can I provide you with the new password?

Thanks, Jürgen

August 23, 2019 um 7:05 pm #4449577

Juergen

... I was able to edit the private message, so you should see the new password there.

August 26, 2019 um 5:06 pm #4460481

Diego Pereira
Supporter

Languages: Englisch (English ) Spanisch (Español ) Portugiesisch, Brasilien (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks, it worked now. I made a copy at my local server using duplicator.

I suspect it is a workflow issue. The attachment page is created the moment the media is added to the post. Perhaps the media was added at the time the settings were incorrect, which did not generate the correct link.

I suspect it is a workflow issue. The attachment page is created the moment the media is added to the post. Perhaps the media was added at the time the settings were incorrect, which did not generate the correct link.

I tried the steps below:
- Check the settings on WPML > Settings > Post Type Translation ( "Media (attachment)" should be set as "Translatable - only show translated items".
- Mark all fields on WPML > Settings > Media Translation, click on "Apply", then click on "Scan"
- Go to the edit screen of the page, on the secondary language (German)
- Add the image again to the post, then select it to link to the secondary language

I recorced the results here: hidden link - The link of the new image (second) works fine. I kept the first image to compare the results.

So the solution is to remove the image then add it again to the post. It will generate the correct link this time, as the settings are correct now.

Please let me know if it works for you.

Kind regards,
Diego

August 27, 2019 um 8:50 am #4463947

Juergen

My issue is resolved now. Thank you!