Skip Navigation

Dies ist das technische Support-Forum für WPML – das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team antwortet im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Our next available supporter will start replying to tickets in about 8.89 hours from now. Thank you for your understanding.

This topic contains 5 Antworten, has 2 Teilnehmer.

Last updated by ursK-3 Vor 7 Monate, 1 Woche.

Assigned support staff: Andreas W..

Author Artikel
April 11, 2022 um 5:19 pm #10997241

ursK-3

Hello
I've been trying to set WPML for a few hours now so that the images of my products appear in all languages but the title and alt text don't need to be translated.
I have a lot of images and I don't want to have to click through all of them for each product.
Another question how can I hide the already translated "sentences" in the ATE?
In the old editor I found the setting.
Greetings Beni

Bildschirmfoto 2022-04-11 um 19.09.34.png
April 12, 2022 um 4:16 pm #11005569

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

In order to avoid translating the image metadata, you need to disable the Plugin WPML Media Translation.

Now, in case you actually need to replace images with alternative physical versions of translated images, you might need WPML Media Translation.

What you could do in such a case is:

1) Cancel the current job at WPML > Translation Management > Jobs
2) Create a new job at WPML > Translation Management Dashboard
3) When creating the job do only mark the images that need a translation.

This feature also is only available when using the WPML Media Translation Plugins.

See details here:
https://wpml.org/documentation/getting-started-guide/media-translation/#id2

Another thing you could try is going to the Media Library and unattach the image from the current content.
Go to the Media Libray and change to list view. Inside the column for "Attached to" unattach the media.

More details about this here:
hidden link.

Best regards
Andreas

April 18, 2022 um 3:12 pm #11039281

ursK-3

This is not working.
I deleted the plugin: Media Translation

Canceled all jobs and deleted all translations from my Woocommerce products.

Then I select translate again and there I have to translate all image ALT and Titles again..!

Greetings Beni

April 19, 2022 um 9:19 am #11043561

ursK-3

Actually now only the product images / gallery pictures (Woocommerce) are for translating.
All ACF fields are fine now.

April 19, 2022 um 6:42 pm #11048725

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Those are good news.

Once we upload an image for the first time on a post, inside the media library the image get attached to this content.

WPML will only translate attached media.

You can see the attached media in the Media Libraries list view.

In fact, the featured image and product gallery are handled by WPML Core.

You do have a global setting for those translations and a sync option at WPML > Settings > Media Translation.

Further, you will find on each post, page, or product a setting for media attachment duplication. This means, that if those fields are not marked, then the products would be without any image.

If you mark the options WPML will create a duplicate on the database and ask you to translate the image meta.

The "Start" button at WPML > Settings > Media Translation will create image entries on the database in all active languages automatically.

Please let me know if you do have further questions regarding this.

Mit freundlichen Grüßen
Andreas

April 20, 2022 um 12:34 pm #11055551

ursK-3

My issue is resolved now. Thank you!