Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

This thread is resolved. Here is a description of the problem and solution.

Problem: Ein iFrame Widget wird nicht in der übersetzen Version in der falschen Sprache angezeigt. Solution: Das Element war in Elementor als Global Widget angelegt, dies musste deaktiviert werden.

Schlagwörter: 

This topic contains 14 Antworten, has 2 Teilnehmer.

Last updated by hartmutT vor 3 Monate.

Assigned support staff: Marcel.

Author Artikel
Juli 9, 2019 um 2:55 am #4166949

hartmutT

Fremdsprache ausgeben. Mit String Übersetzung.

URL der/meiner Website, auf der das Problem auftritt: hidden link

Das Passwort für at für Sie: (removed WPML Support)

Die Übersetzung ist in String Übersetzung eingegeben, Sie wird jedoch nur in der Standard ausgegeben, obwohl alle Übersetzungsteile vorhanden sind.

Mit freundlichem Gruss

Juli 9, 2019 um 11:00 am #4169903

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Hartmut,

Vielen Dank, dass Sie den WPML Support kontaktiert haben.
Ich habe nun das Passwort entfernt, da dies öffentlich einsehbar ist.

Ich benötige für einen Login bitte auch den Benutzernamen Ihrer Installation.
Anhand Ihrer Debug Info sehe ich, dass Sie die max_input_vars in Ihrer php.ini auf Wert 1500 konfiguriert haben. Bitte erhöhen Sie dies auf Wert 10000. Sie können dies direkt in Ihrer php.ini konfigurieren falls Sie darauf Zugriff haben, oder Sie bitte Ihrem Webhoster dies für Sie zu erledigen.
Bitte um Info ob Sie das Problem damit lösen konnten.

Freundliche Grüße
Marcel

Juli 9, 2019 um 11:09 am #4169949

hartmutT

Hallo Marcel,

Unverändert nach erhöhung des wertes auf 10000

MfG

Nun nöchte ich die Seite weiter Bearbeiten, auch die At Seite, so bekomme ich diese Meldung:

Warning: You are trying to edit a translation using the standard WordPress editor but your site is configured to use the WPML Translation Editor.

Go back Edit anyway Open in Translation Editor

Don't show this warning again

Darf ich die Seite nur noch in Deutsch Bearbeiten, in dem original?

Blockt WPML das ich dort Anpassungen vornehmen kann, auch gegebenenfalls mit dem Elementor?

MFG

Juli 9, 2019 um 11:15 am #4170059

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Ich bräuchte bitte temporären Zugriff (WP-Admin und FTP) auf Ihre Seite, vorzugsweise zu einer Test/Staging Seite, an der das Problem nach Möglichkeit repliziert wurde.

Ihre nächste Antwort ist als „Privat“ markiert, dies bedeutet nur Sie und ich haben Zugriff darauf.

❌ Bitte sichern Sie Ihre Datenbank und Website davor ❌

✙ Ich würde außerdem Ihre Erlaubnis benötigen, um Plugins und das Theme zu deaktivieren und erneut zu aktivieren sowie Konfigurationen auf der Seite zu ändern. Dies ist auch der Grund, warum das Backup wirklich wichtig ist.

Freundliche Grüße
Marcel

Juli 9, 2019 um 1:21 pm #4171185

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Vielen Dank. Um welchen (HTML) String handelt es sich genau auf der verlinkte Beispielseite?

"Darf ich die Seite nur noch in Deutsch Bearbeiten, in dem original? Blockt WPML das ich dort Anpassungen vornehmen kann, auch gegebenenfalls mit dem Elementor?"

--> Die Meldung besagt, dass Sie die Seite direkt geöffnet haben, jedoch der WPML Editor aktiviert ist. Bitte klicken Sie in der Standardsprache auf die Flagge und übersetzen die den Text über den WPML Translation Editor (jener welcher links die Default Sprache anzeigt und rechts die Übersetzung, nicht über die Elementor Seite)

Freundliche Grüße
Marcel

Juli 9, 2019 um 1:43 pm #4171337

hartmutT

Die HTML Strings oder der der in de und at ist:
elementor-2679 html-html-2679

Dieser ist in beiden sprachen vorhanden, wird in AT nicht ausgeben.

Bei dem Besagten öffnen so das es korrekt ist das die Seite Geöffnet wurde, und nicht über den WPML Link. Ist Korrekt!

Folgendes Szenario:
1. Im Original ist in der Mehrzahl geschrieben.
2. In AT ist es in Einzahl. (Was auch über jahre noch sein wird.) Auch wenn zb NL oder eine Andere Sprache in der Mehrzahl nicht benötigt wird, wie kann ich einem Übersetzer das beibringen der nach dem Satz übersetzt. {Mein Gedanke dazu war: Das in AT in einzahl zu Schreiben und von dort dann Gegebenenfalls zur übersetzung zu geben.}
3. Wenn ich in At Kommentar zulassen möchte, und in DE nicht. So müsste ich in die Einstellungen direkt in der WP Editor Ansicht das einstellen. Wobei die Meldung kommt.

Anders formuliert:
A
Original in Mehrzahl. Die HTML integration so übersetzen können. So das es ausgegeben wird. Übersetzung in At in Einzahl eingeben, und einem übersetzer von at nach sagen wir nl in Einzahl übersenden. Wobei der HTML Code auch wieder in der String Übersetzung geändert wird. Sollte es mehrere nl Rechner geben so würde ich gerne die DE variante zur übersetzung in nl heran ziehen.

B
Einstellungen die auf der DE Seite anders sein werden als auf der AT oder CH Seite. Dürften doch nur über die eigentliche wordpress Benutzeroberfläche machbar sein? Nicht über die übersetzungs Seite. Da einstellungen verändert werden. Sagen wir Schlagwörter oder auch Kategorien.

Freundliche Grüsse

Hartmut

Juli 10, 2019 um 2:34 pm #4181525

hartmutT

Hallo Marcel,

gerade probierte ich der Seite der ich das Passwort gab, das Passwort zu geben, was auch beim speichern Augenscheinlich in der übersicht der Blogbeiträge dort war.

Jedoch im Frontend auf der Seite war diese ohne Passwort. Auch hinterher im Backend war das Passwort nicht mehr dort.

Also wurde das Passwort Gelöscht.

Eine Weiteres Phänomen, die Sprache wird auf Standard Englisch eingestellt wenn ich von de zu at gehe. Ist es dort möglich die sprache auf meine Bevorzugte einzustellen?

Mit freundlichem Gruss

Hartmut

Juli 11, 2019 um 1:22 pm #4190093

hartmutT

Hallo wpml-Team,

Selbst beim deaktivieren des Elementors, wird die Übersetzung nicht mit in das Frontend ausgebeben.

Quasi WPML WordPress alleine.

Mit freundlichem Gruss

Juli 11, 2019 um 4:56 pm #4192099

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Hartmut,

bitte entschuldigen Sie die verspätete Antwort.

Also der String wurde als "Teilweise übersetzt" angezeigt. Ich habe die Übersetzung nun mit der Checkbox abgeschlossen.

hidden link

Es ist jedoch hier die Sprache "AT" temporär deaktiviert, somit wird die Seite nicht umgeschaltet (über die Flagge)
hidden link

Können Sie dies bitte überprüfen, dann prüfen die Ihre weiteren Fragen.

Freundliche Grüße
Marcel

Juli 11, 2019 um 5:08 pm #4192173

hartmutT

Hallo Marcel,

Kein unterschied.

Es wird nach wie vor Deutschland angezeigt.

MfG

Hartmut

Juli 11, 2019 um 5:15 pm #4192189

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Hartmut,

die Seite wird nun jedoch als AT angezeigt und auch die Flagge zeigt AT. Es wird auch der Kreditrechner ausgegeben:
hidden link?
Der Link aus Ihrem ersten Beitrag leitet auf die DE Seite, diese kann nun umgestellt werden.

Oder verstehe ich nun etwas falsch?

Bitte um Info

Freundliche Grüße
Marcel

Juli 11, 2019 um 5:18 pm #4192261

hartmutT

Danke für die fixe Antwort.

Der Rechner der angezeigt wird, das ist der Deutsche.

nicht der hinterlegte at rechner. Die Übersetzung wird nicht ausgegeben.

MfG

Hartmut

Juli 11, 2019 um 5:20 pm #4192263

hartmutT

im original sieht der so:

hidden link

aus.

MfG

Juli 12, 2019 um 8:29 am #4196391

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Hartmut,

vielen Dank für die Info.

Sie hatten in Elementor auf der Seite ein globales Widget gesetzt. Somit wurde jeweils der iframe in allen Varianten angezeigt. Ich habe dies nun aufgelöst und die 2 Ratenkreditrechner manuell auf der Seite hinzugefügt. Somit hatte die übersetzte Version in der String Translation keine "Funktion".

Bitte überprüfen Sie für die deutsche Seite jedoch die Parameter, da das deutsche durch die AT als globales Widget überschrieben wurde.

hidden link
hidden link

Freundliche Grüße
Marcel

Juli 12, 2019 um 5:35 pm #4200759

hartmutT

My issue is resolved now. Thank you!