Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Our next available supporter will start replying to tickets in about 2.74 hours from now. Thank you for your understanding.

This topic contains 14 Antworten, has 2 Teilnehmer.

Last updated by Marcel vor 4 Monate, 3 Wochen.

Assigned support staff: Marcel.

Author Artikel
April 28, 2019 um 1:18 pm #3698127

rainerW-5

Ich versuche:
Seiten zu übersetzen

Erwartet hatte ich zu sehen:
Ich hatte nicht die Möglichkeit Inhalte meiner Seiten zu übersetzen. Ich kann anscheinend nur die Überschriften übersetzen

Leider kann ich ihnen keine Bilder hochladen.... scheint nicht zu funktionieren

April 29, 2019 um 8:39 am #3701167

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Rainer,

Vielen Dank, dass Sie den WPML Support kontaktiert haben. Gerne bin ich Ihnen bei dieses Problem behiflich:

#1 Updates: Bitte aktualisieren Sie alle WPML Komponenten auf die neueste Version, sowie den WPBakery Page Builder auf die Version 5.7.

Die Upload Größe ist hier auf 1MB beschränkt, dies könnte den Fehler verursacht haben. Sie können alternativ auch einen Image Hoster wie z.B. hidden link verwenden.

#2 PHP Speichergrenze (MemoryLimit) erhöhen

Könnten Sie bitte Ihre WordPress-Speichergrenze (WP Memory Limit) auf mindestens 256 MB erhöhen? Für WPML ist mindestens 128M erforderlich. Sie verwenden momentan 40MB.

Fügen Sie diesen Code Ihrer wp-config.php hinzu, um den Arbeitsspeicher von WP zu erhöhen:

define ('WP_MEMORY_LIMIT', '256M');
Fügen Sie es kurz vor: 
/ That's all, stop editing! Happy blogging. / 

Bitte geben Sie mir Bescheid, welche Fehler Sie im Log lokalisieren konnten.

Freundliche Grüße
Marcel

Mai 2, 2019 um 8:29 am #3722709

rainerW-5

warum auch immer klappt das Update jetzt, nachdem ich zwischenzeitlich nichts mehr hatte als eine weiße Seite. Nachdem ich dann die Sicherung vom Vortag eingespielt habe (zu dem Zeitpunkt hatte ich aber auch das Update-Problem) konnte ich updaten.... sehr seltsam.

Leider kann ich nichts übersetzen, weil zum Einen die falsche Sprache bei der String-Übersetzung angezeigt wird..... (wobei ich das Problem lösen konnte, indem ich die Sprache dort wechseln kann)…………
zum Anderen ist die gesamte Formatierung bei einer Übersetzung weg.
Ich benutze WP-Bakery und hier scheint es Probleme mir WPML zu geben.....

Ich sende 2 Bilder. So wie es in Englisch aussieht und wie es in Deutsch aussieht.....

ups...der Button zum Hochladen funktioniert ja gar nicht.... vergessen....

also in Englisch zeigt es auf der Seite nur einen Code. der sieht so aus:

Reservieren Sie Ihr Zimmer zum besten Preis / reserve your room for the best price
u003ch6u003eu003cspan style=u0022color: #941a21;u0022u003eu003cstrongu003eFragen zu Reservierungen über: u003c/strongu003eu003c/spanu003eu003c/h6u003enu003culu003enu003cliu003eu003cspan style=u0022color: #000000;u0022u003eTelefon : +49 6645 7755356 u003c/spanu003eu003c/liu003enu003cliu003eu003cspan style=u0022color: #000000;u0022u003eWhatsApp: +49 171 1238 696u003c/spanu003eu003c/liu003enu003cliu003eu003cspan style=u0022color: #000000;u0022u003eemail: reservierung@mauritius-ht.deu003c/spanu003eu003c/liu003enu003cliu003eu003cspan style=u0022color: #000000;u0022u003eFax : +49 667 9 6443 333u003c/spanu003eu003c/liu003enu003c/ulu003e

u003cpu003e

Mai 2, 2019 um 9:10 am #3723041

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Rainer,

ich habe den Button nun ausprobiert und konnte keine Probleme feststellen. Ebenso bekommen wir Tickets wo Bilder enthalten sind. Wenn die Bilder größer als 1MB sind komprimieren Sie diese bitte oder verwenden wie oben verlinkt einen Image Hoster, dann sollte dies klappen.

Wir sind mit WPBakery kompatibel, es sind hier aber teilweise einige Einstellungen zu machen. Da WPBakery ein Shortcode basierter Page Builder ist, kann die Formatierung wie oben beschrieben angezeigt werden. Es muss sozusagen davor das HTML "escaped" werden, damit die Sonderzeichen das HTML nicht brechen.

Hier mehr zum Thema: https://wpml.org/documentation/plugins-compatibility/how-to-build-multilingual-sites-with-wpbakery-page-builder-and-wpml/

https://wpml.org/documentation/support/maintaining-wpbakery-page-builder-compatibility-with-wpml/

Sie müssen bitte die XML Konfiguration anlegen wie beschrieben, damit verlieren Sie keine Formatierungen mehr. Wenn Sie mir bitte die Bilder wie beschrieben anhängen, kann ich Ihnen hierbei behilflich sein.

Beste Grüße
Marcel

Mai 2, 2019 um 9:34 am #3723315

rainerW-5

Super..... dann habe ich ja noch Hoffnung.....

Edge Browser wollte den Button nicht.
Opera hat funktioniert

Mai 2, 2019 um 2:15 pm #3725549

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Sehr gut, vielen Dank.

Nun nehmen wir hidden link als Beispiel.

Ich bräuchte bitte temporären Zugriff (WP-Admin und FTP) auf Ihre Seite, vorzugsweise zu einer Test/Staging Seite, an der das Problem nach Möglichkeit repliziert wurde. Hier kann ich die Seite (Doppelzimmer) überprüfen. Haben Sie bereits die Speichermenge erhöht, sowie WPML aktualisiert?

Ihre nächste Antwort ist als „Privat“ markiert, dies bedeutet nur Sie und ich haben Zugriff darauf.

❌ Bitte sichern Sie Ihre Datenbank und Website davor ❌

✙ Ich würde außerdem Ihre Erlaubnis benötigen, um Plugins und das Theme zu deaktivieren und erneut zu aktivieren sowie Konfigurationen auf der Seite zu ändern. Dies ist auch der Grund, warum das Backup wirklich wichtig ist.

Freundliche Grüße
Marcel

Mai 2, 2019 um 2:31 pm #3725631

rainerW-5

Wo mache ich das denn privat ?

Mai 2, 2019 um 2:35 pm #3725675

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Wenn Sie auf diese Antwort zurückschreiben, haben Sie automatisch ein privates Eingabefeld aktiviert. Hier können Sie dann die Zugangsdaten in die dafür vorhergesehenen Felder eintragen.

Mai 3, 2019 um 11:22 am #3733737

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Rainer,

vielen Dank für die Logindaten. Folgendes ist mir nun aufgefallen:

#1 Ihre Seite verwendet 2 Page Builder: SiteOrigin sowie WPBakery zusammen?
#2 Einige Funktionen bezüglich String Translation funktionieren evtl. ohne utf8mb4-Zeichensatz nicht richtig. Bitte kontaktieren Sie Ihren Hoster, um den Utf8mb4-Zeichensatz zu aktivieren, siehe https://wpml.org/home/minimum-requirements/
#3 Ihr Speicherlimit ist auf 40MB gesetzt. Bitte erhöhen Sie dies auf mind. 128MB, besser 256MB:

Fügen Sie bitte diesen Code Ihrer wp-config.php hinzu, um den Arbeitsspeicher von WP zu erhöhen:

define ('WP_MEMORY_LIMIT', '256M'); 

Fügen Sie es kurz vor:

 /* That's all, stop editing! Happy blogging. */ 

#3 Wenn Sie wie auf der oben verlinkten Beispiel Seite den SiteOrigin Page Builder verwenden, beachten Sie bitte folgende Anleitung. Speziell die "Use WPML’s Translation Editor" Option sollte deaktiviert sein. https://wpml.org/documentation/plugins-compatibility/using-wpml-siteorigin/

Bitte um Info, mit welchem Page Builder sie nun weitermachen wollen, dann können wir eine XML dafür anlegen.

Beste Grüße
Marcel

Mai 6, 2019 um 6:54 am #3745359

rainerW-5

Hallo Marcel,

ups, was ist denn da los? Ich muß mal schauen, ob die beide zum Theme gehören....
Ich kümmere mich mal darum dort Ordnung rein zu bekommen und melde mich spätestens morgen

Liebe Grüße
Martin

Mai 6, 2019 um 8:55 am #3746031

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Rainer,

vielen Dank für die Rückmeldung. Geben Sie mir einfach Bescheid, wenn Sie so weit sind 🙂

Beste Grüße
Marcel

Mai 7, 2019 um 12:03 pm #3757601

rainerW-5

Hallo Marcel,

folgendes habe ich gemacht.
Ich habe WP-Bakery deaktiviert und folgende Zeile in die wp-config eingefügt:
define ('WP_MEMORY_LIMIT', '256M');
Dann habe ich die Seiten wo WP-Bakery benutzt wurde wieder gerade gezogen....

Beim Versuch eine Seite zu übersetzen taucht aber auch wieder nur die Überschrift auf.

Was ist denn jetzt zu tun ?

Mai 13, 2019 um 1:21 pm #3798627

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Rainer,

bitte entschuldigen Sie die Verzögerung. Ich habe mir nun alles im Detail angesehen und habe eine Lösung für Ihr Problem gefunden:

#1 Bitte löschen Sie zuerst alle Seiten von hidden link wo der Fehler auftaucht – Wichtig: Danach muss unbedingt der Papierkorb unter „Seiten“ geleert werden.

#2 Dann muss eine neue Seite exakt nach Anleitung über die Duplizier Funktion angelegt werden: https://wpml.org/documentation/plugins-compatibility/using-wpml-siteorigin/ (Dies habe ich nun für „Double Room Standard“ gemacht)

#3 Danach kann eine Seite (wie Double Room Standard) über den normalen Editor übersetzt werden: hidden link
Wenn alle Schritte so ausgeführt werden, finden Sie die fehlerfreie Seite so vor: hidden link

Ich hoffe Sie können es nun übersetzen, ansonsten geben Sie mir bitte Bescheid, wenn Sie Fragen dazu haben.

Beste Grüße
Marcel

Mai 20, 2019 um 6:36 am #3843967

rainerW-5

bei mir scheint es nur zu gehen, wenn ich eine Seite neu erstelle und dann mit "duplicate" übersetze. Alle anderen Dinge funktionieren nur halb, oder gar nicht bei mir.

Eine vorhandene Seite bekomme ich nicht mehr dazu irgendwas übersetzen zu können.

Mai 23, 2019 um 9:59 am #3873241

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Rainer,

genau, dies ist wie in meiner Anleitung beschrieben der Fall. Bitte legen Sie einfach neue Seiten nach der Anleitung an, dann können Sie das Problem beheben.

Bitte geben Sie mir Bescheid, wenn Sie hier weitere Unterstützung benötigen.

Beste Grüße
Marcel