Skip Navigation

Dies ist das technische Support-Forum für WPML – das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team antwortet im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Heute stehen keine Supporter zur Arbeit im German-Forum zur Verfügung. Sie können gern Tickets erstellen, die wir bearbeiten werden, sobald wir online sind. Vielen Dank für Ihr Verständnis.

This topic contains 6 Antworten, has 2 Teilnehmer.

Last updated by markusZ-5 Vor 2 Monate.

Assigned support staff: Andreas W..

Author Artikel
Juli 6, 2021 um 5:20 pm #9141649

markusZ-5

Ich nutze Divi 3 von Elegant Themes, womit ich meine WordPress Website gestalte.
Wenn ich mir nun die Übersetzung für eine einzelne Seite aufrufe, dann habe ich seit einigen Monaten folgendes Problem. Ich kann die jeweiligen Textabschnitte zwar übersetzen, jedoch am Ende die komplette Übersetzung nicht speichern. Früher gab es am Ende danneinen Speicher-Button, welchen es jedoch seit längerer Zeit nicht mehr gibt. Ich nahm an, dies war aufgrund eines fehlenden Updates nach Ablauf meines Jahresabos und buchte dann irgendwann ein neues Abo, was den Fehler doch letztendlich nach einem Update nicht behob. Nach wie vor kann ich Seiten nicht speichern nach dem übersetzen.
Aktuelles Beispiel ist diese Seite:
hidden link

Einen Screenshot habe ich auch angehangen. Dort habe ich zwar nun grade keine Übersetzungen gemacht und die Häkchen bei "Translation is complete" nicht gesetzt, doch auch auch wenn ich alles übersetzt und alle Häkchen gesetzt habe, erscheint kein Speichern-Button, wie er vorher immer am Seitenende zu sehen war.

Ein weiteres Problem ist, wenn ich bei einigen der Textbausteine auf den Button "copy from original" klicke, ist dann das Übersetzungsfeld wie blockiert. D.h. ich kann nichts mehr einfügen und auch den haken nicht mehr setzen.
Ich bitte um eine Lösung des Problems.
Danke!

lIebe Grüße
Markus

Bildschirmfoto 2021-07-06 um 6.59.24 PM.png
Juli 7, 2021 um 12:35 am #9143221

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo Markus,

Könnten Sie bitte einmal folgendes Plugin installieren und mich wissen lassen, ob das Problem danach weiterhin besteht?

https://wordpress.org/plugins/enable-jquery-migrate-helper/

Mehr zum Thema:
https://wpml.org/errata/visual-tab-in-classic-translation-editor-is-not-showing-contents-after-update-to-wordpress-5-6/

Zudem, erhöhen Sie bitte die WP Speichergenze (WP Memory Limit). Der aktuelle Wert von 40M ist hier möglicherweise nicht ausreichend.

Ihre aktuellen Werte sind:

PHP MemoryLimit 268435456M
WP Memory Limit 40M
Fügen Sie diesen Code Ihrer wp-config.php hinzu, um den Arbeitsspeicher von WP zu erhöhen:

define ('WP_MEMORY_LIMIT', '256M');

Fügen Sie es kurz vor:

// That's all, stop editing! Happy blogging.

Diese Einstellungen können direkt von Ihrem Hosting-Provider eingeschränkt werden. Daher empfehle ich Ihnen, sich mit ihnen in Verbindung zu setzen und sie zu bitten, sie direkt zu ändern.
Sie können den aktuellen Wert unter WPML -> Support -> WordPress einsehen.

Mit freundlichen Grüßen
Andreas

Juli 14, 2021 um 11:27 pm #9199457

markusZ-5

Hallo Andreas,

ich kam heute erst dazu, die Empfehlungen auszuprobieren. Jedoch funktioniert das Speichern der Übersetzungen noch immer nicht.
Ich habe die das empfohlene Plug in Enable jQery Migrate Helper installiert und aktiviert und Das Memory Limit entsprechend beschrieben erhöht. Der Wert ist nun auf 256M.
Jedoch besteht der Fehler nach wie vor.

Liebe Grüße
Markus

Juli 15, 2021 um 1:05 am #9199685

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo Markus,

Ich möchte einen temporären Zugriff (wp-admin und FTP) auf Ihre Site anfordern, um das Problem genauer zu untersuchen. Besser wäre eine Testseite, an der das Problem repliziert werden kann.

Die dafür erforderlichen Felder finden Sie unterhalb des Kommentarbereichs, wenn Sie sich anmelden, um Ihre nächste Antwort zu hinterlassen. Die Informationen, die Sie eingeben werden, sind privat, was bedeutet, dass nur Sie und ich sie sehen und darauf zugreifen können.

Vielleicht muss ich Ihre Site lokal replizieren. Dazu muss ich vorübergehend ein Plugin namens „Duplicator“ auf Ihrer Site installieren. Dadurch kann ich eine Kopie Ihrer Website und Ihrer Inhalte erstellen. Sobald das Problem behoben ist, lösche ich die lokale Site. Lassen Sie mich wissen, ob dies bei Ihnen in Ordnung ist.

WICHTIG

Machen Sie eine Sicherungskopie der Site-Dateien und der Datenbank, bevor Sie uns den Zugriff gewähren.
Wenn Sie die Felder "wp-admin / FTP" nicht sehen, werden Ihre Anmeldedaten für Post und Website als "PUBLIC" (Öffentlich) festgelegt. Veröffentlichen Sie NICHT die Details Ihrer Website, es sei denn, Sie sehen die erforderlichen wp-admin / FTP-Felder. Wenn Sie dies nicht tun, bitten Sie mich, die private Box zu aktivieren. Die private Box sieht so aus:
hidden link

Mit freundlichen Grüßen
Andreas

Juli 15, 2021 um 12:49 pm #9209495

markusZ-5

Ich war mir jetzt nicht sicher, ob ich die Testseite mit eingefügt hatte.
Das ist diese:
hidden link

Juli 15, 2021 um 11:42 pm #9212567

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo Markus,

Ich sehe auf dem WPML Übersetzungseditor einen JavaScript-Error der sich auf das Plugin "Divi Children" bezieht.

Ist dieses Plugin momentan essenziell, um die Website zu betreiben? Falls nicht, könnten Sie es bitte einmal deaktivieren und prüfen, ob sich dann die Speicheroption des WPML Übersetzungseditores wieder darstellen lässt?

Mit freundlichen Grüßen
Andreas

Juli 15, 2021 um 11:50 pm #9212569

markusZ-5

Hallo Andreas,
vielen Dank, das war die Lösung des Problems. Nachdem ich das Child Theme Plug in deaktiviert hatte, ist es mir wieder möglich Übersetzungen zu speichern. Zumindest erscheint der Save Button wieder.
Ich werde es später noch an einer neuen Seite ausprobieren und diese übersetzen. Dann kann ich auch gleich testen, ob nun alles wieder fehlerfrei funktioniert. Aber davon gehe ich aus.
Das deaktivierte Plug in wird momentan nicht benötigt. Wenn ich es benötige, kann ich es dann temporär wieder aktivieren.
Vielen Dank für Deine Unterstützung!
Liebe Grüße
Markus