Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Heute stehen keine Supporter zur Arbeit im German-Forum zur Verfügung. Sie können gern Tickets erstellen, die wir bearbeiten werden, sobald wir online sind. Vielen Dank für Ihr Verständnis.

This topic contains 36 Antworten, has 2 Teilnehmer.

Last updated by Andreas W. vor 1 Woche, 5 Tagen.

Assigned support staff: Andreas W..

Autor Beiträge
Oktober 15, 2019 um 2:11 pm #4757893

tobiasL-11

Ich konnte leider nicht schnell genug zum letzten Ticket antworten:
https://wpml.org/de/forums/topic/in-den-warenkorb-button-nicht-mehr-sichtbar/

Die Preise sind bei den Varianten hinterlergt.

Ich gebe jetzt nicht noch mal alle Daten an, da die im alten Ticket sein müssten.

Oktober 15, 2019 um 6:59 pm #4760029

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Vielen Dank, dass Sie das WPML Support Forum kontaktiert haben.

Wenn ich richtig verstehe werden die Preise für einen kurzen Moment korrekt angezeigt und dann tritt der Fehler auf, korrekt?

Ich vermute, dass es sich hier um ein Problem zwischen WPML und einem anderen Plugin oder sogar dem Theme handelt.

Versuchen Sie bitte, die Website mit minimalem Setup auszuführen, um festzustellen, ob das Problem weiterhin besteht.

Deaktivieren Sie alle zusätzlichen Plugins, die nicht mit WPML und ihren Add-Ons zusammenhängen. Wenn das Problem nicht mehr angezeigt wird, reaktivieren Sie alle Plugins oder aktivieren Sie sie in kleinen Gruppen. Überprüfen Sie auf diese Weise, an welchen Stellen das Problem erneut angezeigt wird, um das Plugin anzuzeigen, das das Problem verursacht.

Bitte ändern Sie auch ein Standarddesign wie TwentySeventeen, um zu sehen, ob das Problem möglicherweise themenbezogen ist.

Außerdem können Sie die Funktion wp-debug aktivieren, um festzustellen, ob aktuelle PHP-Fehler vorliegen. Geben Sie dazu folögendes in Ihrer wp-config Datei ein:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG-LOG', true );

Besuchen Sie nun das Frontend Ihrer Website, dort wo der Fehler auftritt. Die Fehler werden in Echtzeit erfasst und in der debug.log Datei im Ordner wp-content Ihres Servers gespeichert. Teilen Sie mit bitte auch hier die Resultate mit.

Weitere Informationen zum Aktivieren dieser Funktion finden Sie hier:
https://wpml.org/documentation/support/debugging-wpml/

Lassen Sie mich bitte wissen, was die Untersuchungen ergeben haben.

Mit freundlichen Grüßen
Andreas

Oktober 16, 2019 um 9:32 am #4764119

tobiasL-11

Wenn ich richtig verstehe werden die Preise für einen kurzen Moment korrekt angezeigt und dann tritt der Fehler auf, korrekt?
--> nein, es geht um den Warenkorb-Button. Wenn du die betreffenden Produkte aufrufst, kannst du es nachvollziehen. Für eine Sekunde sieht man den Button noch, dann ist er weg und man kann das Produkt nicht in den Warenkorb legen.

Ich konnte rausfinden, dass der Konflikt mit dem Plugin "WooCommerce TM Extra Product Options" zusammenhängt. Von der debug-bar habe ich noch folgende Infos bekommen:
wp-content/plugins/woocommerce/includes/wc-deprecated-functions.php:52 - get_product is deprecated since version 3.0! Use wc_get_product instead.
require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/phono-theme/woocommerce/single-product.php'), get_header, locate_template, load_template, require_once('/themes/Divi/header.php'), wp_head, do_action('wp_head'), WP_Hook->do_action, WP_Hook->apply_filters, wp_enqueue_scripts, do_action('wp_enqueue_scripts'), WP_Hook->do_action, WP_Hook->apply_filters, WC_Quantities_and_Units->input_value_validation, get_product, wc_deprecated_function, _deprecated_function

Oktober 16, 2019 um 3:19 pm #4767039

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Vielen Dank für die Informationen.

Bitte installieren Sie das Plugin WooCommerce TM Extra Product Options auf der folgenden Website und falls möglich versuchen Sie das festzustellen, ob das Problem auch hier auftritt.
Sollte dies der Fall sein, werde ich das Problem an unser Kompatibilitätsteam weiterleiten.

One-Click Login: hidden link

Hinterlassen Sie mir bitte eine kurze Nachricht, sobald das Plugin installiert wurde.

Mit freundlichen Grüßen
Andreas

Oktober 17, 2019 um 10:00 am #4772103

tobiasL-11

Hallo Andreas,

ich habe das Plugin installiert, weiß aber gerade nicht wie ich das reproduzieren soll, da eure Seite komplett leer ist.

Viele Grüße
Franziska

Oktober 17, 2019 um 9:37 pm #4777375

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Verstehe ich richtig das es sich nicht um alle Produkte, sondern nur um ein bestimmtes Produkt handelt? Bitte teilen Sie mir Zugang zur Seite und eine detaillierte Erklärung zum Problem mit (Beschreibung, Links).

Ich möchte einen temporären Zugriff (wp-admin und FTP) auf Ihre Site anfordern, um das Problem genauer zu untersuchen. Besser wäre eine Testseite, an der das Problem repliziert werden kann.

Die dafür erforderlichen Felder finden Sie unterhalb des Kommentarbereichs, wenn Sie sich anmelden, um Ihre nächste Antwort zu hinterlassen. Die Informationen, die Sie eingeben werden, sind privat, was bedeutet, dass nur Sie und ich sie sehen und darauf zugreifen können.

Vielleicht muss ich Ihre Site lokal replizieren. Dazu muss ich vorübergehend ein Plugin namens „Duplicator“ auf Ihrer Site installieren. Dadurch kann ich eine Kopie Ihrer Website und Ihrer Inhalte erstellen. Sobald das Problem behoben ist, lösche ich die lokale Site. Lassen Sie mich wissen, ob dies bei Ihnen in Ordnung ist.

 WICHTIG

Machen Sie eine Sicherungskopie der Site-Dateien und der Datenbank, bevor Sie uns den Zugriff gewähren.
Wenn Sie die Felder "wp-admin / FTP" nicht sehen, werden Ihre Anmeldedaten für Post und Website als "PUBLIC" (Öffentlich) festgelegt. Veröffentlichen Sie NICHT die Details Ihrer Website, es sei denn, Sie sehen die erforderlichen wp-admin / FTP-Felder. Wenn Sie dies nicht tun, bitten Sie mich, die private Box zu aktivieren. Die private Box sieht so aus:
hidden link

Mit freundlichen Grüßen
Andreas

Oktober 18, 2019 um 3:28 pm #4784039

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Das Problem scheint sich auf das Plugin WooCommerce TM Extra Product Options zu beziehen. Sobald eine Option (Beispiel: Mittelloch) gewählt ist erscheint der Button. Deaktiviere ich das Plugin erscheint auch alles wie gewohnt.

Könnten Sie bitte das Plugin WooCommerce TM Extra Product Options auf der folgenden Test-Site installieren?

One-Click Login: hidden link

Hinterlassen Sie mir bitte eine kurze Nachricht, sobald das Plugin installiert wurde.

Mit freundlichen Grüßen
Andreas

Oktober 21, 2019 um 11:42 am #4794129

tobiasL-11

okay, ist installiert.

Oktober 21, 2019 um 6:28 pm #4796723

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich konnte das Problem leider nicht auf der Test-Site nachstellen.

Ich habe dann auf Ihrem Staging nochmals getestet und festgestellt, dass der Button auch dann nicht angezeigt wird, wenn WPML und seine Add-ons deaktiviert sind.

Ich würde Ihnen raten hier den WooCommerce Support zu kontaktieren.

Mit freundlichen Grüßen
Andreas

Oktober 22, 2019 um 9:54 am #4800797

tobiasL-11

Hallo,
danke für deine Bemühungen. Der Button ist ja nur in der englischen Version nicht zu sehen. In der deutschen ist er da. Wenn man WPML deaktiviert, ist doch aber gar keine englische Variante mehr vorhanden, oder?

Viele Grüße
Franziska

Oktober 22, 2019 um 6:03 pm #4804839

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich sehe das Problem auf der folgenden deutschen Produktseiten, auch dann, wenn nur WooCommerce, WP Staging und WooCommerce TM Extra Product Options aktiviert sind.

Der Button erscheint etwa eine Sekunde lang und verschwindet dann, nachdem die Website komplett geladen wurde.

Das Problem liegt hier nicht an WPML. Probieren Sie einmal das Produkt zu Duplizieren. Eventuell kann das Problem so gelöst werden, da es nur bei einigen Produkte auftritt.

Mit freundlichen Grüßen
Andreas

Oktober 23, 2019 um 8:58 am #4808909

tobiasL-11

Hallo,
welche folgenden? Kannst du mir den Link zum betreffenden Produkt schicken? Ich habs bisher nur bei der englischen Version entdeckt.

Danke
Franziska

Oktober 23, 2019 um 3:44 pm #4812947

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Entschuldigung, ich hatte den Link wohl vergessen. Wie erwähnt, es kommt bei Produkten mit Mittellöchern vor.

Hier eine deutsche Produktseite:

hidden link

Das Problem besteht weiterhin, selbst, wenn nur WooCommerce und WP Staging und WooCommerce TM Extra Product Options aktiviert sind.

Ich würde Ihnen deshalb raten dementsprechend die jeweiligen Support Teams zu kontaktieren.

Mit freundlichen Grüßen
Andreas

Oktober 24, 2019 um 8:42 am #4817429

tobiasL-11

Dank, das werde ich machen.

Oktober 24, 2019 um 10:25 am #4818583

tobiasL-11

Ich muss das Ticket wieder öffenen, denn das Produkt, was du geschickt hast, funktioniert. Man wählt beide Optionen aus und dann wird einem der Warenkorb button angezigt.
Jedoch bei der englsich Version dieses Produktes nicht:
hidden link