Skip Navigation

Dies ist das technische Support-Forum für WPML – das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team antwortet im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Our next available supporter will start replying to tickets in about 5.96 hours from now. Thank you for your understanding.

This topic contains 46 Antworten, has 2 Teilnehmer.

Last updated by Andreas W. vor 10 months, 2 weeks.

Assigned support staff: Andreas W..

Author Artikel
Oktober 24, 2019 um 3:13 pm #4821579

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich sehe, dass sich der Button auf mehreren Produktseiten unterschiedlich verhält.

Leider sind die Zugangsdaten nicht mehr verfügbar und müsste diese nochmals anfordern. Ich werde dann versuchen eine Kopie der Website zu erstellen, um lokal zu testen.

Ich möchte einen temporären Zugriff (wp-admin und FTP) auf Ihre Site anfordern, um das Problem genauer zu untersuchen. Besser wäre eine Testseite, an der das Problem repliziert werden kann.

Die dafür erforderlichen Felder finden Sie unterhalb des Kommentarbereichs, wenn Sie sich anmelden, um Ihre nächste Antwort zu hinterlassen. Die Informationen, die Sie eingeben werden, sind privat, was bedeutet, dass nur Sie und ich sie sehen und darauf zugreifen können.

Vielleicht muss ich Ihre Site lokal replizieren. Dazu muss ich vorübergehend ein Plugin namens „Duplicator“ auf Ihrer Site installieren. Dadurch kann ich eine Kopie Ihrer Website und Ihrer Inhalte erstellen. Sobald das Problem behoben ist, lösche ich die lokale Site. Lassen Sie mich wissen, ob dies bei Ihnen in Ordnung ist.

 WICHTIG

Machen Sie eine Sicherungskopie der Site-Dateien und der Datenbank, bevor Sie uns den Zugriff gewähren.
Wenn Sie die Felder "wp-admin / FTP" nicht sehen, werden Ihre Anmeldedaten für Post und Website als "PUBLIC" (Öffentlich) festgelegt. Veröffentlichen Sie NICHT die Details Ihrer Website, es sei denn, Sie sehen die erforderlichen wp-admin / FTP-Felder. Wenn Sie dies nicht tun, bitten Sie mich, die private Box zu aktivieren. Die private Box sieht so aus:
hidden link

Mit freundlichen Grüßen
Andreas

Oktober 25, 2019 um 11:38 am #4826507

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich kann leider leider nicht feststellen, wo das Problem liegt. Bei meinem lokalen Test wird in der Tat wird der Button angezeigt, wenn das Plugin WooCommerce TM Extra Product Options deaktiviert wird. Auf einer neuen Installation von WordPress tritt das Problem allerding snicht auf.

Bei der Kopie Ihrer Website war es außerdem möglich, ohne Probleme, ein neues Produkt mit benutzerdefinierten Attributen und Varianten zu erstellen. Da es sich hier nur um ein Problem mit einem einzelnen Produkt handelt, würde ich empfehlen, das Produkt erneut zu erstellen und daraufhin das alte Produkt zu löschen.

Teilen Sie mir bitte mit, ob dies erfolgreich war.

Mit freundlichen Grüßen
Andreas

Oktober 25, 2019 um 12:18 pm #4826809

tobiasL-11

Hallo Andreas,
das ist wirklich komisch. Leider betrifft es mehr als nur ein Produkt, aber ich schätze wir kommen da nicht drum rum. Ohne Ursache keine Lösung.
Danke trotzdem für deine Hilfe.

Viele Grüße
Franziska

Oktober 25, 2019 um 12:30 pm #4826847

tobiasL-11

Mir ist etwas aufgefallen, was beim Ursache finden helfen könnte.
Die Produkte, die das betrifft (und es sind einige) zeigen die Variaten als Galerie.
hidden link
Ein gleiches Produkt, wo es klappt, dort werden die Varinten Bilder nicht mit angezeigt.
hidden link

Ich denke also, dass da irgendwo eine Einstellung im Produkt sein muss, was das hervorruft.

Oktober 28, 2019 um 3:18 pm #4841095

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Bevor wir weitere Schritte vornehmen, bitte aktivieren Sie WPML und gehen Sie auf Plugins -> Neu installieren -> Kommerziell und nutzen Sie die Schaltfläche, um nach neuen Updates zu Suchen.

Wir haben mittlerweile WPML Multilingual CMS 4.3.1 veröffentlicht und auch neue Versionen für viele zusätzlichen Versionen verfügbar.

Installieren Sie die Updates und lassen Sie mich wissen, ob sich etwas an dem Problem geändert hat. Achten Sie bitte auch darauf, dass alle anderen Plugin und das Theme die aktuellste Version verwenden.

Ihr Divi Theme verwendet Version 3.17.6. Führen Sie bitte das Update zu 4.0.3 durch.

Außerdem sind 7 weitere Plugins nicht auf dem neuesten Stand.

Auf meiner lokalen Installation scheint das Problem dadurch gelöst zu sein. Ich bin mir nicht sicher, aber es scheint als ob das Update zu WooCommerce Checkout Manager das Problem gelöst hat.

Bei Produkten mit dem Attribut Mittelloch wird nun zuerst kein Button angezeigt. Wählt man eine Mittelloch Variante erscheint der Button nun allerdings in allen Sprachen.

Ich hoffe das löst das Problem.

Mit freundlichen Grüßen
Andreas

Lassen Sie mich wissen,

Oktober 28, 2019 um 3:29 pm #4841239

tobiasL-11

Hallo Andreas,
ich habe alle Plugins sowie Divi geupdated. Das Problem besteht weiterhin: hidden link

VG Franziska

Oktober 29, 2019 um 6:49 am #4843921

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Vielen Dank für Ihre Nachricht.

Nachdem ich nochmals einen Blick auf die Test-Site geworfen hatte, fiel mir auf dass das Plugin WooCommerce TM Extra Product Options hier dafür verantwortlich ist, dass das Design für die Variantenauswahl nicht korrekt übernommen wird.

Ich habe diese Problem an unser Kompatibiltätsteam weitegeleitet und werde mich bei Ihnen melden, sobald ich eine Rückmeldung habe.

Das Problem mit dem Button konnte ich leider nicht auf einer neune Installation nachstellen, aber ich werde auch diesbezüglich unser Kompatibilitätsteam konsultieren. Beim lokalen Test Ihrer Seite ist das Problem mit dem Button gelöst, wenn das Plugin WooCommerce TM Extra Product Options deaktiviert wurde. (Siehe Screenshot)

Eine weitere Frage. Nutzen Sie das Plugin YITH WooCommerce Cart Messages? Es hat bei meinem Test einen 404 Error auf Produktseiten verursacht. Könnten Sie das Plugin bitte zu der bereits erstellten Test-Site hinzufügen, um es dort nochmal zu testen?

One-Click Login: hidden link

Mit freundlichen Grüßen
Andreas

Oktober 29, 2019 um 9:42 am #4845465

tobiasL-11

Hallo Andreas,

vielen Dank, dass du der Sache auf den Grund gehst.
Yith habe ich hinzugefügt.

VG Franziska

Oktober 30, 2019 um 3:19 pm #4857231

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Bislang habe ich leider noch keine Rückmeldung zum Thema von unserem Kompatibilitätsteam. Ich werde mich melden, sobald wir eine Lösung bereit haben.

Das Problem mit einem 404 Error auf der übersetzten Produktseite, wenn das Plugin "YITH WooCommerce Cart Messages" aktiv ist, existiert sobald das Plugin "404page - your smart custom 404 error page" gleichzeitig aktiv ist.

Könnten Sie das Plugin für weitere Test bitte auch auf unserer Installation hinzufügen?

Mit freundlichen Grüßen
Andreas

Oktober 30, 2019 um 3:49 pm #4857529

tobiasL-11

ist erledigt.

Oktober 30, 2019 um 11:33 pm #4859799

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich konnte das Problem mit dem YITH WooCommerce Cart Messages Plugin im Zusammenhang mit WPML und 404page nachstellen und habe auch diese Angelgenheit weitergeleitet.

Vielen Dank für Ihre Mithilfe. Ich werde mich melden, sobald ich Neuigkeiten habe.

Mit freundlichen Grüßen
Andreas

November 5, 2019 um 1:17 am #4885439

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Eine kurze Rückmeldung von unserem Kompatibilitätsteam zum Problem mit dem 404 Error bei Verwendung von YITH WooCommerce Cart Messages und dem 404 page Plugin:

Wir würde hier gerne eine Lösung anbieten, aber das Problem liegt hier nicht an WPML und sollte mit dem Plugin Author behoben werden:

Das 404pages Plugin hat einen Kompatibilitätsmodus, welcher sich automatisch aktiviert, wenn WPML aktiv ist. Auch dann, wenn WPML deaktivert ist und der Kompatibilitätsmodus läuft, besteht das Problem weiterhin.

Das Problem scheint hier zu liegen, aber Sie sollte dies mit dem Plugin Support abklären:

Auf Linie 325 in wp-content/plugins/404page/inc/class-404page.php the condition empty($posts) ist "true" und sollte auf "false" stehen.

Begründung: Auf Linie 61 in wp-content/plugins/yith-woocommerce-cart-messages/class.yith-woocommerce-cart-messages.php, lädt die Funktion load_messages zu früh und überschreibt $posts.

Eine mögliche Lösung wäre:
In wp-content/plugins/404page/inc/class-404page.php ersetzen Sie Linie 217 mit:

add_filter( 'posts_results', array( $this, 'show404_compatiblity_mode' ), 999 );

ODER

In wp-content/plugins/yith-woocommerce-cart-messages/class.yith-woocommerce-cart-messages.php ersetzen Sie Line 61 mit:

add_action( 'the_posts', array( $this, 'load_messages' ), 1001 );

Beachten Sie, dass wir diese Lösungsvorschläge nicht getestet haben und sie sollten mit den jeweiligen Support Teams abgeklärt werden.

Zum Problem mit WooCommerce TM Extra Product Options werde ich mich so bald wie möglich zurückmelden.

Mit freundlichen Grüßen
Andreas

November 5, 2019 um 3:47 pm #4891179

tobiasL-11

Hallo Andreas,
danke für die Info. Hat dieses Problem denn etwas mit dem ursprünglichen Problem zu tun? Und wie äußert sich das Problem? Ich habe davon noch gar nichts mitbekommen.

Viele Grüße
Franziska

November 5, 2019 um 6:04 pm #4892511

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Ich hatte auf der Kopie der Website, welche ich lokal getestet hatte festgestellt, dass Produktseiten nicht korrekt angezeigt werden und die Übersetzungen nicht verfügbar sind, sobald die Plugins YITH WooCommerce Cart Messages und 404page zusammen verwendet werden.

Sollten Sie auf Ihrer Website keine Probleme mit 404 Errors bei Ihren Produkten feststellen, dann tritt das Problem mit den o.g. Plugins wohl in aktueller Konfiguration nicht auf Ihrer Website auf.

Das Problem trat allerdings beim Test auf der neuen Installation auf, die wir angelegt hatten. Deshalb wollte ich es ansprechen und unsere Entwickler konsultieren. Wie bereits erwähnt liegt dies nicht an WPML und hat auch nichts mit dem Problem in Bezug auf WooCommerce TM Extra Product zu tun.
Zu diesem Problem werde ich mich melden, sobald ich einen Lösungsvorschlag erhalten habe.

Mit freundlichen Grüßen
Andreas

November 6, 2019 um 11:14 am #4897507

tobiasL-11

Hallo Andreas,
kannst du mir vielleicht mal eines dieser Produkte nennen, damit ich das auch testen kann? Ggf. ist mir dieser Fehler bisher nur nicht aufgefallen.
Das andere Problem mit dem fehlenden Button ist aber weiterhin in Klärung, richtig?

Viele Grüße
Franziska