Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Our next available supporter will start replying to tickets in about 1.13 hours from now. Thank you for your understanding.

Schlagwörter: 

This topic contains 6 Antworten, has 2 Teilnehmer.

Last updated by andrejW-2 vor 2 Tage, 22 Stunden.

Assigned support staff: Marcel.

Author Artikel
September 30, 2019 um 7:01 am #4662533

andrejW-2

Ich versuche: Hubspot Formular hinzufuegen (<script charset="utf-8" type="text/javascript" src="//js.hsforms.net/forms/v2.js"></script>)

URL der/meiner Website, auf der das Problem auftritt: hidden link

Erwartet hatte ich zu sehen: EIn JS Kontakt Formular

Stattdessen bekam ich: JS Datei wird erst am Ende eingebunden, somit wird das Formular nicht angezeigt. Wenn man in WordPress eingeloggt ist funktioniert es. Auf deutsch auch, nur in den anderen Sprachen ES/EN/FR nicht

September 30, 2019 um 8:06 am #4662795

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo,

Vielen Dank, dass Sie den WPML Support kontaktiert haben.

Bitte beachten Sie folgende Links:

https://wordpress.org/support/topic/conflict-with-wpml-plugin-3/
hidden link
https://wpml.org/forums/topic/hubspot-forms-not-working-with-translated-website/

Möglicherweise können Sie das Problem ebenso durch die Neuinstallation des Hubspot Plugins lösen, auf Ihrer Seite ist ebenso ein JS Fehler der Auslöser, ansonsten kontaktieren Sie bitte den Hubspot Support.

Freundliche Grüße
Marcel

Oktober 2, 2019 um 12:56 pm #4680313

andrejW-2

Hallo,

vielen Dank fuer die Hilfe. den Hubspot Support haben wir schon kontaktiert, leider scheint es ein WPML Problem zu sein.

Nochmals das Problem hidden link funktioniert, da wird das externe JS eingebunden.
Bei den anderen Sprachen wird es warum auch immer erst danach eingebunden. Bitte vergleichen sie im Quellcode die Stelle der Einbindung des erwaehnten Skripts:

<script charset="utf-8" type="text/javascript" src="//js.hsforms.net/forms/v2.js"></script>

Komischerweise nicht, wenn man in WordPress eingeloggt ist. Wir verstehen nicht wieso es durch WPML zur spaeteren Einbindung im Quellcode kommt, bzw zur zu spaeten.

Das Plugin erneut zu installieren macht kein Sinn, da dieses nicht fuer das Hubspot Formular zustaendig ist und wurde auch schon versucht.

Vielen Dank fuer die Hilfe

Oktober 2, 2019 um 1:41 pm #4680935

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo,

Können Sie bitte Ihre Debug Information anhängen, damit ich Ihre Seiteneinstellungen überprüfen kann?

Anbei eine Anleitung wie das genau funktioniert.: https://wpml.org/faq/provide-debug-information-faster-support/

Vielen Dank

Oktober 2, 2019 um 2:59 pm #4681731

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo,

vielen Dank für die Info. Es könnte z.B. ein Javascript Konflikt ausgelöst werden, oder das HubSpot Plugin dahinter fügt das betroffene Javascript per wp_enqueue_script() zu spät ein und es erscheint daher im Quelltext nicht an der korrekten Stelle für die übersetzte Version.

Da das Plugin bisher nicht getestet wurde (https://wpml.org/de/documentation-3/plugins-kompatibilitaet/?wpv_view_count=119945&dev=0&wpv-plugin-functionality=0&wpv_post_search=hubspot&wpv_filter_submit=Suchen), müssen wir dies testen.

Bitte versuchen Sie bitte das Problem auf folgender Sandbox Umgebung nachzustellen. Wenn Sie es reproduzieren können, kann ich den Fall an unser Kompatibilitätsteam weitergeben. Die werden versuchen einen Workaround dafür zu finden oder kontaktieren, falls notwendig die Entwickler dieses Plugins.

hidden link

Freundliche Grüße
Marcel

Oktober 11, 2019 um 6:57 am #4735855

andrejW-2

Nach Deaktivierung der Javascript Rendering Funktion des Plugins WP Fastest Cache funktioniert das ganze wieder.

Vielen Dank fuer die Hilfe

Oktober 11, 2019 um 6:57 am #4735859

andrejW-2

My issue is resolved now. Thank you!