Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

This topic contains 10 Antworten, has 2 Teilnehmer.

Last updated by tomT-15 vor 6 Monate, 1 Woche.

Assigned support staff: Marcel.

Autor Beiträge
April 4, 2019 um 12:25 pm #3534685

tomT-15

Ich versuche: Eine Seite zu übersetzen

URL der/meiner Website, auf der das Problem auftritt:

Erwartet hatte ich zu sehen:
Ich möchte eine Seite mit WPML Advanced übersetzen, für andere Seiten funktioniert es, nur mit der wichtigsten nicht mehr.

Stattdessen bekam ich:
Ich möchte eine Seite mit dem Advanced Translator übersetzen, klicke ich auf die Übersetzung kommt die Meldung Screen1,
klicke ich dann auf die Berechtigungsverwaltung sehe ich, dass ich die Berechtigung habe siehe Screen 2.
Später bin ich auf die allgemeine Verwaltung gestoßen und wollte die Rechte ne syncronisieren, dann kam die Fehlermeldung siehe Screen 3.

April 4, 2019 um 2:53 pm #3536167

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hallo Tom,

Vielen Dank, dass Sie den WPML Support kontaktiert haben. Dieses Problem wurde mit neuesten Translation Manager (2.8.4) Update behoben, welche Sie bereits installiert haben.

#1 Bitte leeren Sie das Cache von "WP Fastest Cache"
#2 Falls dies nichts gebracht hat, könnte ich mir dies bitte direkt auf Ihrer Seite ansehen?

Dazu bräuchte ich bitte temporären Zugriff (WP-Admin und FTP) auf Ihre Seite.

Ihre nächste Antwort ist als „Privat“ markiert, dies bedeutet nur Sie und ich haben Zugriff darauf.

❌ Bitte sichern Sie Ihre Datenbank und Website davor ❌

✙ Ich würde außerdem Ihre Erlaubnis benötigen, um Plugins und das Theme zu deaktivieren und erneut zu aktivieren sowie Konfigurationen auf der Seite zu ändern. Dies ist auch der Grund, warum das Backup wirklich wichtig ist.

Freundliche Grüße
Marcel

April 9, 2019 um 2:56 pm #3568377
tomT-15

Hi Marcel,

ich habe die Verbindungen zu allen Seiten gelöscht, einen neuen Sidekey erstellt und verknüpft.
Leider funktioniert der Advanced Translator noch nicht.
Die Synchronisierung wirft immernoch den Fehler aus.
Auf der WPML Webseite werden nur 2 WPML PlugIns erkannt.

Kann es sein, dass ich bei Screen6 noch auf den markierten Button klicken muss?

Neue Threads, die von Marcel erstellt wurden und mit diesem verbunden sind, sind unten aufgeführt:

https://wpml.org/de/forums/topic/seiten-werden-unter-wpml-org-accounts-nicht-angezeigt/

April 11, 2019 um 9:23 am #3585641

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hallo Tom,

vielen Dank. Nach weiterer Recherche habe ich nun die Lösung für ihr Problem. Ich werde dazu das Ticket nun in 2 Teile aufteilen, damit ich es an alles korrekt in unsere eskalierten Tickets anhängen kann:

#1 Problem 1: Advanced Translation Editor:

Ich kann das Problem direkt auf Ihrer Datenbank beheben. Ich muss dazu in der Tabelle wp_options eine Option von unserem Advanced Translation Editor in ein weiteres Feld übertragen. Dazu würde ich Sie nochmals um ein aktuelles Backup Ihrer Datenbank sowie Seite bitten, damit keine Bestellungen etc. verloren gehen können.

- Bitte bestätigen Sie, dass Sie ein aktuelles Backup vorliegen haben
- Bitte bestätigen Sie, ebenso dass ich die Änderungen an Ihrer Datenbank durchführen darf
- Bitte senden Sie mir Ihre FTP Zugangsdaten

#2 Problem 2: (Unbenannt5.JPG). Dies ist ein bekannter Bug und unsere Entwickler arbeiten bereits daran. Dieses Ticket wird nun unter https://wpml.org/de/forums/topic/seiten-werden-unter-wpml-org-accounts-nicht-angezeigt/ weitergeführt.

Vielen Dank

Freundliche Grüße
Marcel

April 17, 2019 um 2:07 pm #3631595

tomT-15

Hi Marcel,

die Fehlermeldung ist weg das stimmt, aber es lädt ohne Timeout - siehe Screen 12.
Weiterhin habe ich mir jetzt nochmal eine Email geschickt damit mein Account (Screen13), klicke auf den Link in der Email und komme wieder ins WordPress, bei der Nutzerverwaltung (Screen 14) hab ich die Email aber auch eingerichtet, ich finde dort aber keine Einstellung, dass der Nutzer den Advanced Translator verwenden darf.

April 23, 2019 um 8:17 am #3660441
tomT-15

Hi Marcel,
ich hoffe du hattest schöne Ostern.
Tut mir leid aber ich steh immer noch auf dem Schlauch.

Ich möchte den Advanced Translator für meine Seiten "HOME" verwenden, bekomme aber den klassischen Translator mit den Hinweis 16 angezeigt.
Wie du aber schon schreibst, hat mein Account alle Berechtigungen 15.
Was kann ich hier noch tun?
Grüße Tom

Neue Threads, die von Marcel erstellt wurden und mit diesem verbunden sind, sind unten aufgeführt:

https://wpml.org/de/forums/topic/paypal-plus-from-inpsyde-causes-error-500-when-syncing-translators/

April 23, 2019 um 5:01 pm #3666389

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hallo Tom, vielen Dank, ja. Ich hoffe Sie auch.

Mir ist nun beim Test ein weiterer Fehler in der JS Console aufgefallen. Ich bin dran und geben Ihnen schnellstmöglich Bescheid.

Grüße Marcel

April 24, 2019 um 9:54 am #3671301

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hallo Tom,

ich habe das Ticket nun in 2 Teile getrennt, damit ich diese 2 unterschiedliche, aber zusammenhängende Probleme einzeln eskalieren kann.

#1 Sobald ich versuche die Übersetzter erneut zu synchronisieren, bekomme ich einen neuen Fehler. Dieser ist auf ein Problem im PayPal Plus Plugin von inpsyde zurückzuführen, welche im PHP Log mehrere Fehler in der API geloggt hat. Dadurch kann WPML über die API die Übersetzer nicht laden.

#2 Wenn es deaktiviert ist, verschwindet die Meldung, ATE ist jedoch nicht nutzbar. Dieses Problem werde ich in diesem Ticket weiterführen.

Freundliche Grüße
Marcel

Mai 6, 2019 um 2:56 pm #3750191

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hallo Tom,

Für #1 habe ich gerade die Rückmeldung bekommen, das dieses Problem mit den neuersten Versionen aller betroffenen Plugins nicht mehr nachgestellt werden konnte. Ich wollte dies gerade überprüfen, leider nicht einloggen. (Error 503).

Können Sie bitte die Logindaten/Server überprüfen, damit ich dies testen kann und mit #2 weitermachen kann?

Vielen Dank

Beste Grüße
Marcel

Mai 7, 2019 um 4:56 pm #3760803

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+01:00)

Hallo Tom,

vielen Dank für die Logindaten. Ich konnte das alte PW nun eingeben, ohne einen 503 Fehler zu bekommen.

Können Sie nun bitte versuchen mit Ihrem User die englische Home Seite im ATE Editor zu öffnen? Über meinen User hat nun das Synchronisieren sowie öffnen funktioniert. Ihr User hat andere Berechtigungen, da Sie die Konfiguration durchgeführt haben, bitte daher um Prüfung.

Vielen Dank
Beste Grüße
Marcel

Mai 8, 2019 um 7:14 am #3764297

tomT-15

My issue is resolved now. Thank you!