Skip Navigation

Dies ist das technische Support-Forum für WPML – das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team antwortet im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

This topic contains 29 Antworten, has 2 Teilnehmer.

Last updated by Marcel vor 8 Monate, 2 Wochen.

Assigned support staff: Marcel.

Author Artikel
November 18, 2019 um 3:39 pm #4966461

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Also der alt Tag bleibt auch leer, wenn WPML deaktiviert ist.
Ich werde Ihre Konstellation versuchen auf einer Sandbox nachzustellen.

November 18, 2019 um 5:26 pm #4967113

jensH-24

Oh, ok, woran kann das liegen?
Was meinen Sie, wie lange das dauert?

November 19, 2019 um 5:12 pm #4974641

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo, Ich versuche dies gerade herauszufinden.

- Ich erstelle dazu gerade eine isolierte Sandbox und versuche den Fehler zu reproduzieren.
- Falls es hier korrekt funktioniert, werde ich Ihre Seite auf einen Cloudways Server migrieren und versuchen das Problem ohne Plugins/mit einem Standard Theme zu isolieren.

Spätestens bis Morgen Mittag sollte somit die Ursache gefunden sein.

Freundliche Grüße
Marcel

November 20, 2019 um 11:14 am #4979193

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Kurzes Update:

Auf der Sandbox ist das Problem nicht aufgetreten, es liegt somit schon mal kein Fehler von WPML vor. Siehe in DE oder EN: hidden link (Suchen Sie im Quelltext nach „1ALTTEXT“.

Ich migriere gerade Ihre Seite und werde dann hier weitere Tests durchführen.

Freundliche Grüße
Marcel

November 20, 2019 um 11:55 am #4979617

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo,

das erste Beispiel, welches Sie mir genannt haben, hatte überhaupt keine Alttexte etc. definiert (modalo-uhrenbeweger-clasico-mv4-fuer-3-uhren-schwarz/), das zweite Beispiel (Screenshot von modalo-uhreneinsatz-mv4) schon.

Somit war in er Media Translation nichts vorhanden, was ausgelesen werden kann.

Beispiele:

alt="" war vorhanden und befüllt:
- hidden link
- hidden link

Bei diesem Produkt habe ich nun über die Mediathek einen Alt Text gesetzt, welchen die Media Translation findet und lädt:
hidden link (Suchen Sie im Quelltext nach "1ALTTEXT")

Seobility:
hidden link

"Setzen Sie bei allen Bildern ein beschreibendes ALT-Attribut." -> somit wird dies gefunden und muss nur bei den restlichen Bildern hinterlegt werden.

Freundliche Grüße
Marcel

November 20, 2019 um 1:26 pm #4980639

jensH-24

Hallo nochmal,

vielen Dank für Ihre bisherigen Mühen.
Sie hatten nun jetzt mit eines unserer letzten Artikel genommen, diese hatten jetzt keine Alt-Atribute hinterlegt

hidden link

alle anderen haben aber schon Alt-Atribute.

November 20, 2019 um 1:29 pm #4980693

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo,

bitte um ein konkretes Beispiel, ich aber bisher Ihre genannten Beispiele übernommen. Es liegt somit jedoch kein technisches Problem vor, da andere ja funktionieren.

Freundliche Grüße
Marcel

November 20, 2019 um 1:38 pm #4980811

jensH-24

Hier ist z.b ein solcher Artikel mit alttexten, dieser wird bei Seobility auch angezeigt, dass dieser keine Alltexte hat.

hidden link

Vor dem Fehler mit der 404 Geschichte, hatten alle Artikel solche Atribute in der Ausgabe bei Seobility

November 20, 2019 um 1:40 pm #4980821

jensH-24

Kann es sein, das die Flaggen keine altatribute besitzen und diese daher als leer angezeigt werden?

November 20, 2019 um 1:54 pm #4980925

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Das Testprodukt hat einen Alt-Text -> alt="LUXTIME Uhrenbeweger Baron für 16 Uhren", Seobility meldet somit "Setzen Sie bei ALLEN Bildern ein beschreibendes ALT-Attribut.", dies bedeutet nicht, dass keines funktioniert.

"Kann es sein, das die Flaggen keine altatribute besitzen und diese daher als leer angezeigt werden?"

-> Ja, siehe hier unter ganz unten unter Medienliste: hidden link

Dies können sie z.B.: so setzen: https://wpml.org/forums/topic/alt-text-for-flags/#post-1458885

Freundliche Grüße
Marcel

November 20, 2019 um 4:13 pm #4982081

jensH-24

Können Sie mir den CSS Code für die jeweilige Flagge zukommen lassen, das wäre super.
Wir fügen diesen dann selbst ein.
Weswegen haben wir das Problem aber erst, nachdem wir das mit dem 404 Fehler hatten?

November 20, 2019 um 4:26 pm #4982173

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Nun habe ich was gefunden 🙂

Sie können es über diese PHP Anpassung temporär beheben, dies wird mit einem der nächsten Updates gepatcht: https://wpml.org/errata/missing-alt-tag-for-flag-image-in-a-language-switcher/

Also dies betrifft die WPML eigenen Flaggen, der Fehler hat nichts damit zu tun, dass bei Ihrem Produkt der ALT Text fehlte.

Freundliche Grüße
Marcel

November 21, 2019 um 8:21 am #4985851
jensH-24

Hallo nochmal,

vielen Dank, das mit der PHP Anpassung hat schon mal geholfen.
Wir haben mal eine Frage, kann man alle WPML Module deaktivieren, ohne das Einstellungen verloren gehen, wenn man die Module wieder aktiviert?

Mit freundlichen Grüßen

Neue Threads, die von Marcel erstellt wurden und mit diesem verbunden sind, sind unten aufgeführt:

https://wpml.org/de/forums/topic/wpml-module-deaktivieren/

November 21, 2019 um 8:55 am #4985961

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo

sehr gut, danke für die Info.

Für die neue Frage habe ich ein getrenntes Ticket angelegt. Dieses können Sie somit bitte als erledigt markieren. Ich melde mich gleich im neuen Ticket.

Freundliche Grüße
Marcel

November 27, 2019 um 8:44 am #5026725

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Ich schließe dieses Ticket somit.

Freundliche Grüße
Marcel