Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Our next available supporter will start replying to tickets in about 4.03 hours from now. Thank you for your understanding.

This topic contains 6 Antworten, has 2 Teilnehmer.

Last updated by holgerF vor 1 Monat, 1 Woche.

Assigned support staff: Marcel.

Autor Beiträge
Februar 13, 2020 um 11:46 pm #5490455

holgerF

Hello,
I have some issues here and I can not solve it by myself. Hopefully you can help me. Thank you in advance.
Here is what I am doing:
At frontend I have a form that creates at (custom) post (type) when user submits. I am using formidable forms for this.

When page with form is english (default language) and he submits the form everything is fine: user will be redirected directly to created post /cpt/123 and here he can switch between languages (as usually).

BUT:
When page with form is german (second language) and he submits, he will be corretly redirected to /de/cpt/123 and here the language switcher does not work anymore. User can not change language to english - his only choice at this cpt is german.

I believe there is something wrong in my settings but I do not find how to solve this. Can you help me with this, please!?

Thank you

Holger

Februar 14, 2020 um 1:21 pm #5494333

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Holger,

Vielen Dank, dass Sie den WPML Support kontaktiert haben.

ich würde dies gerne mit einem Seitenlogin versuchen zu reproduzieren. Ich bräuchte dazu bitte temporären Zugriff (WP-Admin und FTP) auf Ihre Seite, vorzugsweise zu einer Test/Staging Seite, an der das Problem nach Möglichkeit repliziert wurde.

Ihre nächste Antwort ist als „Privat“ markiert, dies bedeutet nur Sie und ich haben Zugriff darauf.

❌ Bitte sichern Sie Ihre Datenbank und Website davor ❌

✙ Ich würde außerdem Ihre Erlaubnis benötigen, um Plugins und das Theme zu deaktivieren und erneut zu aktivieren sowie Konfigurationen auf der Seite zu ändern. Dies ist auch der Grund, warum das Backup wirklich wichtig ist.

Freundliche Grüße
Marcel

Februar 14, 2020 um 1:53 pm #5494819

holgerF

Hier ist mal ein Link wo das Problem auftritt!!!! Man kann leider nicht nach Englisch wechseln!

hidden link

Februar 14, 2020 um 4:15 pm #5495871

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Holger,

danke, ich konnte es nachstellen.

Ich kann Ihnen anbieten die Seite auf unseren Cloudways Server zu migrieren und das weitere Debugging dort vorzunehmen. Dann muss ich nicht auf Ihre Live-Seite.

Wäre das für Sie in Ordnung? Sie können dann ganz einfach über ein Plugin die Zugangsdaten eintragen und die Migration läuft automatisch.

Bitte um Info

Freundliche Grüße
Marcel

Februar 14, 2020 um 7:50 pm #5496857

holgerF

Hallo Marcel, das geht leider nicht. Wir möchten keinen FTP Zugang und auch keine Migration gewähren. Vielen Dank für das Verständnis. Ich kann Dir ggf. WP-Admin Zugang geben - das sollte doch auch bereits ausreichen!? Oder Screensharing.
Davon abgesehen glaube ich, dass es einfach eine Einstellung bei Eurem Plugin ist, ein oder zwei Klicks - nur ich weiss nicht wo - hast Du da nicht einen Tipp für mich!? Dann versuche ich selber weiter.
Danke
Holger

Februar 16, 2020 um 6:49 pm #5502637

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Holger,

wir bieten leider keinen Support wie Screensharing. Sie können folgendes prüfen:

#1 Ich sehe, dass hidden link einen 301 Redirect zu /de auslöst. Wie ist der Custom Post Type unter WPML -> Einstellungen konfiguriert? Dieser muss auf "Translateable - only show translated items" gestellt sein.

Doku: https://wpml.org/documentation/getting-started-guide/translating-custom-posts/

#2 Sie können ebenso prüfen, ob es funktioniert, wenn Sie unter WPML -> Sprachen von dem Sprachfolder /de auf die Sprachparameter umstellen. Bitte

Ohne eine Prüfung über das debug.log, bzw. der Debug Info/Einstellungen ist es jedoch schwer zu prüfen, ob dies durch eine fehlerhafte Einstellung, einem Bug oder ein Kompatibilitäts-Problem ausgelöst wird.

Bitte prüfen Sie dies, andernfalls können Sie ebenso versuchen das Problem auf einer von uns übermittelten Sandbox nachzustellen.

Freundliche Grüße
Marcel

Februar 18, 2020 um 7:39 pm #5518377

holgerF

My issue is resolved now. Thank you!