Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Heute stehen keine Supporter zur Arbeit im German-Forum zur Verfügung. Sie können gern Tickets erstellen, die wir bearbeiten werden, sobald wir online sind. Vielen Dank für Ihr Verständnis.

Schlagwörter: 

This topic contains 20 Antworten, has 4 Teilnehmer.

Last updated by Pierre vor 3 Jahre, 8 Monate.

Assigned support staff: Pierre.

Autor Beiträge
Oktober 10, 2015 um 6:37 pm #722113

martinS-20

I am trying to:
Change the language with the Top_Menu language switcher from primary to secondary language

URL of (my) website where problem appears:
hidden link

I expected to see:
hidden link

Instead, I got:
hidden link

Oktober 10, 2015 um 6:41 pm #722114

martinS-20

I observed additional issues:
1. I cant access Theme Options for the English language.
2. Except for the front page I can switch the language on all other pages. Yet the logo is missing in English version.

Time ago all this worked 🙁

Oktober 11, 2015 um 2:00 pm #722234

Mladen Andrejic

Hello,

1. Can you please check if the problem persist when :

- All non WPML Plugins are disabled
- Theme is set to default Twenty Fourteen

2. Activate WordPress debug.log and see if there are any errors displayed? Here are the instructions for activating it : https://wpml.org/documentation/support/debugging-wpml/

3. You can also check the Chrome built-in JavaScript Console for errors. To open the console go to Menu (Three Bars) > Tools > JavaScript Console

Please paste here any errors that you see in the WordPress debug.log or in JS Console.

4. I see that you are using older versions of PHP and MySQL so can you please update those versions and see if this maybe helps?

-- You can also write on German.

Thanks.

Oktober 11, 2015 um 2:48 pm #722248

martinS-20

Hi,

1. Can you please check if the problem persist when :

- All non WPML Plugins are disabled
- Theme is set to default Twenty Fourteen

> Getestet - Problem besteht weiterhin.

2. Activate WordPress debug.log and see if there are any errors displayed? Here are the instructions for activating it : https://wpml.org/documentation/support/debugging-wpml/

> no errors auch mit allen Plugins und dem Avada theme angeschaltet

3. You can also check the Chrome built-in JavaScript Console for errors. To open the console go to Menu (Three Bars) > Tools > JavaScript Console

Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help, check hidden link.
Navigated to hidden link

4. I see that you are using older versions of PHP and MySQL so can you please update those versions and see if this maybe helps?

In aller Höflichkeit - nein ich werde sicherlich nicht upgraden:
1. stabile php version auf Basis CentOS 7.1 (php 5.4.16) - wäre das eine Ursache, so ist es ein Fehler von WPML - php 5.4.16 ist Industriestandard.
2. Es ist kein MySQL sondern MariaDB 5.5 (previous stable), ergo auch nicht hoffnungslos veraltet. De facto Industriestandard, da Standard in CentOS 7.1

-- You can also write on German.

Thanks.

Oktober 12, 2015 um 9:07 am #722550

Mladen Andrejic

Hallo Martin,

Ich muss dieses Problem näher ansehen und dafür brauche ich temporären Zugriff auf Ihre Webseite.

Sie werden die privaten Felder wie im Bild sehen und dort sollten Sie Zugriffsdaten eingeben hidden link
Die Daten sind privat, d.h. niemand außer mir kann die Daten sehen.

// HINWEIS : Bitte erstellen Sie ein komplettes Backup bevor ich die Seite zugreife.

Danke.

Oktober 12, 2015 um 10:53 am #722676

martinS-20

please use the following ftp-account - same pw as in private post:
myselfwpml_support

Oktober 12, 2015 um 11:34 am #722708

Mladen Andrejic

Hallo,

Ich habe jetzt die Seite gecheckt. Es sieht so aus als nur Homepage Probleme mit der Umschaltung hat.

Können Sie bitte zum test derzeitige englische Startseite duplizieren (besser wäre dass Sie neue Seite mit dem gleichen Inhalt erstellen), und sie dann als Übersetzung der deutsche Startseite einstellen.

Ich denke dass Neuerstellung der Startseite hier helfen wird.

Danke.

Oktober 12, 2015 um 11:44 am #722723

martinS-20

Und was ist mit den Logos? Irgendwie kann ich auch nicht mehr auf die englischen Einstellungen der theme options zugreifen... Da läuft wohl auch etwas mti Avada falsch?

Oktober 12, 2015 um 12:25 pm #722772

martinS-20

Nope, das hat nicht geholfen. Die Seite kann man umstellen, wenn sie keine Startseite ist. Sobald die neue Startseite als Startseite eingerichtet wird, passiert das Gleiche wie eingangs beschrieben: es wird immer die deutsche Seite geladen.

Das scheint etwas mit dem Fehlr zu tun zu haben, den ich oben nannte:

3. You can also check the Chrome built-in JavaScript Console for errors. To open the console go to Menu (Three Bars) > Tools > JavaScript Console

Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help, check hidden link.

Oktober 12, 2015 um 1:45 pm #722897

Mladen Andrejic

Hallo,

Es sieht so aus als hier ein jQuery Problem besteht.

Irgendwo im $.ajax() call haben Sie async:false Einstellung und das macht die Probleme.

Wie sie auf dieser Seite sehen können : hidden link

- "As of jQuery 1.8, the use of async: false with jqXHR ($.Deferred) is deprecated" und was auch sehr wichtig ist : "Cross-domain requests and dataType: "jsonp" requests do not support synchronous operation"

Danke.

Oktober 12, 2015 um 1:49 pm #722908

martinS-20

Danke und wo kommt das her? Da ich kein Programmierer bin, ist das auch nicht von mir...

Selbst als ich twentyfive Theme nahm war das PRoblem ja noch da...

Oktober 12, 2015 um 2:04 pm #722923

Mladen Andrejic

Hallo,

Wir haben ja gefunden wo genau async: false im Code steht, unser Developer Team arbeitet jetzt dran.

Sie werden kontaktiert wenn neue Informationen verfügbar sind.

Danke.

Oktober 19, 2015 um 9:23 am #727775

martinS-20

Braucht Ihr noch etwas? Leider kam bisher kein feedback mehr.

Oktober 21, 2015 um 7:17 pm #730184

martinS-20

Hello?

Oktober 23, 2015 um 3:35 pm #731690

martinS-20

*** Login ist nun: moveitsolutions.com/wp-login.php ***

Ich konnte nun folgendes herausfinden:
1. Der Sprachumschalter funktioniert bei allen Seitenunterseiten
2. Der Sprachumschalter funktioniert auf der Hauptseite nicht sondern macht immer einen redirect auf *.de
3. Ich kann die englische Konfigurationsseite nicht verändern. Hier tickert WPML offensichtlich aus.
4. Der Main-link im Logo der .com - Version verweist immer auf *.de/ (siehe zB Logo in der englischen Version).
5. Der Zugriff auf *.com/ leitet immer nach *.de/ weiter

Fazit: die Startseite ist falsch gesetzt für die englische Version, jedoch kann ich das nicht ändern.