Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:
I have a problem with my links on translated pages. I am using the "Salient" Theme for WordPress.

I have translated all my texts, widgets and menus with WPML. All worked great, switch in the footer is working (for admins only currently, just let me know if you need a test account to solve the problem).

But: All links are not leading to the correct, translated pages. So if I got a link that says "/hallo" on a button, it should lead to "en/hello in the translated english version. That is not happening, still leading to "/hallo".

I saw that problem in other support tickets. You always said, that there is a plugin "Sticky Links" to solve that problem? But I can't find this plugin anywhere, so maybe it is not existing anymore?

How can I solve this problem? The links don't show up in any translation editor (as far as I know), so currently I can't translate them and thus not go live with my translated pages.

Solution:
Upon further inspection, our team has found a solution for the issue. We went ahead and added this code in WPML -> Settings -> Custom XML configuration:

shortcode>
    <tag>vc_column_inner</tag>
    <attributes>
        <attribute>column_link</attribute>
    </attributes>
</shortcode>
<shortcode>
    <tag>vc_column</tag>
    <attributes>
        <attribute>column_link</attribute>
    </attributes>
</shortcode>

After that, we made a minor modification to your homepage and opened the Advanced Translated Editor, where now we can see that the missing translation links are available to translate.

Dies ist das technische Support-Forum für WPML – das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team antwortet im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Heute stehen keine Supporter zur Arbeit im German-Forum zur Verfügung. Sie können gern Tickets erstellen, die wir bearbeiten werden, sobald wir online sind. Vielen Dank für Ihr Verständnis.

Schlagwörter: 

This topic contains 14 Antworten, has 2 Teilnehmer.

Last updated by maximilianS-19 Vor 1 Woche, 4 Tage.

Assigned support staff: Mateus Getulio.

Author Artikel
April 4, 2021 um 4:40 am #8462019

maximilianS-19

Hey

I have a problem with my links on translated pages. I am using the "Salient" Theme for WordPress.

I have translated all my texts, widgets and menus with WPML. All worked great, switch in the footer is working (for admins only currently, just let me know if you need a test account to solve the problem).

But: All links are not leading to the correct, translated pages. So if I got a link that says "/hallo" on a button, it should lead to "en/hello in the translated english version. That is not happening, still leading to "/hallo".

I saw that problem in other support tickets. You always said, that there is a plugin "Sticky Links" to solve that problem? But I can't find this plugin anywhere, so maybe it is not existing anymore?

How can I solve this problem? The links don't show up in any translation editor (as far as I know), so currently I can't translate them and thus not go live with my translated pages. Since that is very important for my client it would be awesome if you can assist. Thanks.

Best, Maximilian

April 5, 2021 um 5:21 pm #8468089

Mateus Getulio
Supporter

Languages: Englisch (English ) Portugiesisch, Brasilien (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello Maximilian,

You'll be able to locate the Sticky Links plugin at the bottom of the Downloads page: https://wpml.org/account/downloads/

Alternatively, please feel free to go to Plugins -> Add new -> Commercial tab, select Sticky Links in the list and install it.

Please check our documentation on how to configure and use it properly:

https://wpml.org/documentation/getting-started-guide/sticky-links/
https://wpml.org/announcements/2009/06/feature-spotlight-sticky-links/

Please notice that if it doesn't work, it might be necessary for you to translate the links inside the String Translation screen. To try to do so, please follow these steps:

- Go to WPML -> String Translation
- Search for a small part of the link that isn't working on the secondary language, eg: /hallo
- Enter the correct version of it in the secondary language, eg.: /en/hello
- Test it again to see if the link you translated work as expected now

Thank you, please let me know how that goes.

Best,

Mateus

April 8, 2021 um 1:32 am #8486739

maximilianS-19

Hey Mateus, thanks for the fast reply.

I downloaded and installed the plugin. Nothing changed, links are still not working. I did the changes to the functions.php, didn't help as well.

I can't translate the links in the string translation tab since they don't show up there.

Would it be a good idea for you to check in our WordPress with a login (how to send this to you? here in the ticket? is this visible to others?) what is wrong here so that we can proceed? I seem to be not able to get this working :/

Thanks. Best, Maximilian

April 8, 2021 um 4:47 pm #8495375

Mateus Getulio
Supporter

Languages: Englisch (English ) Portugiesisch, Brasilien (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

Thanks for your reply.

In WPML -> Settings -> Translated documents options -> Page URL, please select "Translate (this will include the slug in the translation and not create it automatically from the title)". This will allow you to edit the URL of your translations manually.

Check if now you can translate the URLs on the Translation Editor. If you can't, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

April 13, 2021 um 1:33 am #8520805

maximilianS-19

Hello. Can't find the form fields to enter my WordPress admin credentials here, pls check that setting again maybe?

The buttons / links are still not working so would be awesome if you could log in to check that.

Thanks. Best, Maximilian

April 13, 2021 um 1:48 pm #8525873

Mateus Getulio
Supporter

Languages: Englisch (English ) Portugiesisch, Brasilien (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi Maximilian,

Sorry about this inconvenience. I'm enabling your next reply as private, and you can enter your access data now.

Also, please show me exactly which are these problematic buttons and links.

Looking forward to your reply. Thank you,
Mateus.

April 19, 2021 um 6:51 pm #8575473

Mateus Getulio
Supporter

Languages: Englisch (English ) Portugiesisch, Brasilien (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

I checked this out but so far I couldn't find a fix for it.

I asked my colleagues to have a look at this issue in order to see if there's anything I'm missing.

I'll come back here as soon as one of my colleagues reply back to me (which it shouldn't take long).

Thanks,
Mateus.

April 22, 2021 um 6:33 pm #8604293

maximilianS-19

Any fix for this? Is this related to a bug in wpml or do you know what the matter is? Because as far as I know, Salient is using a pretty standard page builder, right? So that should then effect a few more themes / sites, right? Or do I miss something here?

Thanks. Best, Maximilian

April 26, 2021 um 2:19 pm #8626433

Mateus Getulio
Supporter

Languages: Englisch (English ) Portugiesisch, Brasilien (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

I have escalated this ticket to our 2nd tier of support where our 2nd tier specialists will take a deeper look at this issue and will try to find a solution.

I will get back to you as soon as I get an answer from them.

Best regards,
Mateus

April 27, 2021 um 6:28 pm #8638363

Mateus Getulio
Supporter

Languages: Englisch (English ) Portugiesisch, Brasilien (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi Maximilian,

Thank you so much for your patience.

Upon further inspection, our team has found a solution for the issue. We went ahead and added this code in WPML -> Settings -> Custom XML configuration:

<shortcode>
    <tag>vc_column_inner</tag>
    <attributes>
        <attribute>column_link</attribute>
    </attributes>
</shortcode>
<shortcode>
    <tag>vc_column</tag>
    <attributes>
        <attribute>column_link</attribute>
    </attributes>
</shortcode>

After that, we made a minor modification to your homepage and opened the Advanced Translated Editor, where now we can see that the missing translation links are available to translate.

Could you please check it on your end and see if it is resolved?

Kind regards,
Mateus.

Mai 2, 2021 um 7:58 pm #8671637

maximilianS-19

Thanks for the reply. Sorry to say but right now, the fields show up in the translation editor, yep. But if I change the values inside, it won't take effect on the website. So its not changed on the frontend, just the fields on the backend (so the WordPress admin page editor) changed now. But the values I put in are not changed on the website. So still not working sadly :/

Mai 3, 2021 um 3:09 pm #8677639

Mateus Getulio
Supporter

Languages: Englisch (English ) Portugiesisch, Brasilien (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

I've just checked your website and could see that the English translation for the homepage was not completed. There were several filled link fields, but the checkboxes "Translation is complete" on them were not marked.

After I made this correction and saved the translation, the English links started to redirect to the correct page. Please check: hidden link

Could you please review it once more and make sure that the translations are complete? Thanks, let us know.

Regards,
Mateus.

Mai 4, 2021 um 12:00 am #8679383

maximilianS-19

Oh, ok. Thanks for the hint and the help - that's awesome.

How can I now activate this for all other pages besides the homepage? You said you did a few changes to the homepage and then it worked.

If I want to add this for example for the "Geschichte" page (hidden link) there is no such link fields, even though there is a button on the page with a link. That link is still leading to the german version, so same mistake as on the homepage before.

So how to activate the fix for all pages, categories, articles etc.? Thanks.

Mai 4, 2021 um 2:12 pm #8686041

Mateus Getulio
Supporter

Languages: Englisch (English ) Portugiesisch, Brasilien (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi Max,

Yes, you should do the procedure of editing the default language content (adding an extra space, for example), and then update the translation. It should work.

If you need, there's a way to update your pages and posts in bulk. Just follow these instructions:

- In the WordPress dashboard, go to Pages or Posts
- Select the language of the post types you want to update
- Select all posts you want to update, and in "Bulk actions", select "Edit"
- Click on "Apply", scroll down the screen and click on the button "Update"

If that doesn't help, you'll have to edit and update each page/post manually.

I hope we are good to close here. Feel free to contact us any time if you need assistance with our products.

Kind regards,
Mateus.

Mai 5, 2021 um 12:57 am #8689239

maximilianS-19

My issue is resolved now. Thank you! Wrote a review as well. Thanks for the help, Mateus 🙂