Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Our next available supporter will start replying to tickets in about 7.53 hours from now. Thank you for your understanding.

This topic contains 7 Antworten, has 2 Teilnehmer.

Last updated by thiloK vor 2 Wochen, 1 Tag.

Assigned support staff: Marcel.

Author Artikel
September 16, 2019 um 10:16 am #4578771

thiloK

Fatal error: Uncaught Error: Class 'WPML_Translation_Management' not found in /pages/59/e2/d0013490/home/htdocs/development-server/wp-content/plugins/sitepress-multilingual-cms/classes/utilities/admin/class-wpml-admin-url.php:7
Stack trace:
#0 /pages/59/e2/d0013490/home/htdocs/development-server/wp-content/plugins/sitepress-multilingual-cms/classes/upgrade/commands/class-wpml-upgrade-display-mode-for-posts.php(83): WPML_Admin_URL::multilingual_setup(7)
#1 /pages/59/e2/d0013490/home/htdocs/development-server/wp-content/plugins/sitepress-multilingual-cms/classes/upgrade/commands/class-wpml-upgrade-display-mode-for-posts.php(29): WPML_Upgrade_Display_Mode_For_Posts->get_notice_content()
#2 /pages/59/e2/d0013490/home/htdocs/development-server/wp-content/plugins/sitepress-multilingual-cms/classes/upgrade/class-wpml-upgrade.php(146): WPML_Upgrade_Display_Mode_For_Posts->run_admin()
#3 /pages/59/e2/d0013490/home/htdocs/development-server/wp-content/plugins/sitepress-multilingual-cms/classes/upgrade/class-wpml-upgrade.php(134): W in /pages/59/e2/d0013490/home/htdocs/development-server/wp-content/plugins/sitepress-multilingual-cms/classes/utilities/admin/class-wpml-admin-url.php on line 7

September 16, 2019 um 1:23 pm #4580737

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Thilo,

Vielen Dank, dass Sie den WPML Support kontaktiert haben.
Haben Sie den Fehler per E-Mail vom WordPress Health Monitor erhalten oder ist der Fehler aktuell auf der Seite bzw. im Backend sichtbar?

Freundliche Grüße
Marcel

September 18, 2019 um 7:20 am #4593055

thiloK

Hallo Marcel,

Vielen herzlichen Dank für die schnelle Antwort.

Wir bekommen den Fehler alle ca. 6 klicks auf der Seite angezeigt. der Fehler basiert auf eine PHP class. Als würde die ensprechende Datei fehlen. Ich denke der Link oben gibt guten Aufschluss auf den genauen Ort.

Wir bekommen den Fehler in WP-admin im Backend angezeigt. Frontend scheint ok aber macht dadurch auch probleme...

Kannst du da helfen was genau los ist?

September 18, 2019 um 7:48 am #4593285

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Thilo,

Ich würde mir das gerne direkt auf Ihrer Seite ansehen. Dazu bräuchte ich bitte temporären Zugriff (WP-Admin und FTP) auf Ihre Seite, vorzugsweise zu einer Test/Staging Seite, an der das Problem nach Möglichkeit repliziert wurde.

Ihre nächste Antwort ist als „Privat“ markiert, dies bedeutet nur Sie und ich haben Zugriff darauf.

❌ Bitte sichern Sie Ihre Datenbank und Website davor ❌

✙ Ich würde außerdem Ihre Erlaubnis benötigen, um Plugins und das Theme zu deaktivieren und erneut zu aktivieren sowie Konfigurationen auf der Seite zu ändern. Dies ist auch der Grund, warum das Backup wirklich wichtig ist.

Freundliche Grüße
Marcel

September 26, 2019 um 3:57 pm #4648581

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Thilo,

vielen Dank. Ich konnte das Problem mit einem Update auf die vor kurzem veröffentlichte Version WPML Version 4.2.9 lösen.

Freundliche Grüße
Marcel

September 30, 2019 um 9:25 am #4663301
thiloK

Hallo Marcel,

vielen herzlichen Dank für die schnelle Hilfe. Wir haben das direkt auf der Live Seite um´gesetzt und es klappt wunderbar. Daraus hat sich allerdings folgendeer Fehler ergeben:

Die Produkte (wenn die seite auf DE verwendet wird ) linken alle auf die Home(404) weiter. Da gibt es ein problem... das heisst wenn ich zumscheispiel auf der produktübersichtseite auf ein produkt klicke, komme ich nicht wie gewohnt auf die deutsche produkt einzelansichtseite, sondern auf die 404 home Seite. Da scheint es ein weiterleitungs problem zu geben. ich habe jetzt direkt versucht den Fehler zu lokalisieren aber bin da ein wenig ratlos.

Gibts dazu ein fix von euerer Seite?

Viele Grüße
Thilo

Neue Threads, die von Marcel erstellt wurden und mit diesem verbunden sind, sind unten aufgeführt:

https://wpml.org/de/forums/topic/404-bei-produkte/

September 30, 2019 um 12:31 pm #4664565

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Thilo,

ich habe dafür ein neues Ticket angelegt. Dieses können Sie bitte somit als "erledigt" markieren.

Ich gebe Ihnen schnellstmöglich im neuen Ticket Bescheid.

Freundliche Grüße
Marcel

September 30, 2019 um 12:50 pm #4664667

thiloK

My issue is resolved now. Thank you!