Skip Navigation

Dies ist das technische Support-Forum für WPML – das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team antwortet im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Schlagwörter: 

This topic contains 12 Antworten, has 3 Teilnehmer.

Last updated by Verein Vor 5 Jahre, 1 Monat.

Assigned support staff: Denise.

Author Artikel
August 29, 2016 um 4:21 pm #1028590

Verein

I am trying to: für den relaunch meiner Seite wurde diese ZUERST in ENGLISCH gemacht, und nicht wie sonst auf DEUTSCH. Nun soll alles in DEUTSCH übersetzt werden und mit WPML online gehen. Nun wird aber angezeigt, dass die Seiten in DEUTSCH sind, Fakt ist, die Sache ist umgekehrt. WIE können wir das nun richtig einstellen? Ich möchte die Admin Sprache nicht in Englisch haben und das hat auch das Problem nicht gelöst. Kann man das nun anders einstellen und wenn - wie? Ich habe keine Lösung gefunden.

URL of (my) website where problem appears:mariaweiss.at

I expected to see: siehe Screenshot: Seiten Deutsch (16) - Deutsches Fähnchen mit "+" Zeichen zum hinzufügen

Instead, I got: das Gegenteil: siehe Screenshot

Steps to duplicate the issue:

Bildschirmfoto 2016-08-29 um 18.19.37.png
August 30, 2016 um 5:14 am #1029369

Verein

Noch ein Zusatz: das Problem ist nun, dass auch im Menü: das Englische wird als DE angezeigt und die (in Bearbeitung befindliche) DEUTSCHE Übersetzung im Menü als Englisch, siehe Screenshot.

Bildschirmfoto 2016-08-30 um 07.12.29.png
August 30, 2016 um 9:13 am #1036515

Denise

Hallo,

ich werde dir damit helfen. Danke für die Debug Information.

Ich glaube die Sprache der jetzige Inhalt war falsch gesetzt in WPML Einstellungen während Set-up.

Du kannst die Sprache von deine Seiten ändern.

Wenn du ein Seite bearbeitest siehst du ein Sprache Abteilung. Dort kannst du die Sprache von der Seite ändern. Siehe Bild.

Danach kannst du deine Menus bearbeiten.

Nur Englisch Inhalt kann in Englisch Menu eingefügt u.s.w.

Wenn du noch nicht deine Inhalt übersetzt hast und alle Inhalt noch Deutsch ist, kannst du WPML voll entfernen (auch mit Sprach Info) und wieder installieren.

- Zuerst ein Datenbank Backup machen
- In WPML - Support - Troubleshooting Page - auf "Reset and deactivate WPML" klicken (ganz unten
- WPML aktivieren in Plugins
- In deine WPML setup, Deutsch als jetzige/Standard Inhalt wählen.

Danke,
Denise

language.png
September 2, 2016 um 2:02 am #1054646

Verein

Dear Denise,

should we write in English? Thank you for your answer.

Thank you for the screenshot - but I cannot change the language of a page - neither if I put English note German as the default language. Also: if I put English as default language my entire wordpress will switch into english which I do not want as I prefer German for my wordpress menu.

Please see screenshots: I cannot realize this step: it will only show German to select if I try to change the language.

I made FIRST the homepage and all the pages in ENGLISH and I installed only AFTER all this the WPML Plugins without setting anything: when I was going to set things the problem already existed.

I CANNOT cancel the homepage now as.
Is there not a setting to resolve this problem and let WPML recognize the pages in english and now put german as well. It does also show the english content now in the main menu as "GERMAN" and the coming german pages as the "English" one's.

Thank you for your help.

Bildschirmfoto 2016-09-02 um 03.56.15.png
Bildschirmfoto 2016-09-02 um 03.55.24.png
Bildschirmfoto 2016-09-02 um 03.52.42.png
September 2, 2016 um 10:44 am #1055961

Mladen Andrejic

Hello,

FYI : You can select backend language regardless of the website's default language, but this is not the most important right now.

I think the best approach would be if I check the website directly. In order to be of a better help, I will need to request temporary access (WP-Admin and FTP) to your site.

You will find the needed fields for this below the comment area when you log in to leave your next reply like this hidden link

The information you will enter is private which means only you and I can see and have access to it.

// NOTE : Make sure that you have performed the backup before you let me access the site.

Thanks.

September 5, 2016 um 6:49 pm #1061580

Denise

Hi Maria,

I hope my German was not so bad that you moved to English 🙂 After eight years, I understand everything but still make grammatical mistakes.

You can keep German as your site's default language if you wish.

I was able to change the language of a page with the directions that I gave you. Please see the screencast hidden link

As for your homepage, I would suggest that you edit the content of the German version to include German text since they have the same English content at the moment.

I think you were having the issue where you could not change the language of your homepage because it was set as your homepage. It does not seem that that is a relevant issue now that you have made a translation.

You should be able to change the language of all the other pages.

Afterwards, I would suggest that you edit your English and German menus to reflect the changes.

Thanks,
Denise

September 11, 2016 um 2:24 pm #1073419

Verein

Dear Mladen Andrejic,

did you enter in my site now and figure out how to resolve the problem?
Am trying my best but cannot figure out the solution, as the language switcher in the menu as well is showing still in the wrong way (German for English content and English for the upcoming german content/pages)...

PS: Dear Denise: I could not understand the process you described in German, please do not take this as an offense, your german is very good!
I am so sorry but I could not follow your instructions to resolve the problem but I do and will do my best.
Best, Maria

September 12, 2016 um 8:09 am #1074152

Denise

Hi Maria,

I'll be helping you with this. As I mentioned earlier I went into your site and changed the language of one of your pages as an example thatI recorded here - hidden link Please look at this video to see how you can change the language of your content.

To change the language of your content:
- Go to the page, hit edit/bearbeiten
- On the right of the page under "Sprache dieses/r seite" select the language of the page (see image 1)
- You will see a verification that you are about to change the language of the page (see image 2) , click OK

Please note:
* If the page is already a translation of of another page, you will not be able to change the language

Please attempt the procedure above to change the language of your content.

Thanks,
Denise

2.png
1.png
September 12, 2016 um 4:14 pm #1075541

Verein

Wonderful Denise,

thank you very much! I will go now through the video and all instructions again and write you back if I could resolve the problem! Thank you for now! Best!

September 13, 2016 um 11:14 am #1077291

Denise

Thanks Maria,

Please open another ticket if you have any problems or questions.

September 13, 2016 um 1:53 pm #1077509

Verein

Perfect dear Denise! Thank you!

:-)))

September 13, 2016 um 3:34 pm #1077850

Denise

No problem. 🙂 Please mark this ticket as resolved.

September 16, 2016 um 7:13 am #1082761

Verein

Thank you Denise, I did mark it as resolved now.
Can you please for security cancel the video from youtube with my wp dashboard on it, I have watched it several times now and do not need it.
Thank you so much for making it! All the best Maria