Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Our next available supporter will start replying to tickets in about 3.10 hours from now. Thank you for your understanding.

Schlagwörter: 

This topic contains 8 Antworten, has 2 Teilnehmer.

Last updated by Rainer vor 3 Monate, 3 Wochen.

Assigned support staff: Bruno Kos.

Autor Beiträge
Juli 23, 2019 um 10:31 pm #4269169

Rainer

Ich versuche: Seite anzuschauen

URL der/meiner Website, auf der das Problem auftritt: hidden link

Erwartet hatte ich zu sehen: die gleiche Seite in bei hidden link

Stattdessen bekam ich: defekte Dastellung der Seite -> siehe Screenshot

Juli 24, 2019 um 6:58 am #4270795

Bruno Kos
Supporter

Languages: Englisch (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Thank you for contacting WPML support!

I hope you don't mind if I answer in English - if you prefer a German supporter, let me know, but some of our German supporters are on vacation this week so I am stepping in.

I've used Google Translate to translate you issue and I am suspecting that the issue could be related to some of your caching plugins, perhaps Autoptimize or any of its settings? Have a look at what I see in the chrome console log - it would appear that no jQuery is opened on these pages, possibly meaning that there is a JavaScript minification activated maybe not loading it properly? Or CSS minification?

Can you try checking this when only WPML and this theme are activated, or at least try disabling any caching systems you have at the moment?

Regards,
Bruno Kos

Juli 24, 2019 um 7:44 am #4271121

Rainer

Thank you!!!!
Now I deactivated Autoptimize and it works.
You my hero of the day!!!

Please check if you can see an error I think not.

Thank you very much.
Rainer

Juli 24, 2019 um 8:11 am #4271281

Bruno Kos
Supporter

Languages: Englisch (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi Rainer,

I hate to spoil the party, but on my end it is still not resolved for some reason, but I am quite sure that it is a caching thing, because even I am using incognito mode, it is still showing up - Autoptimize 404 url.

Can you perhaps have a look at the caching settings of the plugin, clearing it? I see there's some caching plug-in available for Autoptimize (I haven't worked much with), maybe you can try that as well? Or try disabling JavaScript optimization and clearing the caching then?

I'm checking everything in incognito mode.

Can you try the following as well:
- WPML - > Support -> Troubleshooting:
-- Clear the cache in WPML

Regards,
Bruno Kos

Juli 24, 2019 um 8:24 am #4271515

Rainer

Thank you for your help!!
- I deleted the plugin autoptimize
- I delete the WPML Cache
everything ok?
Rainer
PS. should I deactivate the Plugin Fastest Cache?

Juli 24, 2019 um 8:50 am #4271779

Bruno Kos
Supporter

Languages: Englisch (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Ideally, you should be using only one caching system or if you're using multiple caching plugins, they should not be doing the same thing:
hidden link

According to the image you sent, you are actually using JavaScript minification within both autoptimize and Fastest Cache. Try disabling all of them and then choose the one only.

For example, you can use W3 Total Cache and follow this tutorial:
https://wpml.org/documentation/plugins-compatibility/optimize-multilingual-website-performance-using-w3-total-cache/

Regards,
Bruno Kos

Juli 25, 2019 um 6:29 am #4279527

Rainer

Hello Bruno,

I had a problem with the SSL certificate, it´s solved now.

- Autoptimize is deleted
- Fastest Cache works without javascript

Now I hope everything is fine!?
Rainer

I

Juli 25, 2019 um 7:19 am #4279829

Bruno Kos
Supporter

Languages: Englisch (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Yes, this seems to be working properly now. I see the correct layouts on all the languages (I don't see any content on French, I assume that you have not translated it yet, since I see the note is that the shop is not open for French customers, or you are hiding it somehow).

Regards,
Bruno Kos

Juli 25, 2019 um 7:41 am #4280219

Rainer

My issue is resolved now. Thank you!