Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

This topic contains 50 Antworten, has 2 Teilnehmer.

Last updated by Andreas W. vor 2 Wochen.

Assigned support staff: Andreas W..

Author Artikel
August 12, 2019 um 10:30 am

Rainer

Ich versuche:

URL der/meiner Website, auf der das Problem auftritt:
hidden link

Erwartet hatte ich zu sehen: 5 product categories

Stattdessen bekam ich: 4 product categories

I added an staging environment, I see problem line 137

August 12, 2019 um 10:22 pm #4383851

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Vielen Dank, dass Sie das WPML Support Forum kontaktiert haben.

Das Problem besteht auch dann, wenn alle zusätzlichen Plugin bis auf WPML und WooCommerce deaktiviert sind. Es scheint daher ein Problem zwischen WPML und dem Atomion Theme zu bestehen.

Ich bitte Sie das Theme auf der folgenden Test-Site zu installieren, damit ich es auch einer neuen Installation testen kann. Tritt das Problem hier ebenfalls auf, werde ich es sofort an unser Kompatibitätsteam weiterleiten.

Bitte loggen Sie sich mit einem Klick auf den folgenden Link ein:

hidden link

Hinterlassen Sie mir eine kurze Nachricht, sobald das Theme installiert wurde.

Ich sehe auch, dass die Übersetzung erfolgreich war, was im Menü auf dem Front-End ebenfalls ersichtlich ist. Eventuell wird eine Änderung im Theme nötig sein, um alle Kategorien in der Seitenleiste sichtbar zu machen.

Mit freundlichen Grüßen
Andreas

August 13, 2019 um 10:09 am #4386897

Rainer

... das Theme Atomion und das Child Theme sind installiert.
Gruß nach Peru
Rainer
PS. anderes Thema, andere Frage: wie lösche ich die Mails auf Überetzungsaufträge die es nicht mehr gibt?

August 13, 2019 um 11:12 pm #4391069

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Vielen Dank für Ihre Nachricht.

Ich habe auf der Test-Site einige Produkte und 5 Kategorien erstellt, allerdings tritt das Problem hier nicht auf.

hidden link

Ich verstehe bislang nicht warum das Problem auf Ihrer Website auftaucht, aber mir ist aufgefallen, dass Sie für jede Sprache ein individuelles Widget erstellt haben.

Es wäre hier besser, ein Widget für alle Sprachen zu verwenden. Unter Appearance -> Widgets lässt sich für jedes Widget die Einstellung "Alle Sprache" wählen. Der Widget Titel kann danach auch der String Übersetzung übersetzt werden. Gehen Sie dazu auf WPML -> String Translation und wählen Sie aus dem passenden Dropdown die Domain "Widgets".

Könnten Sie das eventuell einmal testen, oder ich biete an morgen eine Kopie Ihrer Website zu machen und diese einmal lokal zu testen.

Mit freundlichen Grüßen
Andreas

August 14, 2019 um 7:00 am #4392775

Rainer

Hallo Andreas,

ich hatte Dir verschwiegen, dass es seit gestern ein Theme Update auf Atomion 1.1.4 gibt.
Dieses Update habe ich bei resinance.de eingespielt und in Deiner Sandbox installiert.

Danke zur Info wie man Widgets mit WPML richtig erstellt. Das war mir bisher nicht klar. Aber falls es kein Problem ist, dann würde ich die Widgets so lassen (je Spache ein Widgets).

Ich habe die Reihenfolge der Produktkategorien geändert/verschoben, und nochmal mir nochmal ein paar Gedanken gemacht und ein wenig "herumgeklickt".
Als ich Dir dann antworten wollte, habe ich festgestellt die 5 Kategorien sind nun in allen Sprachen vorhanden!!!
#### Problem gelöst! wie auch immer!

Ich werde jetzt nochmal alles testen.
Kannst Du auch noch mal alles testen, wäre nett!
Frage: wie lösche ich die Mails auf Überetzungsaufträge die es nicht mehr gibt?

Gruß
Rainer

August 14, 2019 um 10:47 am #4394269

Rainer

Hallo Andreas,
ein weiteres Problem besteht im EN + FR Shop (DE Shop funktioniert).
Wenn man seine Versandadresse eingeben möchte, wegen der Versandkosten, wird die Adresse nicht "erkannt".
Damit ist kein Versand möglich.
Gruß Rainer

August 14, 2019 um 11:28 pm #4397999

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo Rainer,

Tut mir leid, ich glaube ich hatte vergessen auf die E-Mails einzugehen. Im Grunde sendet Translation Management Benachrichtigungen solange der Übersetzungsjob existiert. Das Problem hierbei ist, dass es momentan noch nicht möglich ist als Translation Manager solche Jobs zu löschen.

Eine Möglichkeit ist, dass der Übersetzer, den Übersetzungsjob, der Ihm zugewiesen muss, abbrechen muss. Der Übersetzungsmanager sollte, den Job dann abschließen beenden können, sollte ich mich hier nicht irren.

Eine andere Möglichkeit, wäre den Beitrag oder die Seite provisorisch zu übersetzten, somit den Job abzuschließen und dann den Beitrag oder die Seite im WordPress Backend komplett zu löschen, also auch aus dem Papierkorb.

Im Grunde legt Translation Management für jede Änderung einen Vorgang an, egal ob Seite, Beitrag, Formular oder Produkt. Diese lassen sich nicht manuell löschen, solange der Inhalt besteht. Das Plugin beruft sich dabei auf das, was in der Datenbank vorhanden ist.

Verstehe ich richtig, dass Sie E-Mails zu Jobs erhalten, die nicht mehr existieren? Als ich gestern nachgesehen hatte, fand ich zwei Jobs mit dem Titel "Line", die auf Übersetzung warten. Gehen Sie auf WPML -> Übersetzungen (Translations) und brechen Sie die Aufträge ab. Sie sollten dann eigentlich keine E-Mails mehr erhalten. Lassen Sie mich wissen, ob es funktioniert hat.

Dass das Problem mit den Kategorien gelöst werden konnte freut mich zu hören. Sollte es wiederholt auftauchen, bitte Bescheid geben.

Zum Versand und den Adressen sehe ich, dass unter den WooCommerce Einstellungen für Versand, die Lieferziele für die Versandzonen DE und EU mit der Versandart Table Rate PRO markiert wurden. Darf ich fragen auf welchem Plugin diese Versandart beruht? Anscheinend besteht das Problem nur auf übersetzen Seiten. Besteht das gleiche Problem, wenn Sie eine andere Versandart hinzufügen?

Mit freundlichen Grüßen
Andreas

August 15, 2019 um 11:56 am #4400607

Rainer

Hallo Andreas,
1. das Abbrechen von Übersetzungsaufträgen, wie soll das funkionieren, ich kann es nicht? siehe Screenshot
(aber im Zweifelsfall nicht so wichtig, denn wenn ich es richtig verstanden habe, gibt es vielleicht in absehbarer Zeit ein Update zum Löschen?)
2. Plugin "Woocommerce Table Rate Shipping Pro" von hidden link, Problem besteht nur auf übersetzen Seiten. Genau das ist das Problem.
Aber Sie haben ja ZUgriff auf die Seite und dies auch schon gesehen, oder?

Können Sie helfen?
Gruß Rainer

August 15, 2019 um 2:57 pm #4401851

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo Rainer,

zu Punkt 1)

Unsere Entwickler arbeiten momentan an einer Lösung für das Problem, wir haben aber in der Zwischenzeit einen Workaround gefunden. Dabei musste nur ein String namens "Local" auf der String-Übersetzung übersetzt werden. Ich habe das jetzt vorgenommen und die beiden Übersetzungsaufträge für "Line" abgebrochen.

Dies sollte auch das Problem mit den E-Mails lösen.

zu Punkt 2)

Bitte installieren Sie das Plugin Woocommerce Table Rate Shipping Pro auf der folgenden Test-Site, damit ich weitere Test durchführen kann.

One Click Login: hidden link

Ich gehe davon aus, dass es sich hier um ein Kompatiblitätsproblem handelt. Sollte das Problem auch auf dieser neuen WordPress Installation auftreten, so werde ich es direkt an unser Kompatibilitätsteam weiterleiten.

Hinterlassen Sie mir bitte eine kurze Nachricht, sobald das Plugin installiert wurde.

Mit freundlichen Grüßen
Andreas

August 18, 2019 um 9:35 am #4411827

Rainer

Hallo Andreas,
1. Übersetzungsaufträge abbrechen: super endlich keine lästigen Mails mehr!
Das gleiche Problem habe ich bei fugenmeister.de/fugenmeister.com.
Kannst Du da auch helfen? Neues Ticket?
2. Plugin Woocommerce Table Rate Shipping Pro: ich habe das Plugin nicht und muss leider auf meinen Kollegen warten. Hoffe dass er am Montag wieder da ist.
Gruß Rainer

August 18, 2019 um 6:40 pm #4412617

Rainer

... Plugin Woocommerce Table Rate Shipping Pro in die Test-Site hochgeladen.
Gruß
Rainer

August 20, 2019 um 1:31 am #4419729

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo Rainer,

Ich komm leider grad erst dazu mir das Plugin anzuschauen und melde mich später dazu bei Dir.

Nur kurz zu fugenmeister.de/fugenmeister.com:

Geh auf String Translation und gib im Textsuchfeld "Local" ein. Markiere auch die beiden Checkboxen für "Exakte Suche" und "Übersetzungen anzeigen".

Es sollte un ein String der zur Domain "translation-management" gehört, angezeigt werden. Einfach 1 zu 1 übersetzen und das Problem mit dem Abbrechen von Übersetzungsaufträgen sollte gelöst sein.

Im Zweifelsfall, hab ich eben die private Box aktiviert, damit Du mir die Zugangsdaten senden kannst.

Mit freundlichen Grüßen
Andreas

August 20, 2019 um 2:28 am #4419967

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo Rainer,

Entschuldige bitte, aber ich hab mich mit dem Table Rate Plugin soweit nicht befasst und erhalte hier überhaupt keine Versandoption. Könntest Du Dir das bitte selbst einmal kurz anschauen? Habe ich etwas übersehen?

One Click Login: hidden link

Mit freundlichen Grüßen
Andreas

August 20, 2019 um 7:07 am
August 20, 2019 um 8:01 am #4421373

Rainer

Hallo Andreas,
Du gehtst zu-> WooCommerce -> Einstellungen -> Versand -> Auswahl "shipping zone UK/Germany" -> shipping method anklicken/edit -> mit der Maus auf "Table Rate pro" dann kannst Du edit auswählen.
Ich habe Standard hinzugefügt.
aktivieren -> enable this shipping method
- Table Rates -> add new rates
*so wie Du es bei Flatrate gemacht hast sieht gut aus.
*ausloggen und auf shop hidden link
ich habe es in dem Sandbox shop DE und EN ausprobiert. Es funktioniert.
Ich habe es auf resinance.de ausprobiert, DE klappt, Fr hat 1x geklappt das zweite Mal nicht mehr, EN klappt nicht.
Gruß Rainer