Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

Heute stehen keine Supporter zur Arbeit im German-Forum zur Verfügung. Sie können gern Tickets erstellen, die wir bearbeiten werden, sobald wir online sind. Vielen Dank für Ihr Verständnis.

This topic contains 50 Antworten, has 2 Teilnehmer.

Last updated by Andreas W. vor 2 Wochen, 5 Tagen.

Assigned support staff: Andreas W..

Autor Beiträge
August 20, 2019 um 9:29 am #4422113

Rainer

... ich war bei fugenmeister.de nicht erfolgreich. Gerade das nächste Email erhalten, siehe Screenshot.
Gruß Rainer

August 20, 2019 um 8:28 pm #4426423

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo Rainer,

Auf der erstellten Test-Site tritt das Problem nicht auf, allerdings läuft diese mit einer anderen URL Struktur.

Ich habe dann eine Kopie erstellt und lokal getestet. Das Problem besteht weiterhin und ich habe keine Fehler gefunden, die auf einen Bug oder Kompatibilitätsproblem hinweisen.

Ich würde gerne eine neue Site erstellen, die mit Domains in verschiedenen Sprachen läuft, damit ich testen kann, ob das Problem auch hier besteht. Ich habe dazu eine Installation auf unserem Test-Server erstellt und bitte Sie sich anzumelden und dann Table Rate PRO Plugin zu installieren.

Ich schicke dazu eine weitere private Nachricht.

In Bezug auf fugenmeister.de ist die URL leider nicht komplett. Konntest Du die Übersetzungsjobs abbrechen?

Mit freundlichen Grüßen
Andreas

August 20, 2019 um 8:29 pm
August 20, 2019 um 9:15 pm #4426589

Rainer

...Plugin Woocommerce table rate pro installiert.
Gruß Rainer

August 20, 2019 um 9:29 pm #4426631

Rainer

fugenmeister.de ... ich habe die Übersetzungsjobs der 3 Produkte abgeschlossen.
Gruß Rainer
PS. ausgerechnet heute beginnt der Inhaber der Seite 3 neue Produkte einzustellen.
Damit habe ich nicht gerechnet 😉

August 21, 2019 um 5:12 pm #4434173

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo Rainer,

Das Problem besteht nicht auf meiner Testserver Installation. Die Versandpreise werden in allen Sprachen korrekt angezeigt.

Ich habe dann festgestellt, dass Sie Permalinks nicht ideal eingestellt waren. Aus Erfahrung ist es hier ratsam die Permalinks für WooCommerce auf Englisch zu belassen und diese in WooCommerce Multilingual -> Store-URLs zu übersetzten. In Deinem Fall habe ich diese Enpoints auch noch zusätzlich über unsere String Translation angepasst (Domain: WP Endpoints).
Dies hat das Problem allerdings auch nicht beheben können.

Ich hatte nun versucht mich per FTP auf Deiner Website anzumelden, um ein wp-debug zu fahren, bevor ich das Problem an unsere Entwickler weiterleiten kann. Allerdings ist das Passwort nicht mehr gültig.

Bitte überprüfe dies einmal und kontaktiere bitte auch deinen Hosting Provider, es sein denn Du weißt selbst wie Du an das error.log des Servers ran kommst. Teil mir bitte mit, ob der Server irgendwelche Fehler meldet. Sollte dort Fehler sein, bitte auch den Host-Anbieter um Rat.

Mit freundlichen Grüßen
Andreas

August 21, 2019 um 6:09 pm #4434491

Rainer

Hallo Andreas,

danke für die perfekte WPML Einstellung!!

Benutzername: u91201221-Klick7
Port 22
Rest ist gleich
Die error.logs liegen auf dem Server in sep. Verzeichnis.

Gruß Rainer

August 21, 2019 um 6:11 pm #4434517

Rainer

Ich hatte vor 3 Wochen mit dem Hoster IONOS (früher 1&1) Kontakt weil der Shop so langsam ist.
Der hat alles geprüft und sagte serverseitig ist alles super.
Problem für die Geschwindigkeit wären die vielen Plugins, WPML, WooCommerce und das Theme Atomion.
Gruß Rainer

August 22, 2019 um 3:46 pm #4440931

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Der Zugriff auf den Server wird mir leider verweigert. Kannst Du da bitte mal nachschauen?

Es wäre sehr hilfreich, wenn Du folgende Änderung in der wp-config.php vornehmen könntest. Sie befindet sich im WordPress Hauptverzeichnis:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

Diese Codes sollten sich direkt vor dem folgenden Kommentar befinden:

/* That's all, stop editing! Happy blogging. */

Lass mich wissen, ob die Änderung vornhemen konntest.

Mit freundlichen Grüßen
Andreas

August 22, 2019 um 4:10 pm #4441475

Rainer

Hallo Andreas,
config.php Änderung per FTP durchgeführt debug, debug display auch auf true gesetzt
->siehe Screenshot.

Gruß Rainer

August 22, 2019 um 4:26 pm #4441611

Rainer

seltsam, wollte mich nochmal einwählen ohne Erfolg. Deshalb Passwort geändert.
Gruß Rainer
PS. display auf false gesetzt wie gewünscht, Du bist der Chef 😉

August 26, 2019 um 9:36 am #4457209

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo Rainer,

Ich habe nochmals verschiedenste Einstellungen und Troubleshoot Optionen probiert, doch konnte keinen Grund für das Problem identifizieren.

Zu meiner Verwunderung wurde auch keinerlei Hinweise auf Probleme oder Fehler in den PHP Dateien angezeigt.

Ich würde Dich bitte deine Live-Site auf unseren Live-Server zu migrieren, damit ich diese an unsere Entwickler weiterleiten kann und sende dazu eine weitere private Nachricht in einem Moment.

Mit freundlichen Grüßen
Andreas

August 26, 2019 um 9:40 am
August 26, 2019 um 11:20 am #4457927

Rainer

erfolgreich migriert
hidden link
Viel Erfolg.
Rainer
PS. vielen Dank für den großen Aufwand!

August 27, 2019 um 2:44 pm #4467797

Andreas W.
Supporter

Languages: Englisch (English ) Spanisch (Español ) Deutsch (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo Rainer,

Entschuldige bitte die Verzögerung.

Ich habe auf der migrierten Website festgestellt, dass das Problem gelöst ist sobald Translation Management deaktiviert wird. Das war mir vorher leider nicht aufgefallen.

Ich würde dies gerne noch ein letztes mal auf der folgenden Test-Site nachstellen, um sicherzugehen, ob wir es hier mit einem Kompatibilitätsproblem oder eine Problem speziell auf deiner Website handelt. Diese Entscheidung ist für den weiteren Prozess maßgebend.

Bitte installiere ein letztes Mal das Plugin Woocommerce Table Rate Shipping Pro auf der folgenden neuen Test-Site und sende mir eine Benachrichtigung.

Entschuldige bitte die Unannehmlichkeiten.

Login:
hidden link

Benutzername:
hello@wpml.org

Passwort:
VKJ3KNhH9v

Mit freundlichen Grüßen
Andreas