Dies ist das technische Support-Forum für WPML - das mehrsprachige WordPress-Plugin.

Mitlesen können alle, doch nur WPML-Kunden können hier Fragen veröffentlichen. Das WPML-Team beantwortet Anfragen im Forum an 6 Tagen pro Woche, 22 Stunden am Tag.

This thread is resolved. Here is a description of the problem and solution.

Problem: WPML, WooCommerce, Sprachen etc. wurden aktualisiert, nun sind im englischsprachigen Teil der Webseite viele Übersetzungen nicht mehr verfügbar. Das fällt besonders auf der Artikeldetailseite sowie im Checkout auf.

Solution:

#1 Ich habe unter WPML -> Theme- und Plugin-Lokalisierung -> die Lokalisierungsoptionen von "Themes und Plugins mit WPMLs String Translation übersetzen und immer .mo-Dateien als Backup laden" auf Themes und Plugins nur mit WPMLs String Translation übersetzen (Keine .mo-Dateien laden)" umgestellt.

#2 Sowie unter der identischen Maske folgende Option deaktiviert: "Angenommen, die Originalsprache aller Strings ist Englisch". Nun sind die beschriebenen Strings wieder auf Englisch. Relevant Documentation: https://wpml.org/de/documentation-3/ratgeber-zum-loslegen/theme-lokalisierung/

This topic contains 7 Antworten, has 2 Teilnehmer.

Last updated by carstenZ-2 vor 3 Monate, 1 Woche.

Assigned support staff: Marcel.

Autor Beiträge
Juli 8, 2019 um 3:56 pm #4164181

carstenZ-2

WPML, WooCommerce, Languages etc. wurden geupdatet, nun sind im englischsprachigen Teil der Webseite viele Übersetzungen nicht mehr verfügbar. Das fällt besonders auf der Artikeldetailseite sowie im Checkout auf. Schaut man im WPML bzw. auch in den String-Übersetzungen, sind die Übersetzungen aber vorhanden.

Es wurden bereits diverse Caches gelöscht, auch die String Übersetzungstabelle neu generiert, leider ohne Erfolg.

URL: hidden link (deutsch) bzw. hidden link (englisch)

Juli 9, 2019 um 10:52 am #4169797

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Carsten,

Vielen Dank, dass Sie den WPML Support kontaktiert haben. Ich konnte das Problem im Checkout sehen.

Ich würde mir das gerne direkt auf Ihrer Seite ansehen. Dazu bräuchte ich bitte temporären Zugriff (WP-Admin und FTP) auf Ihre Seite, vorzugsweise zu einer Test/Staging Seite, an der das Problem nach Möglichkeit repliziert wurde.

Ihre nächste Antwort ist als „Privat“ markiert, dies bedeutet nur Sie und ich haben Zugriff darauf.

❌ Bitte sichern Sie Ihre Datenbank und Website davor ❌

✙ Ich würde außerdem Ihre Erlaubnis benötigen, um Plugins und das Theme zu deaktivieren und erneut zu aktivieren sowie Konfigurationen auf der Seite zu ändern. Dies ist auch der Grund, warum das Backup wirklich wichtig ist.

Freundliche Grüße
Marcel

Juli 10, 2019 um 7:23 am #4176577

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Carsten,

nun funktioniert es.

Ich habe unter WPML -> Theme- und Plugin-Lokalisierung -> die Lokalisierungsoptionen von "Themes und Plugins mit WPMLs String Translation übersetzen und immer .mo-Dateien als Backup laden" auf Themes und Plugins nur mit WPMLs String Translation übersetzen (Keine .mo-Dateien laden)" umgestellt.

Nun sind in der String Translation Tabelle wieder über 45.000 String registriert und nicht nur 185.

Freundliche Grüße
Marcel

Juli 10, 2019 um 3:43 pm #4182255

carstenZ-2

Hallo Marcel,

vielen Dank. In der Tat ist es jetzt nun viel besser.

Mich wundert es allerdings, dass wenn man auswählt, dass WPML auch aus .mo Dateien importieren soll WENIGER Übersetzungen vorhanden sind. Das muss dein ein Bug sein, oder? Und können mit der jetzigen Einstellung nicht auch Übersetzungen fehlen?

Leider sind einzelne Strings immer noch nicht übersetzt. So z.B. "Jetzt kostenpflichtig bestellen" im Checkout. Dort ist für Englisch "Order now!" in der String-Übersetzung hinterlegt. Oder auch "Lieferzeit" und einige mehr.

Bitte nochmal schauen, danke

Juli 10, 2019 um 4:17 pm #4182497

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hallo Carsten,

Ich habe nun unter der identischen Maske folgende Option ebenso deaktiviert: "Angenommen, die Originalsprache aller Strings ist Englisch". Nun sind die beschriebenen Strings wieder auf Englisch.

Einzig der String "Melden Sie sich jetzt für unseren Newsletter an" blieb auf Deutsch. Bitte überprüfen Sie ob der String über getText() registriert ist.

Freundliche Grüße
Marcel

Juli 11, 2019 um 6:02 am #4186225

carstenZ-2

Vielen Dank soweit! Jetzt erscheinen allerdings die deaktivierten Sprachen Französisch und Spanisch wieder. Ich möchte diese Sprachen und alle damit zusammen hängende Übersetzungen am liebsten löschen. Wie mache ich das?

Juli 11, 2019 um 7:18 am #4186629

Marcel
Supporter

Languages: Englisch (English ) Deutsch (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Gerne,

Die 2 Sprachen sind bereits in er WPML Konfiguration deaktiviert. Sie können die Altlasten am einfachsten per SQL bereinigen. (Bitte zuvor unbedingt ein Backup durchführen)

https://wpml.org/forums/topic/delete-old-translations-languages-strings-from-not-anymore-used-plugins/#post-2490498

Freundliche Grüße
Marcel

Juli 11, 2019 um 4:04 pm #4191785

carstenZ-2

My issue is resolved now. Thank you!